Mint Updater error

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Midnighter
Level 6
Level 6
Posts: 1300
Joined: Tue May 22, 2007 1:52 pm
Location: Western Australia

Mint Updater error

Post by Midnighter » Sun Aug 12, 2018 10:52 pm

Hi. Running Mint Cinnamon 18.3, fully updated. When i run update from terminal, i get no errors, but when i run the updater, and it goes to update, i get this error

Code: Select all

E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi'
E: Sub-process returned an error code
Googled the error, but got NO returns. I can just update from terminal, but this error puzzles me. Any suggestions please?
If you accept - and I do - that freedom of speech is important, then you are going to have to defend the indefensible. That means you are going to be defending the right of people to read, or to write, or to say, what you don't say or like or want said.

User avatar
catweazel
Level 17
Level 17
Posts: 7747
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Mint Updater error

Post by catweazel » Sun Aug 12, 2018 11:08 pm

Midnighter wrote:
Sun Aug 12, 2018 10:52 pm
Any suggestions please?
Please post the output of this terminal command:

Code: Select all

sudo appstreamcli refresh
Enclose the results between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
Midnighter
Level 6
Level 6
Posts: 1300
Joined: Tue May 22, 2007 1:52 pm
Location: Western Australia

Re: Mint Updater error

Post by Midnighter » Mon Aug 13, 2018 1:37 am

Code: Select all

sudo appstreamcli refresh
[sudo] password for david: 
AppStream cache update is not necessary.
If you accept - and I do - that freedom of speech is important, then you are going to have to defend the indefensible. That means you are going to be defending the right of people to read, or to write, or to say, what you don't say or like or want said.

User avatar
Midnighter
Level 6
Level 6
Posts: 1300
Joined: Tue May 22, 2007 1:52 pm
Location: Western Australia

Re: Mint Updater error

Post by Midnighter » Mon Aug 13, 2018 2:23 am

Just to clarify, it seems to check all the repos and update the list, then gives that error at the end.
If you accept - and I do - that freedom of speech is important, then you are going to have to defend the indefensible. That means you are going to be defending the right of people to read, or to write, or to say, what you don't say or like or want said.

Post Reply

Return to “Software & Applications”