Max OSX and Mint Cinnamon Shares Not Working

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
stuff4me
Level 1
Level 1
Posts: 1
Joined: Mon Aug 20, 2018 11:14 pm

Max OSX and Mint Cinnamon Shares Not Working

Post by stuff4me » Mon Aug 20, 2018 11:36 pm

I am new to the (pure) Linux world with Linux Mint being my first to start using and learning. I am running into a bit of a problem with a few shares that I have setup on my Linux Mint Cinnamon. I have install samba from the Software Manager and rebooted. I see the share(s) on my MacOSX (High Sierra), but when I try to access them on my Mac, I get the following error:

"The operation can't be completed because the original item for "test" can't be found."

The above happens when the computer is connecting as "guest" user.

When I try to connect as a real user that is on the Linux computer, the login screen on the Mac just shakes as if I got the password or username wrong. At first I tried using the username and password I have setup for the main user I setup from the installation of Linux Mint on the computer. I then created another user on the computer and put them in the sambashare and tried using that user/password on the Mac and the same thing happened.

Other then installing samba from the software manager, is there anything else I need to install? I saw there was also a SAMBA CONFIGURATION program, does this need to be installed as well?

I can ping, vnc, and ssh to the linux computer. I am just scratching my head over this one, as it does seem pretty straight forward from what I have read, but it is not working. Both computers has been rebooted several times.

Any help/guidance would be greatly appreciated.

Thank you.
Josh

altair4
Level 19
Level 19
Posts: 9320
Joined: Tue Feb 03, 2009 10:27 am

Re: Max OSX and Mint Cinnamon Shares Not Working

Post by altair4 » Tue Aug 21, 2018 6:29 am

"The operation can't be completed because the original item for "test" can't be found."
The above happens when the computer is connecting as "guest" user.
Please post the output of the following commands so we can see how you are set up:

Code: Select all

testparm -s

Code: Select all

net usershare info --long
When I try to connect as a real user that is on the Linux computer, the login screen on the Mac just shakes as if I got the password or username wrong. At first I tried using the username and password I have setup for the main user I setup from the installation of Linux Mint on the computer. I then created another user on the computer and put them in the sambashare and tried using that user/password on the Mac and the same thing happened.
The part that you are missing is there are two passwords in Linux: the one you login with on the physical box and the other is for samba. They can be the same password but either way you need to tell samba what password to use. You do that with this command:

Code: Select all

sudo smbpasswd -a altair
Change altair to your Mint login user name.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Other networking topics”