[SOLVED] winbind does not work after reboot on Mint 19 / Ubuntu 18.04

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
Level 15
Level 15
Posts: 5879
Joined: Sun Mar 27, 2016 6:58 pm

[SOLVED] winbind does not work after reboot on Mint 19 / Ubuntu 18.04

Post by rene »

Just installed Mint 19 and noticed a WINS name resolution buglet. I assume this applies to Ubuntu 18.04 as well.

Windows, i.e., NetBIOS, name resolution is on Linux provided for by the "winbindd" daemon, part of the Samba suite. One does not need either of the other two Samba daemons "smbd" and "nmbd" when NetBIOS name resolution is all you need: sudo apt-get install libnss-winbind (which additionally pulls in "winbind" itself) and adding "wins" before "dns" to the "hosts" line of /etc/nsswitch.conf is enough.

While this works fine directly after installation it does no more after reboot due to a systemd unit file dependency issue. The standard /lib/systemd/system/winbind.service orders itself after "network.target" and "nmbd.service" which if you do not in fact have "samba" hence "nmbd.service" installed amounts to "network.target" only. It however needs "network-online.target" -- itself a dependency of "smbd.service" if you do have that installed as well.

You can solve things by copying the unit file to its corresponding directory under /etc and editing it,

Code: Select all

sudo cp /{lib,etc}/systemd/system/winbind.service
xed admin:/etc/systemd/system/winbind.service
to change the line

Code: Select all

After=network.target nmbd.service
to the two lines

Code: Select all

After=network-online.target nmbd.service
After save and reboot you will have NetBIOS name resolution functional without all of the rest of Samba running.

Note that although this fix is not needed when you do have "samba" itself installed the above is still fine also then.

Post Reply

Return to “Other networking topics”