How to play .mkv file?

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: How to play .mkv file?

Post by deepakdeshp » Sun Sep 16, 2018 4:01 pm

gm10 wrote:
Sun Sep 16, 2018 3:30 pm
deepakdeshp wrote:
Sun Sep 16, 2018 3:18 pm
The error when I try running the file is could not determine the type stream I have another file-blueray.mp4 file which has name blueray in the file name. It doesnt run and gives the same error too' I suspect that it is something to do with blueray which is preventing the files to be played
That means that it could not find the required codec to play the file. Try this:

Code: Select all

apt install --reinstall gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly
I tried the command above , the error message is not there now, But both the files do not run. I feel that the chances that 2 different type of files corrupted ,mkv and mp4 should be very less.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

gm10
Level 12
Level 12
Posts: 4149
Joined: Thu Jun 21, 2018 5:11 pm

Re: How to play .mkv file?

Post by gm10 » Sun Sep 16, 2018 4:15 pm

deepakdeshp wrote:
Sun Sep 16, 2018 4:01 pm
I tried the command above , the error message is not there now, But both the files do not run. I feel that the chances that 2 different type of files corrupted ,mkv and mp4 should be very less.
I agree, but with the error message gone that's progress at least. So what does it say instead? Maybe best post the entire output.

Another option is to try another player. Can you try what happens if you install mpv

Code: Select all

apt install mpv
and then play that video of yours:

Code: Select all

mpv Shane.1953.720p.BluRay.X264-AMIABLE.mkv

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: How to play .mkv file?

Post by deepakdeshp » Sun Sep 16, 2018 4:31 pm

gm10 wrote:
Sun Sep 16, 2018 4:15 pm
deepakdeshp wrote:
Sun Sep 16, 2018 4:01 pm
I tried the command above , the error message is not there now, But both the files do not run. I feel that the chances that 2 different type of files corrupted ,mkv and mp4 should be very less.
I agree, but with the error message gone that's progress at least. So what does it say instead? Maybe best post the entire output.

Another option is to try another player. Can you try what happens if you install mpv

Code: Select all

apt install mpv
and then play that video of yours:

Code: Select all

mpv Shane.1953.720p.BluRay.X264-AMIABLE.mkv
That is indeeed progress! When I open the file through mpv .the error is Failed to recognize file format. When I try opening the file through vlc it doesnt give any error at all , while it previously did give error. I also tried with other players on the system but it wasnt successful
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

gm10
Level 12
Level 12
Posts: 4149
Joined: Thu Jun 21, 2018 5:11 pm

Re: How to play .mkv file?

Post by gm10 » Sun Sep 16, 2018 4:44 pm

deepakdeshp wrote:
Sun Sep 16, 2018 4:31 pm
That is indeeed progress! When I open the file through mpv .the error is Failed to recognize file format. When I try opening the file through vlc it doesnt give any error at all , while it previously did give error. I also tried with other players on the system but it wasnt successful
But vlc has to say something?

Try mpv again like this to get some more information:

Code: Select all

mpv -v Shane.1953.720p.BluRay.X264-AMIABLE.mkv

rene
Level 8
Level 8
Posts: 2226
Joined: Sun Mar 27, 2016 6:58 pm

Re: How to play .mkv file?

Post by rene » Sun Sep 16, 2018 5:14 pm

Together with mkvinfo not showing Code IDs I would at this point expect the issue to lie at the container-level. The quite possibly easiest fix would be

Code: Select all

ffmpeg -i Shane.1953.720p.BluRay.X264-AMIABLE.mkv -c copy Fixed.Shane.1953.720p.BluRay.X264-AMIABLE.mkv
If that produces a playable Fixed.Shane.1953.720p.BluRay.X264-AMIABLE.mkv you may of course feel free to mv it over the original. Same thing should be possible with the .mp4.

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: How to play .mkv file?

Post by deepakdeshp » Mon Sep 17, 2018 4:54 am

rene wrote:
Sun Sep 16, 2018 5:14 pm
Together with mkvinfo not showing Code IDs I would at this point expect the issue to lie at the container-level. The quite possibly easiest fix would be

Code: Select all

ffmpeg -i Shane.1953.720p.BluRay.X264-AMIABLE.mkv -c copy Fixed.Shane.1953.720p.BluRay.X264-AMIABLE.mkv
If that produces a playable Fixed.Shane.1953.720p.BluRay.X264-AMIABLE.mkv you may of course feel free to mv it over the original. Same thing should be possible with the .mp4.

Code: Select all

ffmpeg -i Shane.1953.720p.BluRay.X264-AMIABLE.mkv -c test.mkv
ffmpeg version 3.4.4-0ubuntu0.18.04.1 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 7 (Ubuntu 7.3.0-16ubuntu3)
  configuration: --prefix=/usr --extra-version=0ubuntu0.18.04.1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-librsvg --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared
  libavutil      55. 78.100 / 55. 78.100
  libavcodec     57.107.100 / 57.107.100
  libavformat    57. 83.100 / 57. 83.100
  libavdevice    57. 10.100 / 57. 10.100
  libavfilter     6.107.100 /  6.107.100
  libavresample   3.  7.  0 /  3.  7.  0
  libswscale      4.  8.100 /  4.  8.100
  libswresample   2.  9.100 /  2.  9.100
  libpostproc    54.  7.100 / 54.  7.100
Trailing options were found on the commandline.
[matroska,webm @ 0x55d7139c5820] Format matroska,webm detected only with low score of 1, misdetection possible!
[matroska,webm @ 0x55d7139c5820] Read error at pos. 1 (0x1)
[matroska,webm @ 0x55d7139c5820] EBML header parsing failed
Shane.1953.720p.BluRay.X264-AMIABLE.mkv: Invalid data found when processing input


There is an error when I run the command,
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: How to play .mkv file?

Post by deepakdeshp » Mon Sep 17, 2018 4:57 am

gm10 wrote:
Sun Sep 16, 2018 4:44 pm

But vlc has to say something?

Try mpv again like this to get some more information:

Code: Select all

mpv -v Shane.1953.720p.BluRay.X264-AMIABLE.mkv
Vlc doesnt say anything.

Code: Select all

mpv -v Shane.1953.720p.BluRay.X264-AMIABLE.mkv
[cplayer] Command line options: '-v' 'Shane.1953.720p.BluRay.X264-AMIABLE.mkv'
[cplayer] mpv 0.27.2 (C) 2000-2017 mpv/MPlayer/mplayer2 projects
[cplayer]  built on UNKNOWN
[cplayer] ffmpeg library versions:
[cplayer]    libavutil       55.78.100
[cplayer]    libavcodec      57.107.100
[cplayer]    libavformat     57.83.100
[cplayer]    libswscale      4.8.100
[cplayer]    libavfilter     6.107.100
[cplayer]    libswresample   2.9.100
[cplayer] ffmpeg version: 3.4.4-0ubuntu0.18.04.1
[cplayer] 
[cplayer] Configuration: ./waf configure --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu --confdir=/etc/mpv --zshdir=/usr/share/zsh/vendor-completions --enable-cdda --enable-dvdnav --enable-dvdread --enable-encoding --enable-libmpv-shared --enable-libsmbclient --enable-sdl2 --enable-sndio --enable-zsh-comp --disable-build-date --enable-dvbin
[cplayer] List of enabled features: 52arch alsa asm atomics avutil-content-light-level avutil-icc-profile avutil-imgcpy-uc avutil-spherical caca cdda cplayer cplugins cuda-hwaccel debug-build drm dvbin dvdnav dvdread dvdread-common egl-drm egl-helpers egl-x11 encoding fchmod gbm gbm.h gl gl-wayland gl-x11 glibc-thread-name glob glob-posix gnuc iconv is_ffmpeg jack jpeg lcms2 libass libass-osd libav libavcodec libavdevice libbluray libdl libm libmpv-shared librt libsmbclient linux-fstatfs lua nanosleep optimize oss-audio plain-gl posix posix-or-mingw posix-spawn pthreads pulse rubberband sdl2 shm sndio stdatomic termios uchardet vaapi vaapi-drm vaapi-egl vaapi-glx vaapi-hwaccel vaapi-wayland vaapi-x-egl vaapi-x11 vdpau vdpau-gl-x11 vdpau-hwaccel vt.h wayland x11 xv zlib zsh-comp
[global] config path: '' -> '/home/uma/.config/mpv'
[global] config path: 'encoding-profiles.conf' -/-> '/home/uma/.config/mpv/encoding-profiles.conf'
[global] config path: 'encoding-profiles.conf' -/-> '/home/uma/.mpv/encoding-profiles.conf'
[global] config path: 'encoding-profiles.conf' -> '/etc/mpv/encoding-profiles.conf'
[cplayer] Reading config file /etc/mpv/encoding-profiles.conf
[global] config path: 'mpv.conf' -/-> '/home/uma/.config/mpv/mpv.conf'
[global] config path: 'config' -/-> '/home/uma/.config/mpv/config'
[global] config path: 'mpv.conf' -/-> '/home/uma/.mpv/mpv.conf'
[global] config path: 'config' -/-> '/home/uma/.mpv/config'
[global] config path: 'mpv.conf' -> '/etc/mpv/mpv.conf'
[global] config path: 'config' -/-> '/etc/mpv/config'
[cplayer] Reading config file /etc/mpv/mpv.conf
[cplayer] Setting option 'hwdec' = 'vaapi' (flags = 4)
[cplayer] Setting option 'v' = '' (flags = 8)
[global] config path: 'input.conf' -/-> '/home/uma/.config/mpv/input.conf'
[global] config path: 'input.conf' -/-> '/home/uma/.mpv/input.conf'
[global] config path: 'input.conf' -/-> '/etc/mpv/input.conf'
[osc] Loading lua script @osc.lua...
[global] config path: 'scripts' -/-> '/home/uma/.config/mpv/scripts'
[global] config path: 'scripts' -/-> '/home/uma/.mpv/scripts'
[global] config path: 'scripts' -/-> '/etc/mpv/scripts'
[osc] loading mp.defaults
[osc] loading @osc.lua
[global] config path: 'lua-settings/osc.conf' -/-> '/home/uma/.config/mpv/lua-settings/osc.conf'
[global] config path: 'lua-settings/osc.conf' -/-> '/home/uma/.mpv/lua-settings/osc.conf'
[global] config path: 'lua-settings/osc.conf' -/-> '/etc/mpv/lua-settings/osc.conf'
[osc] lua-settings/osc.conf not found. 
[cplayer] Run command: define-section, flags=0, args=[showhide, mouse_move script-binding osc/__keybinding1
[cplayer] mouse_leave script-binding osc/__keybinding2
[cplayer] , force]
[cplayer] Run command: enable-section, flags=0, args=[showhide, allow-hide-cursor+allow-vo-dragging]
[cplayer] Run command: define-section, flags=0, args=[input, mbtn_left script-binding osc/__keybinding3
[cplayer] shift+mbtn_left script-binding osc/__keybinding4
[cplayer] mbtn_right script-binding osc/__keybinding5
[cplayer] wheel_up script-binding osc/__keybinding6
[cplayer] wheel_down script-binding osc/__keybinding7
[cplayer] mbtn_left_dbl ignore
[cplayer] shift+mbtn_left_dbl ignore
[cplayer] mbtn_right_dbl ignore
[cplayer] , force]
[cplayer] Run command: enable-section, flags=0, args=[input, ]
[cplayer] Run command: define-section, flags=0, args=[input_osc, del script-binding osc/__keybinding8
[cplayer] , default]
[cplayer] Run command: enable-section, flags=0, args=[input_osc, allow-hide-cursor+allow-vo-dragging]
[cplayer] Run command: define-section, flags=0, args=[input_forced_osc, , force]
[cplayer] Run command: enable-section, flags=0, args=[input_forced_osc, allow-hide-cursor+allow-vo-dragging]
[cplayer] Done loading @osc.lua.
[ytdl_hook] Loading lua script @ytdl_hook.lua...
[global] config path: 'scripts' -/-> '/home/uma/.config/mpv/scripts'
[global] config path: 'scripts' -/-> '/home/uma/.mpv/scripts'
[global] config path: 'scripts' -/-> '/etc/mpv/scripts'
[ytdl_hook] loading mp.defaults
[cplayer] Run command: disable-section, flags=0, args=[input]
[global] config path: 'fonts' -/-> '/home/uma/.config/mpv/fonts'
[global] config path: 'fonts' -/-> '/home/uma/.mpv/fonts'
[global] config path: 'fonts' -/-> '/etc/mpv/fonts'
[osd/libass] Shaper: FriBidi 0.19.7 (SIMPLE) HarfBuzz-ng 1.7.2 (COMPLEX)
[global] config path: 'subfont.ttf' -/-> '/home/uma/.config/mpv/subfont.ttf'
[global] config path: 'subfont.ttf' -/-> '/home/uma/.mpv/subfont.ttf'
[global] config path: 'subfont.ttf' -/-> '/etc/mpv/subfont.ttf'
[global] config path: 'fonts.conf' -/-> '/home/uma/.config/mpv/fonts.conf'
[global] config path: 'fonts.conf' -/-> '/home/uma/.mpv/fonts.conf'
[global] config path: 'fonts.conf' -/-> '/etc/mpv/fonts.conf'
[osd/libass] Setting up fonts...
[ytdl_hook] loading @ytdl_hook.lua
[global] config path: 'lua-settings/ytdl_hook.conf' -/-> '/home/uma/.config/mpv/lua-settings/ytdl_hook.conf'
[global] config path: 'lua-settings/ytdl_hook.conf' -/-> '/home/uma/.mpv/lua-settings/ytdl_hook.conf'
[global] config path: 'lua-settings/ytdl_hook.conf' -/-> '/etc/mpv/lua-settings/ytdl_hook.conf'
[ytdl_hook] lua-settings/ytdl_hook.conf not found. 
[cplayer] Run command: hook-add, flags=0, args=[on_load, 1, 10]
[cplayer] Run command: hook-add, flags=0, args=[on_preloaded, 2, 10]
[cplayer] Done loading @ytdl_hook.lua.
[global] config path: 'scripts' -/-> '/home/uma/.config/mpv/scripts'
[global] config path: 'scripts' -/-> '/home/uma/.mpv/scripts'
[global] config path: 'scripts' -/-> '/etc/mpv/scripts'
[global] config path: 'watch_later' -> '/home/uma/.config/mpv/watch_later'
[cplayer] Playing: Shane.1953.720p.BluRay.X264-AMIABLE.mkv
[cplayer] Running hook: ytdl_hook/on_load
[osd/libass] Using font provider fontconfig
[osd/libass] Done.
[cplayer] Run command: hook-ack, flags=0, args=[on_load]
[ifo] Opening Shane.1953.720p.BluRay.X264-AMIABLE.mkv
[ifo_dvdnav] Opening Shane.1953.720p.BluRay.X264-AMIABLE.mkv
[bdmv/bluray] Opening Shane.1953.720p.BluRay.X264-AMIABLE.mkv
[file] Opening Shane.1953.720p.BluRay.X264-AMIABLE.mkv
[file] Stream opened successfully.
[cache] Cache size set to 150000 KiB (75000 KiB backbuffer)
[demux] Trying demuxers for level=normal.
[lavf] No format found, try lowering probescore or forcing the format.
[demux] Trying demuxers for level=unsafe.
[lavf] Found 'matroska,webm' at score=1 size=2048.
[lavf] Found 'matroska,webm' at score=1 size=4096.
[lavf] Found 'matroska,webm' at score=1 size=8192.
[lavf] Found 'matroska,webm' at score=1 size=16384.
[lavf] Found 'matroska,webm' at score=1 size=32768.
[lavf] Found 'matroska,webm' at score=1 size=65536.
[lavf] Found 'matroska,webm' at score=1 size=131072.
[lavf] Found 'matroska,webm' at score=1 size=262144.
[lavf] Found 'matroska,webm' at score=1 size=524288.
[lavf] Found 'matroska,webm' at score=1 size=1048576.
[lavf] Found 'matroska,webm' at score=1 size=2097152.
[lavf] Found 'matroska,webm' at score=1 size=2097152.
[lavf] No format found, try lowering probescore or forcing the format.
[cache] Terminating cache...
[cache] Cache exiting...
[cplayer] Opening failed or was aborted: Shane.1953.720p.BluRay.X264-AMIABLE.mkv
[cplayer] finished playback, unrecognized file format (reason 4)
[cplayer] Failed to recognize file format.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

gm10
Level 12
Level 12
Posts: 4149
Joined: Thu Jun 21, 2018 5:11 pm

Re: How to play .mkv file?

Post by gm10 » Mon Sep 17, 2018 5:28 am

deepakdeshp wrote:
Mon Sep 17, 2018 4:57 am
Vlc doesnt say anything.

Code: Select all

[file] Opening Shane.1953.720p.BluRay.X264-AMIABLE.mkv
[file] Stream opened successfully.
[cache] Cache size set to 150000 KiB (75000 KiB backbuffer)
[demux] Trying demuxers for level=normal.
[lavf] No format found, try lowering probescore or forcing the format.
[demux] Trying demuxers for level=unsafe.
[lavf] Found 'matroska,webm' at score=1 size=2048.
[lavf] Found 'matroska,webm' at score=1 size=4096.
[lavf] Found 'matroska,webm' at score=1 size=8192.
[lavf] Found 'matroska,webm' at score=1 size=16384.
[lavf] Found 'matroska,webm' at score=1 size=32768.
[lavf] Found 'matroska,webm' at score=1 size=65536.
[lavf] Found 'matroska,webm' at score=1 size=131072.
[lavf] Found 'matroska,webm' at score=1 size=262144.
[lavf] Found 'matroska,webm' at score=1 size=524288.
[lavf] Found 'matroska,webm' at score=1 size=1048576.
[lavf] Found 'matroska,webm' at score=1 size=2097152.
[lavf] Found 'matroska,webm' at score=1 size=2097152.
[lavf] No format found, try lowering probescore or forcing the format.
Weird about vlc, sounds like it just crashes. You can also run it -v verbose but probably won't make a difference. Based on the mpv output the file is probably corrupt, it cannot parse the mkv header, however, maybe you get lucky and it will play if you start it like this:

Code: Select all

mpv --demuxer-lavf-probescore=1 Shane.1953.720p.BluRay.X264-AMIABLE.mkv
or

Code: Select all

mpv --demuxer=lavf Shane.1953.720p.BluRay.X264-AMIABLE.mkv
or

Code: Select all

mpv --demuxer=mkv Shane.1953.720p.BluRay.X264-AMIABLE.mkv

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: How to play .mkv file?

Post by deepakdeshp » Mon Sep 17, 2018 6:03 am

CODE: SELECT ALL

mpv --demuxer-lavf-probescore=1 Shane.1953.720p.BluRay.X264-AMIABLE.mkv
or
CODE: SELECT ALL

mpv --demuxer=lavf Shane.1953.720p.BluRay.X264-AMIABLE.mkv
or
CODE: SELECT ALL

mpv --demuxer=mkv Shane.1953.720p.BluRay.X264-AMIABLE.mkv
I ran all the three commands but every time the error is Failed to recognize file format.
Can it be something about bluray support as the files have bluray in their name?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

gm10
Level 12
Level 12
Posts: 4149
Joined: Thu Jun 21, 2018 5:11 pm

Re: How to play .mkv file?

Post by gm10 » Mon Sep 17, 2018 6:09 am

deepakdeshp wrote:
Mon Sep 17, 2018 6:03 am
Can it be something about bluray support as the files have bluray in their name?
No, that simply means they were pirated from a blu-ray, it says nothing about the file format. So, either buy/rent the real thing, watch it on a streaming service, or try your luck downloading it again I guess.
Last edited by gm10 on Mon Sep 17, 2018 6:14 am, edited 2 times in total.

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: How to play .mkv file?

Post by deepakdeshp » Mon Sep 17, 2018 6:11 am

gm10 wrote:
Mon Sep 17, 2018 6:09 am
deepakdeshp wrote:
Mon Sep 17, 2018 6:03 am
Can it be something about bluray support as the files have bluray in their name?
No, that simply means they were pirated from a blu-ray. So, either buy/rent the real thing, stream it from Netflix or similar, or try your luck downloading it again I guess.
I will do the same. Thank you so much for helping me patiently for this problem.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

gm10
Level 12
Level 12
Posts: 4149
Joined: Thu Jun 21, 2018 5:11 pm

Re: How to play .mkv file?

Post by gm10 » Mon Sep 17, 2018 6:15 am

I just thought, last try could be to force a generic x264 codec and disable the audio:

Code: Select all

mpv --demuxer=mkv --vd=h264 -no-audio Shane.1953.720p.BluRay.X264-AMIABLE.mkv
I don't think it will work, but at least you tried.

rene
Level 8
Level 8
Posts: 2226
Joined: Sun Mar 27, 2016 6:58 pm

Re: How to play .mkv file?

Post by rene » Mon Sep 17, 2018 8:28 am

deepakdeshp wrote:
Mon Sep 17, 2018 4:54 am

Code: Select all

ffmpeg -i Shane.1953.720p.BluRay.X264-AMIABLE.mkv -c test.mkv
[ ... ]
[matroska,webm @ 0x55d7139c5820] Format matroska,webm detected only with low score of 1, misdetection possible!
[matroska,webm @ 0x55d7139c5820] Read error at pos. 1 (0x1)
[matroska,webm @ 0x55d7139c5820] EBML header parsing failed
Shane.1953.720p.BluRay.X264-AMIABLE.mkv: Invalid data found when processing input
You left out the "copy" bit of "-c copy". However, given the error you get that's not to say it would in fact likely matter any; the file's seemingly simply too damaged.

If you care: note that with Transmission you can redownload/restart the torrent, wait for it to start, pause it, move the file you already have in place of the "Shane.1953.720p.BluRay.X264-AMIABLE.mkv.part" it is now creating, right-click the file in Transmission and choose "Verify Local Data" so as to have only damaged parts redownloaded. Other torrent clients will have similar functionality.

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: How to play .mkv file?

Post by deepakdeshp » Mon Sep 17, 2018 9:14 am

rene wrote:
Mon Sep 17, 2018 8:28 am
deepakdeshp wrote:
Mon Sep 17, 2018 4:54 am

Code: Select all

ffmpeg -i Shane.1953.720p.BluRay.X264-AMIABLE.mkv -c test.mkv
[ ... ]
[matroska,webm @ 0x55d7139c5820] Format matroska,webm detected only with low score of 1, misdetection possible!
[matroska,webm @ 0x55d7139c5820] Read error at pos. 1 (0x1)
[matroska,webm @ 0x55d7139c5820] EBML header parsing failed
Shane.1953.720p.BluRay.X264-AMIABLE.mkv: Invalid data found when processing input
You left out the "copy" bit of "-c copy". However, given the error you get that's not to say it would in fact likely matter any; the file's seemingly simply too damaged.

If you care: note that with Transmission you can redownload/restart the torrent, wait for it to start, pause it, move the file you already have in place of the "Shane.1953.720p.BluRay.X264-AMIABLE.mkv.part" it is now creating, right-click the file in Transmission and choose "Verify Local Data" so as to have only damaged parts redownloaded. Other torrent clients will have similar functionality.
That's a good information about the torrents. Thank you.
I did with copy bit too but the result was the same.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 11
Level 11
Posts: 3856
Joined: Sun Aug 09, 2015 10:00 am

Re: How to play .mkv file?

Post by deepakdeshp » Mon Sep 17, 2018 9:31 am

gm10 wrote:
Mon Sep 17, 2018 6:15 am
I just thought, last try could be to force a generic x264 codec and disable the audio:

Code: Select all

mpv --demuxer=mkv --vd=h264 -no-audio Shane.1953.720p.BluRay.X264-AMIABLE.mkv
I don't think it will work, but at least you tried.
Yes I tried. It says unable to recognize file format
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Sound, Multimedia, & Codecs”