[SOLVED] Unable to install python3-distutils package

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
mkspeter3
Level 1
Level 1
Posts: 4
Joined: Sun Sep 16, 2018 1:04 pm

[SOLVED] Unable to install python3-distutils package

Post by mkspeter3 » Sun Sep 16, 2018 2:10 pm

I'm trying to install python3-distutils but everytime i try installing it i get this error:

Code: Select all

peter@peter ~ $ sudo apt-get install python3-distutils
[sudo] password for peter: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package python3-distutils
I also tried downloading "python3-distutils_3.6.6-1_all.deb" manually and then open it with Package Installer but I was getting:
Error:Dependency is not satisfiable:python3(>=3.6.4-1~)
i have python 2.7.12 and 3.5.2 by default. I also installed python 3.7.0 thinking that the package needed python >= 3.6.4

I'm new to Linux. The system is mint 18 Cinnamon 64 bit.
Last edited by mkspeter3 on Mon Sep 17, 2018 5:34 am, edited 1 time in total.

gm10
Level 9
Level 9
Posts: 2638
Joined: Thu Jun 21, 2018 5:11 pm

Re: Unable to install python3-distutils package

Post by gm10 » Sun Sep 16, 2018 3:17 pm

You tried to install a package from the upcoming Ubuntu 18.10 onto Mint 18, which is based on Ubuntu 16.04. In the Linux world, packages created for a specific distribution and release typically only work for exactly that distribution and release.

However, what are you actually trying to achieve? distutils is pre-installed on Mint 18.

User avatar
Lord Boltar
Level 4
Level 4
Posts: 220
Joined: Mon Jan 09, 2017 7:24 pm

Re: Unable to install python3-distutils package

Post by Lord Boltar » Sun Sep 16, 2018 4:16 pm

The best way is use your Synaptic Package Manager in the search block type in python3-distutils
It should come up - the version that is displayed is generally for the build you have Mint 18.3 or 19 etc this will also get any dependencies needed

gm10
Level 9
Level 9
Posts: 2638
Joined: Thu Jun 21, 2018 5:11 pm

Re: Unable to install python3-distutils package

Post by gm10 » Sun Sep 16, 2018 4:23 pm

Lord Boltar wrote:
Sun Sep 16, 2018 4:16 pm
The best way is use your Synaptic Package Manager in the search block type in python3-distutils
It should come up - the version that is displayed is generally for the build you have Mint 18.3 or 19 etc this will also get any dependencies needed
No, it won't come up. That package does not exist on Mint 18. The distutils module is part of the standard library of python3 on Mint 18, so he's already got it, as I said.

User avatar
Lord Boltar
Level 4
Level 4
Posts: 220
Joined: Mon Jan 09, 2017 7:24 pm

Re: Unable to install python3-distutils package

Post by Lord Boltar » Sun Sep 16, 2018 4:31 pm

gm10 wrote:
Sun Sep 16, 2018 4:23 pm
Lord Boltar wrote:
Sun Sep 16, 2018 4:16 pm
The best way is use your Synaptic Package Manager in the search block type in python3-distutils
It should come up - the version that is displayed is generally for the build you have Mint 18.3 or 19 etc this will also get any dependencies needed
No, it won't come up. That package does not exist on Mint 18. The distutils module is part of the standard library of python3 on Mint 18, so he's already got it, as I said.
That makes sense guess I should have read it more closely

mkspeter3
Level 1
Level 1
Posts: 4
Joined: Sun Sep 16, 2018 1:04 pm

Re: Unable to install python3-distutils package

Post by mkspeter3 » Mon Sep 17, 2018 2:14 am

Thanks for the replies.
gm10 wrote:
Sun Sep 16, 2018 3:17 pm
You tried to install a package from the upcoming Ubuntu 18.10 onto Mint 18, which is based on Ubuntu 16.04. In the Linux world, packages created for a specific distribution and release typically only work for exactly that distribution and release.

However, what are you actually trying to achieve? distutils is pre-installed on Mint 18.
I'm trying to install the latest version of aircrack-ng. On installing its dependencies with this command:

Code: Select all

sudo apt install autoconf automake libpcre3-dev libnl-3-dev libsqlite3-dev libssl-dev ethtool build-essential g++ libnl-genl-3-dev libgcrypt20-dev libtool python3-distutils
I get the following error:

Code: Select all

peter@peter ~ $ sudo apt install autoconf automake libpcre3-dev libnl-3-dev libsqlite3-dev libssl-dev ethtool build-essential g++ libnl-genl-3-dev libgcrypt20-dev libtool python3-distutils
[sudo] password for peter: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package python3-distutils

gm10
Level 9
Level 9
Posts: 2638
Joined: Thu Jun 21, 2018 5:11 pm

Re: Unable to install python3-distutils package

Post by gm10 » Mon Sep 17, 2018 4:29 am

mkspeter3 wrote:
Mon Sep 17, 2018 2:14 am
I'm trying to install the latest version of aircrack-ng. On installing its dependencies with this command:

Code: Select all

sudo apt install autoconf automake libpcre3-dev libnl-3-dev libsqlite3-dev libssl-dev ethtool build-essential g++ libnl-genl-3-dev libgcrypt20-dev libtool python3-distutils
No, you are not, you are apparently trying to compile some version of aircrack-ng but those are certainly not the dependencies of the official source, which is found here:

https://github.com/aircrack-ng/aircrack-ng

Suggest you use that. Careful with random stuff you find on the Internet. There are bad people out there, certainly for software like this... ;)

mkspeter3
Level 1
Level 1
Posts: 4
Joined: Sun Sep 16, 2018 1:04 pm

Re: [SOLVED] Unable to install python3-distutils package

Post by mkspeter3 » Mon Sep 17, 2018 5:36 am

Thank you very much, It has worked.

Post Reply

Return to “Newbie Questions”