Wifi issues with RTL8723BE in linux mint.

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
hchodnekar
Level 1
Level 1
Posts: 9
Joined: Sun Sep 16, 2018 8:00 am

Wifi issues with RTL8723BE in linux mint.

Post by hchodnekar » Sun Sep 16, 2018 2:18 pm

I installed linux mint a couple days ago and was having issues with wifi connectivity. The wifi signal was very slow and wifi connection kept dropping. So, I tried this solution I found on the forums by JeremyB
JeremyB wrote:
Mon May 07, 2018 5:41 am
It likely only has one antenna on a card designed for 2, in terminal

Code: Select all

sudo modprobe -r rtl8723be && sleep 15 && sudo modprobe rtl8723be ant_sel=2
If that fixes the issue do

Code: Select all

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be-ant.conf
This worked and wifi was working fine I had proper connection. But today after reboot the same issues are back again and ant-sel doesn't seem to be working. Wifi works fine in windows 10. How do I get wifi to work properly? I have RTL8723BE wifi card in my laptop.

JeremyB
Level 19
Level 19
Posts: 9038
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by JeremyB » Sun Sep 16, 2018 2:24 pm

Use a kernel older than 4.15.0-33 or you can

Code: Select all

sudo apt-get install dkms git build-essential
git clone https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
With this fix you will need to have Secure Boot disabled in BIOS/UEFI, you can check status by installing mokutil

Code: Select all

sudo apt install moktil && mokutil --sb-state

hchodnekar
Level 1
Level 1
Posts: 9
Joined: Sun Sep 16, 2018 8:00 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by hchodnekar » Sun Sep 16, 2018 2:57 pm

JeremyB wrote:
Sun Sep 16, 2018 2:24 pm
Use a kernel older than 4.15.0-33 or you can

Code: Select all

sudo apt-get install dkms git build-essential
git clone https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
With this fix you will need to have Secure Boot disabled in BIOS/UEFI, you can check status by installing mokutil

Code: Select all

sudo apt install moktil && mokutil --sb-state
Did the or part and now there is no wireless option. :lol:

JeremyB
Level 19
Level 19
Posts: 9038
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by JeremyB » Sun Sep 16, 2018 3:15 pm

What does

Code: Select all

lspci -nnk | grep -iA3 net; mokutil --sb-state
Show us?

hchodnekar
Level 1
Level 1
Posts: 9
Joined: Sun Sep 16, 2018 8:00 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by hchodnekar » Sun Sep 16, 2018 3:31 pm

This.

Code: Select all

08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
	Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
	Kernel modules: rtl8723be
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 0a)
	Subsystem: Hewlett-Packard Company RTL810xE PCI Express Fast Ethernet controller [103c:8096]
	Kernel driver in use: r8169
	Kernel modules: r8169
0a:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 940M] [10de:1347] (rev a2)
SecureBoot disabled

JeremyB
Level 19
Level 19
Posts: 9038
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by JeremyB » Sun Sep 16, 2018 3:56 pm

Post results for

Code: Select all

modinfo rtl8723be

hchodnekar
Level 1
Level 1
Posts: 9
Joined: Sun Sep 16, 2018 8:00 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by hchodnekar » Sun Sep 16, 2018 4:36 pm

Code: Select all

filename:       /lib/modules/4.15.0-34-generic/updates/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw_36.bin
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE	<wlanfae@realtek.com>
author:         PageHe	<page_he@realsil.com.cn>
srcversion:     1B45BB96576F0C4D6674527
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
retpoline:      Y
name:           rtl8723be
vermagic:       4.15.0-34-generic SMP mod_unload 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)

JeremyB
Level 19
Level 19
Posts: 9038
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by JeremyB » Sun Sep 16, 2018 4:44 pm

What happens when you

Code: Select all

sudo modprobe -v rtl8723be

hchodnekar
Level 1
Level 1
Posts: 9
Joined: Sun Sep 16, 2018 8:00 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by hchodnekar » Sun Sep 16, 2018 5:01 pm

Code: Select all

insmod /lib/modules/4.15.0-34-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723com/rtl8723-common.ko 
modprobe: ERROR: could not insert 'rtl8723be': Unknown symbol in module, or unknown parameter (see dmesg)

JeremyB
Level 19
Level 19
Posts: 9038
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by JeremyB » Sun Sep 16, 2018 5:14 pm

Code: Select all

dmesg | grep rtl8723be
Strange as that works in Ubuntu with the same kernel

hchodnekar
Level 1
Level 1
Posts: 9
Joined: Sun Sep 16, 2018 8:00 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by hchodnekar » Sun Sep 16, 2018 5:17 pm

dmesg with rtl8723be returned empty so i did one with rtl only

Code: Select all

[   12.557757] Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[   12.557759] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[   12.578039] rtlwifi: loading out-of-tree module taints kernel.
[   12.578104] rtlwifi: module verification failed: signature and/or required key missing - tainting kernel
[   12.733569] bluetooth hci0: Direct firmware load for rtl_bt/rtl8723b_config.bin failed with error -2
[   12.733576] Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[   12.829482] rtl8723_common: Unknown symbol rtl_fw_page_write (err 0)
[   12.829527] rtl8723_common: Unknown symbol rtl_fill_dummy (err 0)
[ 1634.058330] rtl8723_common: Unknown symbol rtl_fw_page_write (err 0)
[ 1634.058362] rtl8723_common: Unknown symbol rtl_fill_dummy (err 0)
[ 2685.875311] rtl8723_common: Unknown symbol rtl_fw_page_write (err 0)
[ 2685.875343] rtl8723_common: Unknown symbol rtl_fill_dummy (err 0)

JeremyB
Level 19
Level 19
Posts: 9038
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by JeremyB » Sun Sep 16, 2018 5:19 pm

See the wireless script link in my signature and post results

hchodnekar
Level 1
Level 1
Posts: 9
Joined: Sun Sep 16, 2018 8:00 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by hchodnekar » Sun Sep 16, 2018 5:23 pm


JeremyB
Level 19
Level 19
Posts: 9038
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by JeremyB » Sun Sep 16, 2018 5:29 pm

This is strange, do

Code: Select all

cd rtlwifi_new
git status
What does it show?

hchodnekar
Level 1
Level 1
Posts: 9
Joined: Sun Sep 16, 2018 8:00 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by hchodnekar » Sun Sep 16, 2018 5:35 pm

On branch master
Your branch is up to date with 'origin/master'.

nothing to commit, working tree clean

JeremyB
Level 19
Level 19
Posts: 9038
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi issues with RTL8723BE in linux mint.

Post by JeremyB » Sun Sep 16, 2018 6:29 pm

I would use the grub menu at boot advanced options menu to boot into a kernel older than 4.15.0-33 for now

Post Reply

Return to “Wireless”