Error trying to install "fsl" on Mint 19

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
mahshidf
Level 1
Level 1
Posts: 2
Joined: Tue Sep 25, 2018 8:44 am

Error trying to install "fsl" on Mint 19

Post by mahshidf »

Hi,
I am trying to install a software named "fsl" (https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/ ... tion/Linux) on linuxmint 19 but it failed and the error is : "[FAILED] linuxmint x86_64 not supported". However it could be installed on different releases of ubuntu. what do you suggest? is there any way or solution to solve it ? or I should uninstall the mint and reinstall ubuntu?
Best,
Mahshid
Last edited by xenopeek on Tue Sep 25, 2018 10:36 am, edited 1 time in total.
Reason: split from tutorial and moved here; added link to fsl's install instructions
User avatar
catweazel
Level 19
Level 19
Posts: 9884
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Error trying to install "fsl" on Mint 19

Post by catweazel »

mahshidf wrote:
Tue Sep 25, 2018 9:46 am
Hi,
I am trying to install a software named "fsl" (https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/ ... tion/Linux) on linuxmint 19 but it failed and the error is : "[FAILED] linuxmint x86_64 not supported". However it could be installed on different releases of ubuntu. what do you suggest? is there any way or solution to solve it ? or I should uninstall the mint and reinstall ubuntu?
You ought to contact the developers or maintainers.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Error trying to install "fsl" on Mint 19

Post by thx-1138 »

mahshidf wrote:
Tue Sep 25, 2018 9:46 am
.............what do you suggest?
...what i would try...totally untested in this case.
1) ...make a Timeshift snapshot in case things go wrong, as the following is a rather stupid hack...
2) ...modify /etc/os-release & /etc/lsb-release to match Bionic's...first make a backup of them:
sudo mv /etc/os-release /etc/os-release.mint && sudo mv /etc/lsb-release /etc/lsb-release.mint

xed admin:///etc/os-release

Code: Select all

NAME="Ubuntu"
VERSION="18.04.1 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.1 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic
xed admin:///etc/lsb-release

Code: Select all

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"
Now try their installer...
3)...did i mentioned that you should absolutely take a Timeshift snapshot before trying out ugly hacks like that?... :)
mahshidf
Level 1
Level 1
Posts: 2
Joined: Tue Sep 25, 2018 8:44 am

Re: Error trying to install "fsl" on Mint 19

Post by mahshidf »

thx-1138 wrote:
Wed Sep 26, 2018 4:29 am
mahshidf wrote:
Tue Sep 25, 2018 9:46 am
.............what do you suggest?
...what i would try...totally untested in this case.
1) ...make a Timeshift snapshot in case things go wrong, as the following is a rather stupid hack...
2) ...modify /etc/os-release & /etc/lsb-release to match Bionic's...first make a backup of them:
sudo mv /etc/os-release /etc/os-release.mint && sudo mv /etc/lsb-release /etc/lsb-release.mint

xed admin:///etc/os-release

Code: Select all

NAME="Ubuntu"
VERSION="18.04.1 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.1 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic
xed admin:///etc/lsb-release

Code: Select all

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"
Now try their installer...
3)...did i mentioned that you should absolutely take a Timeshift snapshot before trying out ugly hacks like that?... :)


hi,
Thanksssssssssssssssssssssss, it just started working. kiss, :D :wink:
msp
Level 1
Level 1
Posts: 3
Joined: Fri Jun 28, 2019 3:04 pm

Re: Error trying to install "fsl" on Mint 19

Post by msp »

thx-1138 wrote:
Wed Sep 26, 2018 4:29 am
mahshidf wrote:
Tue Sep 25, 2018 9:46 am
.............what do you suggest?
...what i would try...totally untested in this case.
1) ...make a Timeshift snapshot in case things go wrong, as the following is a rather stupid hack...
2) ...modify /etc/os-release & /etc/lsb-release to match Bionic's...first make a backup of them:
sudo mv /etc/os-release /etc/os-release.mint && sudo mv /etc/lsb-release /etc/lsb-release.mint

xed admin:///etc/os-release

Code: Select all

NAME="Ubuntu"
VERSION="18.04.1 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.1 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic
xed admin:///etc/lsb-release

Code: Select all

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"
Now try their installer...
3)...did i mentioned that you should absolutely take a Timeshift snapshot before trying out ugly hacks like that?... :)
Hi, I understand Fedoria is not Debian, but I have this exact same problem on Fedora 29, and I must admit I'm confused by what you mean about making the os-release and lsb-release "match Bionic's". Would you please provide more detail?
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Error trying to install "fsl" on Mint 19

Post by thx-1138 »

msp wrote:
Fri Jun 28, 2019 3:07 pm
............................
Hi, I understand Fedoria is not Debian, but I have this exact same problem on Fedora 29, and I must admit I'm confused by what you mean about making the os-release and lsb-release "match Bionic's". Would you please provide more detail?
...hi msp, the above was meant to 'trick' the installer's script into thinking that Mint was 'vanilla' Ubuntu,
but Fedora is not even binary compatible with such.
I believe something among those lines is what you're looking for (ie. making fsinstaller believe it deals with CentOS).

In case it further helps...examining said json file, leads here currently as the latest CentOS version.
Then follow instructions from the gist above to install further required dependencies there / configure the installation etc...
msp
Level 1
Level 1
Posts: 3
Joined: Fri Jun 28, 2019 3:04 pm

Re: Error trying to install "fsl" on Mint 19

Post by msp »

Hi thx-1138,

Thanks so much for your help. May I ask another question?

I note in the gist you sent instructions to "append this filename (of the latest v. of CentOS) to the string in Settings.mirror and paste into your browser". Can one download binaries using Chrome?
msp
Level 1
Level 1
Posts: 3
Joined: Fri Jun 28, 2019 3:04 pm

Re: Error trying to install "fsl" on Mint 19

Post by msp »

Apologies thx-1138,

When attempting to follow gist instructions using a Python 2.7 interpreter, when I type: with open('~/manifest.json`, 'w') as fp: -the terminal returns Syntax error w a carrot below the "w".

Any additional help would be greatly appreciated.

Thanks again.
User avatar
thx-1138
Level 8
Level 8
Posts: 2114
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Error trying to install "fsl" on Mint 19

Post by thx-1138 »

msp, just grab the latest binaries (3.3gb roughly, browser doesn't matter), then extract the archive / install dependencies etc etc...
Post Reply

Return to “Software & Applications”