Installing Qt5 on linux mint 19 MATE

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
navracer
Level 1
Level 1
Posts: 12
Joined: Thu Aug 02, 2018 4:01 pm

Installing Qt5 on linux mint 19 MATE

Post by navracer » Fri Sep 28, 2018 11:50 am

:?: How do I install this software on my machine ?
Hope you can help :)

User avatar
catweazel
Level 19
Level 19
Posts: 9604
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Installing Qt5 on linux mint 19 MATE

Post by catweazel » Fri Sep 28, 2018 5:53 pm

navracer wrote:
Fri Sep 28, 2018 11:50 am
:?: How do I install this software on my machine ?
./qt-opensource-linux-x64-5.10.1.run

Assuming you've downloaded qt-opensource-linux-x64-5.10.1.run.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

navracer
Level 1
Level 1
Posts: 12
Joined: Thu Aug 02, 2018 4:01 pm

Re: Installing Qt5 on linux mint 19 MATE

Post by navracer » Fri Sep 28, 2018 9:15 pm

Fast reply :)
but my command line knowledge is not that good.
Something to do with sudo chmod maybe ? because ./qt-opensource-linux-x64-5.10.1.run
results in sudo: ./qt-opensource-linux-x64-5.10.1.run : commande introuvable ( French for not found )
Hope you can help

gm10
Level 19
Level 19
Posts: 9288
Joined: Thu Jun 21, 2018 5:11 pm

Re: Installing Qt5 on linux mint 19 MATE

Post by gm10 » Fri Sep 28, 2018 9:30 pm

Considering Qt5 is partially pre-installed on LM19 and the rest is available from the repository, maybe the better question is what you are trying to achieve.

navracer
Level 1
Level 1
Posts: 12
Joined: Thu Aug 02, 2018 4:01 pm

Post by navracer » Sat Sep 29, 2018 10:11 am

Hello,
I still can't get Qt5 installed :
I have the file ./qt-opensource-linux-x64-5.10.1.run in downloads.
this file bash cannot find to run
The software manager starts to install Qt5-default, but results in a broken package and then says it it installed
apt-install qt5 results in cannot find qt5-default :|

User avatar
MtnDewManiac
Level 6
Level 6
Posts: 1456
Joined: Fri Feb 22, 2013 5:18 pm
Location: United States

Re: Installing Qt5 on linux mint 19 MATE

Post by MtnDewManiac » Sun Sep 30, 2018 4:29 am

gm10 wrote:
Fri Sep 28, 2018 9:30 pm
Considering Qt5 is partially pre-installed on LM19 and the rest is available from the repository, maybe the better question is what you are trying to achieve.
Yes. OP, are you trying to install the full development version of QT5 for programming/development use, or... ?

Regards,
MDM
Mint 18 Xfce 4.12.

If guns kill people, then pencils misspell words, cars make people drive drunk, and spoons made Rosie O'Donnell fat.

User avatar
catweazel
Level 19
Level 19
Posts: 9604
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Installing Qt5 on linux mint 19 MATE

Post by catweazel » Sun Sep 30, 2018 4:33 am

gm10 wrote:
Fri Sep 28, 2018 9:30 pm
Considering Qt5 is partially pre-installed on LM19 and the rest is available from the repository, maybe the better question is what you are trying to achieve.
qt-opensource-linux-x64-5.10.1.run installs the complete development environment, and it is completely separate from the Qt installed in the OS. Ne'er the two shall meet, and the version in the repos is old.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
catweazel
Level 19
Level 19
Posts: 9604
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Installing Qt5 on linux mint 19 MATE

Post by catweazel » Sun Sep 30, 2018 5:16 am

navracer wrote:
Fri Sep 28, 2018 9:15 pm
Fast reply :)
but my command line knowledge is not that good.
Something to do with sudo chmod maybe ? because ./qt-opensource-linux-x64-5.10.1.run
results in sudo: ./qt-opensource-linux-x64-5.10.1.run : commande introuvable ( French for not found )
Hope you can help
chmod +x qt-opensource-linux-x64-5.10.1.run

Followed by ./qt-opensource-linux-x64-5.10.1.run

Don't use sudo.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

gm10
Level 19
Level 19
Posts: 9288
Joined: Thu Jun 21, 2018 5:11 pm

Re: Installing Qt5 on linux mint 19 MATE

Post by gm10 » Sun Sep 30, 2018 7:07 am

catweazel wrote:
Sun Sep 30, 2018 4:33 am
gm10 wrote:
Fri Sep 28, 2018 9:30 pm
Considering Qt5 is partially pre-installed on LM19 and the rest is available from the repository, maybe the better question is what you are trying to achieve.
qt-opensource-linux-x64-5.10.1.run installs the complete development environment, and it is completely separate from the Qt installed in the OS. Ne'er the two shall meet, and the version in the repos is old.
I'm fully aware of that, but I have not seen any indication that the OP, who even struggles with basic things like the command line and the executable flag, has any interest in the development environment. For now I consider it very much more likely that they are following some guide for a different release which tells them to install the Qt5 runtimes for some software they want to run. I may be wrong, but that's why I am asking before telling them to install things they may never need. ;)

User avatar
catweazel
Level 19
Level 19
Posts: 9604
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Installing Qt5 on linux mint 19 MATE

Post by catweazel » Sun Sep 30, 2018 7:10 am

gm10 wrote:
Sun Sep 30, 2018 7:07 am
I'm fully aware of that, but I have not seen any indication that the OP, who even struggles with basic things like the command line and the executable flag, has any interest in the development environment. For now I consider it very much more likely that they are following some guide for a different release which tells them to install the Qt5 runtimes for some software they want to run. I may be wrong, but that's why I am asking before telling them to install things they may never need. ;)
I think it's a fair question.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

navracer
Level 1
Level 1
Posts: 12
Joined: Thu Aug 02, 2018 4:01 pm

Re: Installing Qt5 on linux mint 19 MATE

Post by navracer » Sun Sep 30, 2018 10:27 am

Gentlemen, I am absolutely certain that my original question is valid ( wether or not I'm interested in Qt5 ).
Which above subject has NOT been addressed ( whether or not I am struggling with basic questions as executable flags ).
I am still thankful for your responses but I remain completely in the dark about "Installing Qt5 on linux mint 19 MATE".
Have a good continuation. :!:

gm10
Level 19
Level 19
Posts: 9288
Joined: Thu Jun 21, 2018 5:11 pm

Re: Installing Qt5 on linux mint 19 MATE

Post by gm10 » Sun Sep 30, 2018 10:33 am

navracer wrote:
Sun Sep 30, 2018 10:27 am
Gentlemen, I am absolutely certain that my original question is valid ( wether or not I'm interested in Qt5 ).
Which above subject has NOT been addressed ( whether or not I am struggling with basic questions as executable flags ).
I am still thankful for your responses but I remain completely in the dark about "Installing Qt5 on linux mint 19 MATE".
Have a good continuation. :!:
Lol wow. I'll join you in wishing you to "Have a good continuation. :!:", but without my participation. ;)

User avatar
phd21
Level 19
Level 19
Posts: 9321
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Installing Qt5 on linux mint 19 MATE

Post by phd21 » Sun Sep 30, 2018 4:35 pm

Hi navracer,

I just read your post and the good replies to it. Here are my thoughts on this as well.

It is important to know why you want to install QT5, for certain applications, or because you are interested in learning how to develop software in QT5, or Both, etc... Are you getting some message(s) regarding QT5 from something else, if so what?

As was already stated, parts of QT5 are already installed in all editions of Linux Mint versions 19.x and version 18.x as far as I know.

The command below will install all the default QT5 software packages for Linux Mint 19.x based Ubuntu 18.04 Bionic and some development tools, you can also install these from the Software Manager or Synaptic Package Manager (SPM).
qt5-default
qttools5-dev-tools
qttools5-dev

Code: Select all

sudo apt install qt5-default qttools5-dev-tools qttools5-dev
If you want the newest QT5 full development system, then catweazel gave you those good instructions already in his replies.


Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
catweazel
Level 19
Level 19
Posts: 9604
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Installing Qt5 on linux mint 19 MATE

Post by catweazel » Sun Sep 30, 2018 6:45 pm

navracer wrote:
Sun Sep 30, 2018 10:27 am
Which above subject has NOT been addressed...
Oh, dear.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
MtnDewManiac
Level 6
Level 6
Posts: 1456
Joined: Fri Feb 22, 2013 5:18 pm
Location: United States

Re: Installing Qt5 on linux mint 19 MATE

Post by MtnDewManiac » Sun Sep 30, 2018 7:32 pm

LOL, yeah. Sometimes(*), the ability for a person to understand the question that they, themselves, are asking is just as important as being able to understand the answers they are given.

I don't know QT5 from Q-tips, lol, but - as previously mentioned multiple times, some of it will already be present on your system (or should be). Unless it's different than everything else, any other parts of the thing that you end up requiring in order to install something will be considered to be dependencies - and will be automatically installed when you attempt to install something that does require the stuff.

Therefore, for practical purposes, the answer to your question, as it was worded, would appear to be, "You install Linux 19 MATE," :roll: .

IF you are fully cognizant of the above and, therefore, are feeling somewhat frustrated by the answers (which did, after all, address your question), perhaps you would like to help reduce your frustration level by clarifying things just a bit, to wit, asking a different and/or more complete question?

Annoying the very people who are trying to help, by causing them to feel just as frustrated as you do... is not especially likely to be all that helpful. Or so past experience has shown me. It's not like you're communicating with a paid support staff here, lol, otherwise you'd still be responding to the first set of scripts that some mindless droid was reading off of his/her crib sheet. These are just regular users, just like you, who are trying to help you because they're nice people.

(*)Okay, always - but I did not want to cause the OP to feel silly :lol: .

Regards,
MDM
Mint 18 Xfce 4.12.

If guns kill people, then pencils misspell words, cars make people drive drunk, and spoons made Rosie O'Donnell fat.

navracer
Level 1
Level 1
Posts: 12
Joined: Thu Aug 02, 2018 4:01 pm

Re: Installing Qt5 on linux mint 19 MATE

Post by navracer » Sun Sep 30, 2018 10:37 pm

Hello everyone,
first I want to offer my apologies because my posts were grating on some nerves.
I have been using ubuntu since 2009. That said, I've had to rely on some helpful souls to get by.
I'm a hobbyist and I lean heavily on forums to study programming ( also some books ).
I tried first the software manager, then Synaptic and last the command line.
Synaptic says I have this problem : E: Internal Error, No file name for libgl1-mesa-dev:am

Finally the first reply was the suggestion to download : qt-opensource-linux-x64-5.10.1.run
but this file did not have the right permission to execute .
It was all my mistakes and I hope the other helpful people will forgive me :?
navracer
PS Qt5 got installed and I will be dinking in Qt5. Again thanks

chopinregis
Level 1
Level 1
Posts: 2
Joined: Sun Jul 02, 2017 7:56 am
Location: Montreal, QC,
Contact:

Re: Installing Qt5 on linux mint 19 MATE

Post by chopinregis » Sat Feb 09, 2019 10:29 pm

phd21 wrote:
Sun Sep 30, 2018 4:35 pm
Hi navracer,

I just read your post and the good replies to it. Here are my thoughts on this as well.

It is important to know why you want to install QT5, for certain applications, or because you are interested in learning how to develop software in QT5, or Both, etc... Are you getting some message(s) regarding QT5 from something else, if so what?

As was already stated, parts of QT5 are already installed in all editions of Linux Mint versions 19.x and version 18.x as far as I know.

The command below will install all the default QT5 software packages for Linux Mint 19.x based Ubuntu 18.04 Bionic and some development tools, you can also install these from the Software Manager or Synaptic Package Manager (SPM).
qt5-default
qttools5-dev-tools
qttools5-dev

Code: Select all

sudo apt install qt5-default qttools5-dev-tools qttools5-dev
If you want the newest QT5 full development system, then catweazel gave you those good instructions already in his replies.


Hope this helps ...
You are a life saver. I'm on Linux Mint 19.1 Tessa and I've been struggling to get this to work days. Thanks a bunch.

User avatar
phd21
Level 19
Level 19
Posts: 9321
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Installing Qt5 on linux mint 19 MATE

Post by phd21 » Sat Feb 09, 2019 10:32 pm

Hi chopinregis,

You are welcome...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “Software & Applications”