Verifica/Instalar Drivers

Spanish Forum

Moderator: JCSenar

Post Reply
nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Verifica/Instalar Drivers

Post by nekue » Sat Oct 06, 2018 9:41 pm

Hola a todos y gracias por el soporte en español!!

Hace poco instalé LM19 y Ub18.04 y me gustaría tener los controladores correctos en mi sistema...

Aquí las especificaciones de sistema:

Code: Select all

inxi -v7
System:    Host: android Kernel: 4.15.0-36-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Gnome 3.28.3 (Gtk 3.22.30-1ubuntu1) info: gnome-shell dm: gdm3 Distro: Ubuntu 18.04.1 LTS
Machine:   Device: laptop System: ASUSTeK product: X550VX v: 1.0 serial: N/A
           Mobo: ASUSTeK model: X550VX v: 1.0 serial: N/A
           UEFI: American Megatrends v: X550VX.302 date: 05/04/2017
Battery    BAT0: charge: 19.9 Wh 84.2% condition: 23.6/45.0 Wh (52%) volts: 15.0/15.0
           model: ASUSTeK ASUS Li-ion serial: N/A status: Charging cycles: 267
CPU:       Quad core Intel Core i7-6700HQ (-MT-MCP-) arch: Skylake-S rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20736
           clock speeds: min/max: 800/3500 MHz 1: 1533 MHz 2: 2060 MHz 3: 1520 MHz 4: 2260 MHz 5: 1941 MHz
           6: 1866 MHz 7: 1932 MHz 8: 1737 MHz
Memory:    Using dmidecode: root required for dmidecode
Graphics:  Card-1: Intel HD Graphics 530 bus-ID: 00:02.0 chip-ID: 8086:191b
           Card-2: NVIDIA GM107M [GeForce GTX 950M] bus-ID: 01:00.0 chip-ID: 10de:139a
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.05hz
           OpenGL: renderer: GeForce GTX 950M/PCIe/SSE2 version: 4.6.0 NVIDIA 396.54 Direct Render: Yes
Audio:     Card Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a170
           Sound: Advanced Linux Sound Architecture v: k4.15.0-36-generic
Network:   Card-1: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
           driver: rtl8821ae port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8821
           IF: wlp2s0 state: up mac: b0:c0:90:be:5f:cb
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: c000 bus-ID: 03:00.1 chip-ID: 10ec:8168
           IF: enp3s0f1 state: down mac: 70:4d:7b:3e:a0:5c
           WAN IP: 139.47.17.144
           IF: enp3s0f1 ip-v4: N/A ip-v6-link: N/A
           IF: wlp2s0 ip-v4: 192.168.1.2 ip-v6-link: fe80::ebc8:c69a:aa5f:8b74
Drives:    HDD Total Size: 1000.2GB (2.8% used)
           ID-1: /dev/sda model: HGST_HTS541010A9 size: 1000.2GB serial: JD1009DM1YH08H
           Optical-1: /dev/sr0 model: Slimtype DVD A  DA8A6SH rev: GAA2 dev-links: cdrom,cdrw,dvd,dvdrw
           Features: speed: 24x multisession: yes
           audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 47G used: 11G (25%) fs: ext4 dev: /dev/sda6
           label: N/A uuid: d47770a1-22e3-4b7a-8a84-2fcb1409fd56
           ID-2: /media/Datos size: 586G used: 16G (3%) fs: fuseblk dev: /dev/sda5
           label: Datos uuid: 9AC8CD51C8CD2BF7
           ID-3: /boot/efi size: 96M used: 30M (31%) fs: vfat dev: /dev/sda2 label: N/A uuid: E012-66D3
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Unmounted: ID-1: /dev/sda1 size: 0.52G label: Recuperación uuid: 1E4E0DB64E0D87AB
           ID-2: /dev/sda3 size: 0.02G label: N/A uuid: N/A
           ID-3: /dev/sda4 size: 134.53G label: WIndows10 uuid: 0270354E703549A5
Sensors:   System Temperatures: cpu: 56.0C mobo: N/A gpu: 0.0:53C
           Fan Speeds (in rpm): cpu: 2900
Info:      Processes: 241 Uptime: 1:01 Memory: 1392.8/7872.3MB Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191 running in gnome-terminal-) inxi: 2.3.56 
Decirme si necesito mostraros algún comando mas y si tengo todo correcto.

Creo que los controladores de la gráfica Intel no están instalados...

Conseguí instalar los controladores Nvidia, pero resulta que mi portátil también tiene grafica Intel (una es dedicada y la otra integrada), pero noto que se calienta en exceso el portátil y he leído que podría usar las dos gráficas para un menor consumo pero no sé como llevarlo acabo.

Gracias y un saludo

nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Re: Verifica/Instalar Drivers

Post by nekue » Sun Oct 07, 2018 7:08 am

Perdón por el doble post, pero no queria liaros con lo dicho arriba...
He instalado los repositorios MESA para tener los controladores Intel con estos comandos:

Code: Select all

sudo add-apt-repository ppa:ubuntu-x-swat/updates
sudo apt update
sudo apt full-upgrade
he reiniciado y por lo visto algo a hecho, porque ahora si tengo el controlador grafico de intel pero sikiero volver a utilizar el de nvidia ¿Cómo lo hago?... por que ahora parece que no lo está utilizando...

Code: Select all

nvidia-smi 
Sun Oct  7 12:01:14 2018       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 396.54                 Driver Version: 396.54                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 950M    Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   50C    P0    N/A /  N/A |      0MiB /  2004MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|  No running processes found                                                 |
+-----------------------------------------------------------------------------+
Os muestro un glxinfo para mostraros datos:

Code: Select all

glxinfo | grep "OpenGL"
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 530 (Skylake GT2) 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.1.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.1.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 18.1.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
También os muestro el log del "X Xorg.0.log" con los datos relativos a la gráfica "nvidia":

Code: Select all

grep -i nvidia /var/log/Xorg.0.log
[  8073.583] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules"
[  8073.583] (**) OutputClass "Nvidia Prime" ModulePath extended to "/x86_64-linux-gnu/nvidia/xorg,/usr/lib/x86_64-linux-gnu/nvidia/xorg,/usr/lib/xorg/modules"
[  8073.583] (**) OutputClass "Nvidia Prime" setting /dev/dri/card1 as PrimaryGPU
[  8073.585] (II) Loading /usr/lib/x86_64-linux-gnu/nvidia/xorg/libglx.so
[  8073.591] (II) Module glx: vendor="NVIDIA Corporation"
[  8073.591] (II) NVIDIA GLX Module  396.54  Tue Aug 14 22:37:05 PDT 2018
[  8073.591] (II) Applying OutputClass "nvidia" to /dev/dri/card1
[  8073.591] 	loading driver: nvidia
[  8073.591] (II) Applying OutputClass "Nvidia Prime" to /dev/dri/card1
[  8073.591] 	loading driver: nvidia
[  8073.591] (==) Matched nvidia as autoconfigured driver 0
[  8073.591] (==) Matched nvidia as autoconfigured driver 1
[  8073.591] (II) LoadModule: "nvidia"
[  8073.591] (II) Loading /usr/lib/x86_64-linux-gnu/nvidia/xorg/nvidia_drv.so
[  8073.592] (II) Module nvidia: vendor="NVIDIA Corporation"
[  8073.593] (II) NVIDIA dlloader X Driver  396.54  Tue Aug 14 22:15:03 PDT 2018
[  8073.593] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  8073.593] (II) NOUVEAU driver for NVIDIA chipset families :
[  8073.598] (II) NVIDIA(0): Creating default Display subsection in Screen section
[  8073.598] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  8073.598] (==) NVIDIA(0): RGB weight 888
[  8073.598] (==) NVIDIA(0): Default visual is TrueColor
[  8073.598] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  8073.598] (II) Applying OutputClass "nvidia" options to /dev/dri/card1
[  8073.598] (II) Applying OutputClass "Nvidia Prime" options to /dev/dri/card1
[  8073.598] (**) NVIDIA(0): Option "AllowEmptyInitialConfiguration"
[  8073.598] (**) NVIDIA(0): Option "IgnoreDisplayDevices" "CRT"
[  8073.598] (**) NVIDIA(0): Enabling 2D acceleration
[  8073.810] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 950M (GM107-A) at PCI:1:0:0 (GPU-0)
[  8073.810] (--) NVIDIA(0): Memory: 2097152 kBytes
[  8073.810] (--) NVIDIA(0): VideoBIOS: 82.07.9b.00.f1
[  8073.810] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  8073.810] (II) NVIDIA(0): Validated MetaModes:
[  8073.810] (II) NVIDIA(0):     "NULL"
[  8073.810] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[  8073.810] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[  8073.810] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[  8073.970] (II) NVIDIA: Using 6144.00 MB of virtual memory for indirect memory
[  8073.970] (II) NVIDIA:     access.
[  8074.007] (II) NVIDIA(0): Setting mode "NULL"
[  8074.010] (==) NVIDIA(0): Disabling shared memory pixmaps
[  8074.010] (==) NVIDIA(0): Backing store enabled
[  8074.010] (==) NVIDIA(0): Silken mouse enabled
[  8074.011] (==) NVIDIA(0): DPMS enabled
[  8074.011] (WW) NVIDIA(0): Option "PrimaryGPU" is not used
[  8074.011] (II) NVIDIA(0): [DRI2] Setup complete
[  8074.011] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[ 31772.285] (II) NVIDIA(GPU-0): Deleting GPU-0
Y el log con los datos relativos a "intel" (aunque parece que no revelan nada):

Code: Select all

grep -i intel /var/log/Xorg.0.log
[  8074.380] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event12)
[  8074.380] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event13)
[  8074.381] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=7 (/dev/input/event14)
[  8074.381] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=8 (/dev/input/event15)
[  8074.381] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=9 (/dev/input/event16)
[  8074.382] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=10 (/dev/input/event17)
Ahora datos relativos al kernel con dmesg para la grafica "nvidia":

Code: Select all

dmesg -T | grep -i nvidia
[dom oct  7 11:17:48 2018] nvidia: loading out-of-tree module taints kernel.
[dom oct  7 11:17:48 2018] nvidia: module license 'NVIDIA' taints kernel.
[dom oct  7 11:17:48 2018] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[dom oct  7 11:17:48 2018] nvidia-nvlink: Nvlink Core is being initialized, major device number 242
[dom oct  7 11:17:48 2018] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  396.54  Tue Aug 14 19:02:34 PDT 2018 (using threaded interrupts)
[dom oct  7 11:17:48 2018] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  396.54  Tue Aug 14 23:08:44 PDT 2018
[dom oct  7 11:17:48 2018] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[dom oct  7 11:17:48 2018] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
[dom oct  7 11:18:08 2018] nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 239
Y este es el dmesg de la "intel":

Code: Select all

dmesg -T | grep -i intel
[dom oct  7 11:17:47 2018]   Intel GenuineIntel
[dom oct  7 11:17:47 2018] ACPI: LPIT 0x000000007662F538 000094 (v01 INTEL  SKL      00000000 MSFT 0000005F)
[dom oct  7 11:17:47 2018] ACPI: SSDT 0x000000007662F5D0 000248 (v02 INTEL  sensrhub 00000000 INTL 20120913)
[dom oct  7 11:17:47 2018] ACPI: DBGP 0x000000007662F818 000034 (v01 INTEL           00000000 MSFT 0000005F)
[dom oct  7 11:17:47 2018] ACPI: DBG2 0x000000007662F850 000054 (v00 INTEL           00000000 MSFT 0000005F)
[dom oct  7 11:17:47 2018] ACPI: DMAR 0x000000007663AC88 0000A8 (v01 INTEL  SKL      00000001 INTL 00000001)
[dom oct  7 11:17:47 2018] Reserving Intel graphics memory at 0x0000000079000000-0x000000007affffff
[dom oct  7 11:17:47 2018] smpboot: CPU0: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz (family: 0x6, model: 0x5e, stepping: 0x3)
[dom oct  7 11:17:47 2018] Performance Events: PEBS fmt3+, Skylake events, 32-deep LBR, full-width counters, Intel PMU driver.
[dom oct  7 11:17:48 2018] intel_idle: MWAIT substates: 0x11142120
[dom oct  7 11:17:48 2018] intel_idle: v0.4.1 model 0x5E
[dom oct  7 11:17:48 2018] intel_idle: lapic_timer_reliable_states 0xffffffff
[dom oct  7 11:17:48 2018] intel_pstate: Intel P-state driver initializing
[dom oct  7 11:17:48 2018] intel_pstate: HWP enabled
[dom oct  7 11:17:48 2018] intel_pmc_core:  initialized
[dom oct  7 11:17:48 2018] fb: switching to inteldrmfb from EFI VGA
[dom oct  7 11:17:48 2018] fbcon: inteldrmfb (fb0) is primary device
[dom oct  7 11:17:48 2018] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[dom oct  7 11:18:09 2018] intel_rapl: Found RAPL domain package
[dom oct  7 11:18:09 2018] intel_rapl: Found RAPL domain core
[dom oct  7 11:18:09 2018] intel_rapl: Found RAPL domain uncore
[dom oct  7 11:18:09 2018] intel_rapl: Found RAPL domain dram
[dom oct  7 11:18:10 2018] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[dom oct  7 11:18:10 2018] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input19
[dom oct  7 11:18:10 2018] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input20
[dom oct  7 11:18:10 2018] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input21
[dom oct  7 11:18:10 2018] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input22
[dom oct  7 11:18:10 2018] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input23
[dom oct  7 11:18:10 2018] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input24
Ahora el modinfo para consultar el módulo de "nvidia" cargado en el kernel:

Code: Select all

modinfo nvidia
filename:       /lib/modules/4.15.0-36-generic/updates/dkms/nvidia.ko
alias:          char-major-195-*
version:        396.54
supported:      external
license:        NVIDIA
srcversion:     CDDF5F6229BAD6360A195B1
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        ipmi_msghandler
retpoline:      Y
name:           nvidia
vermagic:       4.15.0-36-generic SMP mod_unload 
signat:         PKCS#7
signer:         
sig_key:        
sig_hashalgo:   md4
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_CheckPCIConfigSpace:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_UseThreadedInterrupts:int
parm:           NVreg_EnableStreamMemOPs:int
parm:           NVreg_EnableBacklightHandler:int
parm:           NVreg_EnableUserNUMAManagement:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_IgnoreMMIOCheck:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RegistryDwordsPerDevice:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_AssignGpus:charp
Y este es el de "intel": (aunque este no muestra nada)

Code: Select all

modinfo intel
modinfo: ERROR: Module intel not found.
Ahora un lspci para mostraros todo lo que hay en mi portátil:

Code: Select all

lspci
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #3 (rev f1)
00:1c.3 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #4 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
03:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
Aquí un poco mas abreviado:

Code: Select all

lspci | grep -i VGA|3D
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
Ahora os enseño el hardware de las gráficas, en mi caso tengo dos, una integrada y otra dedicada, con el comando "lshw":

Code: Select all

lshw -class display
  *-display                 
       descripción: 3D controller
       producto: GM107M [GeForce GTX 950M]
       fabricante: NVIDIA Corporation
       id físico: 0
       información del bus: pci@0000:01:00.0
       versión: a2
       anchura: 64 bits
       reloj: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list rom
       configuración: driver=nvidia latency=0
       recursos: irq:16 memoria:de000000-deffffff memoria:c0000000-cfffffff memoria:d0000000-d1ffffff ioport:e000(size=128) memoria:df000000-df07ffff
  *-display
       descripción: VGA compatible controller
       producto: HD Graphics 530
       fabricante: Intel Corporation
       id físico: 2
       información del bus: pci@0000:00:02.0
       versión: 06
       anchura: 64 bits
       reloj: 33MHz
       capacidades: pciexpress msi pm vga_controller bus_master cap_list rom
       configuración: driver=i915 latency=0
       recursos: irq:126 memoria:dd000000-ddffffff memoria:b0000000-bfffffff ioport:f000(size=64) memoria:c0000-dffff
Cuando intento entrar en la aplicación de nvidia-settings no se abre (la pensaba utilizar para cambiar de grafica en el apartado "nvidia PRIME", donde antes si me dejaba escoger que grafica usar, pero ahora no me funciona... en la ultima imagen esta lo que me refiero)

Code: Select all

nvidia-settings -q all

ERROR: Unable to find display on any available system



ERROR: Unable to find display on any available system
Creo que ahora la he liado al no poder cambiar a la nvidia que yo diria que es mejor que la intel, ustedes que opinan, que deberia hacer para solucionar esto, o algo estoy haciendo mal...
Image
Gracias

EDITO1: al final nose que he echo que me a tocado reinstalar el sistema de nuevo desde cero (Creo que a sido por instala bublebee) ya que se quedaba en pantalla en negro... y ni con nomodeset iniciaba... vuelvo a estar como al principio (He instalado el ultimo driver de nvidia 396.54 + cuda 9.2)... la verdad no sé que más probar...

EDITO2: He encontrado esto navegando por googlle https://github.com/timrichardson/Prime-Ubuntu-18.04 pero no se ingles y el traductor no lo traduce muy bien que digamos, si alguien me puede ayudar con las traducciones y en definitiva que pasos debo seguir? no tengo claro si debo instalar esto: lightdm y esto bbswitch (aunque en los repos me aparece como: bbswitch-dkms) :( :oops:

User avatar
JOPETA
Level 13
Level 13
Posts: 4912
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Verifica/Instalar Drivers

Post by JOPETA » Sun Oct 07, 2018 5:03 pm

Puedes cambiar la gráfica de inicio con sudo prime-select intel (o nvidia) y reiniciar ya que parece que con cerrar y abrir de nuevo sesión no basta en esta edición. Si tienes suerte y esto funciona, por ahora es lo que hay.

En el lanzamiento de Ubuntu bionic ya se avisa de esta "novedad" de no tener la posibilidad de cambiar la gráfica de forma sencilla en portátiles con gráfica híbridas (primus/uptimus) como es tu caso como si es posible en Ubuntu 16.04 y anteriores (LM 17 y LM 18 ). Los cambios anunciados son la consecuencias de otros muchos que están pasando desapercibidos y que agravan bastante la situación en distros derivadas como mint. Esto demuestra que no todos los cambios son siempre para bien y lo más nuevo no es siempre para mejor para algunos. :roll:

Las soluciones provisionales son a costa de introducir inestabilidad, además no són extrapolables los resultados a Mint que sigue con el lightdm (con lo bien que se estaba con mdm).

Tienes mas información sobre estos problemas y su origen aquí. Si no te satisfacen los ajustes que pudieras hacer en el rendimiento de la Nvidia con Nvidia Setting Manager (nvidia-setting) para evitar en calentamiento excesivo y abusos de consumo de energía o el cambio de gráfica de la forma indicada te supone un incordío siempre puedes instalar Linux Mint 18 (aún tendrás dos años para esperar a ver cómo se resuelve el embrollo o si Ubuntu pega un nuevo bandazo esta vez en la dirección correcta). :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Re: Verifica/Instalar Drivers

Post by nekue » Sun Oct 07, 2018 5:25 pm

JOPETA wrote:
Sun Oct 07, 2018 5:03 pm
Tienes mas información sobre estos problemas y su origen aquí. Si no te satisfacen los ajustes que puedieras hacer en el rendimiento de la Nvidia con Nvidia Setting Manager (nvidia-setting) para evitar en calentamiento excesivo y abusos de consumo de energía y el cambio de gráfica de la forma indicada te supone un incordío siempre puedes instalar Linux Mint 18.
Gracias @JOPETA.. es justo lo que comento en EDIT2...
Estoy ahora mismo como-loco traduciendo todo lo del Git de @TimRichardson...
Ya he instalado:

Code: Select all

# (para comprobar los Watios que me consume el PC= casi 20W... con razón duraba tan poco la batería y se calentaba tanto)
sudo apt install powertop
sudo apt install rustc cargo
sudo apt install bbswitch-dkms
# (Este sustituye al gmk3... resulta que no mata bien la nvidia al cambiar a la intel)
sudo apt install lightdm
# (lo que no tengo muy claro es si es persistente o debo activarlo cada vez que quiera cambiar de GPU) Con este comoando:
sudo dpkg-reconfigure lightdm
sudo apt install libcurl4-gnutls-dev libexpat1-dev gettext libz-dev libssl-dev git
# (esto para clonar GITs, otra cosa que no savia hacer :D )
sudo git clone https://github.com/timrichardson/Prime-Ubuntu-18.04.git
cd prime_socket/src/ (después de extraer)
sudo make install (Y esto para instalarlo)
Bueno hasta aquí he llegado... algo estoy aprendiendo con cada ensayo/error... ya he perdido la cuenta de las veces que me ha tocado reinstalar de cero por no estar seguro, y en mi vida he googleado tanto :P

Si me puedes decir que tal voy.... mientras seguiré con el google traductor jajaja
Gracias!

nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Re: Verifica/Instalar Drivers

Post by nekue » Sun Oct 07, 2018 8:56 pm

Algo no va bien, según lo que entendí cuando ejecuto este comando "sudo prime-select intel" debería de reiniciarse, pero mire lo que me sale por pantalla...
me dice que el archivo nvidia-fallback.service no existe...

Code: Select all

sudo prime-select intel
Info: selecting the intel profile
Created symlink /etc/systemd/system/multi-user.target.wants/nvidia-prime-boot.service → /etc/systemd/system/nvidia-prime-boot.service.
Failed to disable unit: Unit file nvidia-fallback.service does not exist.
También lo he buscado por internet, lo he creado con nano en /etc/systemd/system/multi-user.target.wants/nvidia-fallback.service y he agregado estas lineas:

Code: Select all

[Unit]
Description=Fallback to nouveau if nvidia did not load
After=akmods.service dkms.service
Before=display-manager.service
ConditionPathExists=!/sys/module/nvidia

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=-/sbin/modprobe nouveau

[Install]
WantedBy=multi-user.target
Pero tampoco funciona

Si modifico el archivo "prime-select" y comento las lineas donde llama a ese servicio, ¿funcionará?

User avatar
JOPETA
Level 13
Level 13
Posts: 4912
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Verifica/Instalar Drivers

Post by JOPETA » Mon Oct 08, 2018 2:39 am

El post de respuesta lo empecé con tu primer post. pero decidí no participar ya que las pruebas que realicé en verano no me condujeron a nada quizás porque mientras las realizaba Ubuntu seguía introduciendo continua modificaciones en kernel y controladores y librearías de las que se habla en los enlaces (el primero es de hace poco días).

No he tendio tiempo ni lo tendré por ahora para ver el detalle (bbswitch-dkms es uno de los implicados que al fin y al cabo resulta incompaible/ineficaz con el nuevo kernel/sistema, si instalas el semiprivativo de nvidia debes evitar la carga del nouveau por el kernel...) de lo que haces pero procura no actuar al modo Ubuntu . Por ejemplo, el repositorio adicional X Swat (la alternativa es la ppa graphics drivers, aunque tambien ha cambiado en los últimos meses no reeemplaza otras librerías del sistema), los backported y los upgrades, te van a conducir a un sistema cada vez más inestable, con roturas del servidor X, reisntalacion de controloladores,..reinstalción del sistema (hasta tres llegó mi paciencia con LM 19).

Si intervine fué para decir en resumen no te vuelvas loco e instala LM 18 donde todo funciona como debiera incluso con le kernel 4.15 por ahora, hasta que se vayan clarificando las cosas. Si por el contrario tu objetivo es la pelea con la adversidad seguro que aprenderás un montón con esto, pero por ahora olvidate de que tu sistema optimus funcione como en ediciones anteriores, si es ese tu objetivo, y confórmate con que funcione el prime y no rompas el servidor X al cambiar de gráficas... :wink:
nekue wrote:
Sun Oct 07, 2018 8:56 pm
Algo no va bien, según lo que entendí cuando ejecuto este comando "sudo prime-select intel" debería de reiniciarse, pero mire lo que me sale por pantalla...
me dice que el archivo nvidia-fallback.service no existe...
No, debes reiniciar tu (sudo reboot). Por otra parte (los otros cambios y systemd que para mi sigue siendo territorio hostil) tal vez te debería haber remitido directamente al ejecutable sudo /usr/bin/prime-select intel.
Last edited by JOPETA on Mon Oct 08, 2018 3:05 am, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Re: Verifica/Instalar Drivers

Post by nekue » Mon Oct 08, 2018 3:03 am

JOPETA wrote:
Mon Oct 08, 2018 2:39 am
Si intervine fué para decir en resumen no te vuelvas loco e instala LM 18 donde todo funciona como debiera incluso con le kernel 4.15 por ahora, hasta que se vayan clarificando las cosas. Si por el contrario tu objetivo es la pelea con la adversidad seguro que aprenderás un montón con esto :wink:
Me a vuelto a crashear el sistema, cada vez que intento iniciar se bloquea en el inicio, y el ventilador se pone a tope.... :(
Pues si tienes toda la razón, pero es que me da coraje que veo que gente que tiene casi las mismas caracteristicas de pc y que yo no pueda con ello, sigo todo al pie de la letra pero nada... ya sólo me queda el enlace ese que comentas de @Alberto (creo recordar que se llama)....
Pero sí quizas la opción seria instalar LM18 :?
JOPETA wrote:
Mon Oct 08, 2018 2:39 am
No he tendio tiempo ni lo tendré para ver el detalle de lo que haces pero procura no actuar al modo Ubuntu . Por ejemplo, el repositorio adicional X Swat (la alternativa es la ppa graphics drivers, aunque tambien ha cambiado en los últimos meses no reeemplaza otras librerías del sistema), los backported y los upgrades, te van a conducir a un sistema cada vez más inestable, con roturas del servidor X, reisntalacion de controloladores,..reinstalción del sistema (hasta tres llegó mi paciencia con LM 19).
Pero sigo pensando que los repositorios de ubuntu no instalan el driver de Intel, y creo que el motivo del crasheo es ese..
Con los repos de x.swat me los instalo a la primera...
Nose estoy pensando que igual lo estoy haciendo al reves, siempre instalo los Nvidia primero nada mas entrar a la distro y estoy por hacer un ultimo intento y empezar por los de Intel pero como digo no me los instala los repos de ubuntu (o yo nose como hacerlo, siempre tengo iniciar con nomodeset)...
Esta será mi ultima bala en el cargador ;)
Si tienes algun consejo, bienvenido sea ehh, o lo mas seguro es que esté equivocado...
Gracias
JOPETA wrote:
Mon Oct 08, 2018 2:39 am
No, debes reiniciar tu (sudo reboot). Por otra parte (los otros cambios y systemd que para mi sigue siendo territorio hostil)
Pues segun el video que hay en Github, a él se le reinicia solo, es mas esta escrito en el readme...
No, hay el fallo fue mio desde el principio, tenia los drivers nvidia 396.xx(beta)... cuando en el readme dice claramente 390.87, por eso no aparecia ese servicio...
JOPETA wrote:
Mon Oct 08, 2018 2:39 am
tal vez te debería haber remitido directamente al ejecutable sudo /usr/bin/prime-select intel.
Y este comando fue el ultimo que probé y se fué todo al carajo, no, ese tuyo, no... (este: sudo /usr/local/bin/prime-select intel, aquí si se reinició solo, pero ya no volvió a iniciar, y estuve provando mas cosas desde el "modo seguro?", pero nada, no pude rescatarlo, soy un poco malillo en consola) :P
Hay dos prime-select, el que está en /usr/local/bin va primero en la orden de ejecucion que el que está en: /usr/bin/ (tambien lo dice en readme)

User avatar
JOPETA
Level 13
Level 13
Posts: 4912
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Verifica/Instalar Drivers

Post by JOPETA » Mon Oct 08, 2018 3:25 am

Creía que sólo estabas traduciendo el github no que lo habías seguido ya, como te digo no he tenido tiempo ni ganas para profundizar como aconsajarlo sólo era otra lectura recomendada. :(
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Re: Verifica/Instalar Drivers

Post by nekue » Mon Oct 08, 2018 4:01 am

JOPETA wrote:
Mon Oct 08, 2018 3:25 am
Creía que sólo estabas traduciendo el github no que lo habías seguido ya, como te digo no he tenido tiempo ni ganas para profundizar como aconsajarlo sólo era otra lectura recomendada. :(
Si pero hay algo que se me escapa, no es posible... aquí hay muchos que han conseguido reducir el consumo de bateria un 50% o más.. y siguen los pasos de @TimRicharson, el mismo que el del git...
¿Es posible que sea por el kernel?

nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Re: Verifica/Instalar Drivers

Post by nekue » Mon Oct 08, 2018 4:21 am

Edit: mira este video, el tio tiene casicasi las mismas caracteristicas que el mio y le funciona de P.M. (Lo que pasa que habla ingles y no me entero de ná)

Y este otro es el que te hecomentado antes del reinicio automatico (bueno mas bien es un cierre de sesión)...

@JOPETA tu tambien tienes portatil hibrido? que SO tienes? cuales son la caracteristicas de tu PC?

User avatar
JOPETA
Level 13
Level 13
Posts: 4912
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Verifica/Instalar Drivers

Post by JOPETA » Mon Oct 08, 2018 5:54 am

Ten cuidado con las comparaciones aunque basado en Ubuntu tu tienes instalado Linux Mint 19 y las diferencias sin ser muy llamativas existen (y espero que siga siendo así por mucho tiempo). Todos estos remedios provisionales son para Ubuntu bionic y está por demostrar que sean extensibles a otros distros derivadas (no sólo Mint) ) y por saber a costa de qué.

Evidentemente si tengo un portátil i7 con gráfica híbrida intel-nvidia (si no podría ni opinar) mas antiguo que el tuyo, y mientras pueda seguiré con LM 17.3 como entorno productivo. Tengo una instalación LM 18.3 que me empeño en que se comporte de la forma más aproximada a LM 17 (igual ya no va a ser posible :( ..es lo que tienen estos nuevo tiempos) para cuando llegue el momento de decidir. Cuando tuve tiempo trapichee con LM 19 y lo seguiŕe haciendo caundo disponga de tiempo, ahora no. :wink:
Last edited by JOPETA on Tue Oct 09, 2018 10:01 am, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Re: Verifica/Instalar Drivers

Post by nekue » Tue Oct 09, 2018 4:57 am

He vuelto ha hacer una instalación limpia de ubuntu18.04 (aunque comentan que tambien funcionaria en LM19. Podrias probarlo tu tambien y asi me echas un cable).. y si tenias razon en lo referente a que el controlador intel 'i915 ya viene en el kernel de ubuntu...
Mi fallo estaba en que no llegue a modificar el grub añadiendo la linea nouveau.modeset=0...(crees que deberia añadir algun dato mas a esta linea?)
Me dispongo ahora a instalar los drivers nvidia 390 como se dice en el git. No me quiero arriesgar a instalar los 396 y que me pase como antes. Es mas dicen de instalarlos de la forma estandar desde software y actualizaciones/controladores adicionales...

vaca
Level 1
Level 1
Posts: 22
Joined: Thu Jul 12, 2018 1:58 pm
Location: Barcelona Spain

Re: Verifica/Instalar Drivers

Post by vaca » Tue Oct 09, 2018 8:50 pm

Olvida a el sr richardson , no funciona probe el invento en su momento y fue la razón principal de volver a la estabilidad de mint 18.3 , otro consejo que te doy la hibrida nuestra intel nvidia tendrá un comportamiento excelente con el kernel 4,13,45 que es el que uso.
Según he leido del boletin mensual de clement ceo de mint se piensa implementar una solución a los drivers de la serie 340 en adelante en 18,1 en noviembre si todo va bien.
Con mint 18.3 y teniendo presente que hasta 2021 hay soporte sin prisas , valoro más la estabilidad y si comparamos yo lo veo solido como una roca , y es fantastico asi que bionic puede esperar , por lo menos dos revisiones que pulan sus fallos , lo positivo aqui es que no tienes que actualizar a la ruleta rusa de windows ,asi que no te agobies tanto por mint 19
saludos !

nekue
Level 1
Level 1
Posts: 13
Joined: Fri Oct 05, 2018 11:29 am

Re: Verifica/Instalar Drivers

Post by nekue » Wed Oct 10, 2018 2:13 am

Me puse en contacto con Tim y me dijo que para hacerlo funcionar no importa el kernel pero si la version del driver nvidia (390)....
Lo que influye en el buen funcionamiento es el lightdm que al parecer solo funciona en xubuntu (o bien instalar xubuntu-desktop al ubuntu18.04)...
Asi que me estoy descargando xubuntu y realizar las pruebas desde él... aunque como digo, él me dice que funciona el LM19. Tal vez lo intente primero en este...

Post Reply

Return to “Español (Spanish)”