[RESOLVED N/A] Previously unknown errors with a fresh reinstall.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
ineuw
Level 4
Level 4
Posts: 276
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

[RESOLVED N/A] Previously unknown errors with a fresh reinstall.

Post by ineuw » Tue Oct 09, 2018 9:05 pm

Code: Select all

inxi -F
System:    Host: mint Kernel: 4.15.0-20-generic x86_64 bits: 64 Desktop: Cinnamon 3.8.8
           Distro: Linux Mint 19 Tara
Machine:   Device: unknown System: Apple product: MacBook3 1 v: 1.0 serial: N/A
           Mobo: Apple model: Mac-F22788C8 v: PVT serial: N/A
           UEFI: Apple v: MB31.88Z.008E.B02.0803051832 date: 03/05/08
Battery    BAT0: charge: 50.3 Wh 100.0% condition: 50.3/54.0 Wh (93%)
CPU:       Dual core Intel Core2 Duo T7300 (-MCP-) cache: 4096 KB
           clock speeds: max: 2000 MHz 1: 1197 MHz 2: 1165 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x800@59.91hz
           OpenGL: renderer: Mesa DRI Intel 965GM version: 2.1 Mesa 18.0.0-rc5
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Broadcom Limited BCM4321 802.11a/b/g/n driver: b43-pci-bridge
           IF: N/A state: N/A mac: N/A
           Card-2: Marvell 88E8058 PCI-E Gigabit Ethernet Controller driver: sky2
           IF: ens5 state: up speed: 100 Mbps duplex: full mac: 00:1b:63:ae:20:32
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/sda model: Patriot_Torch_LE size: 120.0GB
           ID-2: USB /dev/sdb model: USB_Flash_Disk size: 16.1GB
Partition: ID-1: / size: 2.0G used: 37M (2%) fs: overlay dev: N/A
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 56.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 167 Uptime: 9 min Memory: 563.2/3925.9MB Client: Shell (bash) inxi: 2.3.56
The following scenario applies to either LM 18.3 or LM 19 Cinnamon. Please see the uploaded images linked at the end of the post.

Tried to clean install Linux Mint 19, then reverted to LM 18.3 and then back again to LM19 on a Macbook 3.1 which previously had LM 18.3, but now I ran into major problems.

The identical errors in the photos show up after Grub booting, either from the USB live stick, or after normal installation and reboot. It takes 5 minutes to get to the Grub screen, then 5 minutes to reach the login screen, and then another 5 minutes to reach the desktop. Once it reaches the desktop, everything works like a charm.

I verified the media with the Grub menu option and everything was OK.
Also noticed that the intel-microcode was included in the post-installation updates.
After searching the web, the errors seem to point to a video problem.

bootup messages
http://www.picfront.org/d/9OGv

shutdown messages
http://www.picfront.org/d/9OGw
Last edited by ineuw on Fri Dec 07, 2018 1:44 pm, edited 1 time in total.
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit with LM 18 Cinnamon 4gb RAM.

caracal478
Level 1
Level 1
Posts: 31
Joined: Sun Feb 25, 2018 8:37 pm

Re: Previously unknown errors with a fresh reinstall.

Post by caracal478 » Wed Oct 10, 2018 2:22 am

definitely a video problem (unfortunately still way too common a problem on linux).

what video driver are you using ? the output of lsmod might be helpful.

if you are using the chipset specific driver the key is to NOT use it. unfortunately how exactly to do that escapes me at the moment.

perhaps someone else can chime in .

User avatar
ineuw
Level 4
Level 4
Posts: 276
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

Re: Previously unknown errors with a fresh reinstall.

Post by ineuw » Wed Oct 10, 2018 5:55 pm

Code: Select all

ineuw@lm19lt64:~$ lsmod
Module                  Size  Used by
uas                    24576  0
usb_storage            69632  1 uas
rfcomm                 77824  4
bnep                   20480  2
btusb                  45056  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                16384  1 btusb
bluetooth             548864  31 btrtl,btintel,bnep,btbcm,rfcomm,btusb
ecdh_generic           24576  1 bluetooth
appletouch             20480  0
snd_hda_codec_realtek   106496  1
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_intel          40960  5
snd_hda_codec         126976  3 snd_hda_intel,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           81920  4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              20480  1 snd_hda_codec
snd_pcm                98304  4 snd_hda_intel,snd_hda_codec,snd_hda_core
applesmc               20480  0
nls_iso8859_1          16384  1
input_polldev          16384  1 applesmc
coretemp               16384  0
kvm_intel             212992  0
kvm                   598016  1 kvm_intel
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
irqbypass              16384  1 kvm
snd_rawmidi            32768  1 snd_seq_midi
isight_firmware        16384  0
input_leds             16384  0
joydev                 24576  0
snd_seq                65536  2 snd_seq_midi_event,snd_seq_midi
b43                   413696  0
bcma                   57344  1 b43
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
lpc_ich                24576  0
mac80211              778240  1 b43
snd_timer              32768  2 snd_seq,snd_pcm
snd                    81920  19 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_rawmidi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm
cfg80211              622592  2 b43,mac80211
shpchp                 36864  0
sbs                    20480  0
soundcore              16384  1 snd
sbshc                  16384  1 sbs
apple_bl               16384  0
mac_hid                16384  0
sch_fq_codel           20480  2
parport_pc             36864  0
ppdev                  20480  0
lp                     20480  0
parport                49152  3 lp,parport_pc,ppdev
ip_tables              28672  0
x_tables               40960  1 ip_tables
autofs4                40960  2
btrfs                1126400  0
xor                    24576  1 btrfs
zstd_compress         163840  1 btrfs
raid6_pq              114688  1 btrfs
dm_mirror              24576  0
dm_region_hash         20480  1 dm_mirror
dm_log                 20480  2 dm_mirror,dm_region_hash
hid_apple              16384  0
hid_appleir            16384  0
hid_generic            16384  0
usbhid                 49152  0
hid                   118784  4 hid_appleir,hid_generic,usbhid,hid_apple
ssb_hcd                16384  0
i915                 1617920  12
ahci                   36864  3
i2c_algo_bit           16384  1 i915
libahci                32768  1 ahci
drm_kms_helper        172032  1 i915
pata_acpi              16384  0
firewire_ohci          40960  0
sky2                   61440  0
ssb                    57344  2 b43,ssb_hcd
firewire_core          65536  1 firewire_ohci
syscopyarea            16384  1 drm_kms_helper
crc_itu_t              16384  1 firewire_core
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
drm                   401408  5 i915,drm_kms_helper
video                  45056  1 i915
Although I don't know if I am doing it correctly, I will use blacklist the video module, and see what happens.
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit with LM 18 Cinnamon 4gb RAM.

caracal478
Level 1
Level 1
Posts: 31
Joined: Sun Feb 25, 2018 8:37 pm

Re: Previously unknown errors with a fresh reinstall.

Post by caracal478 » Wed Oct 10, 2018 11:29 pm

that's weird.
i915 is an intel generic chipset driver, I think.

what does your driver manager tell you ?

what you want to do is force the vesa driver. if you blacklist the i915 that might happen.

do you know about the "E" trick on the boot screen ? that will get you into the boot parameters where you can add the blacklist.

be forewarned, i've been trying to blacklist the i915 on my machine and the kernel seems to ignore it.

there doesn't seem to be any easy way to force the vesa driver to be used.

User avatar
ineuw
Level 4
Level 4
Posts: 276
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

Re: Previously unknown errors with a fresh reinstall.

Post by ineuw » Thu Oct 11, 2018 6:58 am

caracal478 wrote:
Wed Oct 10, 2018 11:29 pm
that's weird.
i915 is an intel generic chipset driver, I think.
According to inxi, my video is Intel Mobile GM965/GL960 Integrated Graphics Controller vesa and that is what I was focusing on, although I admit I am not sure if I am doing things right. Blacklisted "video", but it didn't do anything. I will now try to blacklist i915.
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit with LM 18 Cinnamon 4gb RAM.

User avatar
ineuw
Level 4
Level 4
Posts: 276
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

Re: Previously unknown errors with a fresh reinstall.

Post by ineuw » Fri Oct 12, 2018 6:24 pm

ineuw wrote:
Thu Oct 11, 2018 6:58 am
caracal478 wrote:
Wed Oct 10, 2018 11:29 pm
that's weird.
i915 is an intel generic chipset driver, I think.
According to inxi, my video is Intel Mobile GM965/GL960 Integrated Graphics Controller vesa and that is what I was focusing on, although I admit I am not sure if I am doing things right. Blacklisted "video", but it didn't do anything. I will now try to blacklist i915.
@caracal478, My previous post displayed my ignorance about blacklisting. Blacklisted the i915 with no effect of any kind. Is there a log that would record a problem related to this in particular?
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit with LM 18 Cinnamon 4gb RAM.

User avatar
thx-1138
Level 6
Level 6
Posts: 1288
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Previously unknown errors with a fresh reinstall.

Post by thx-1138 » Sat Oct 13, 2018 1:21 am

ineuw wrote:
Fri Oct 12, 2018 6:24 pm
............................
...try this, see if it makes any difference... (do not blacklist the i915 / video modules etc)...

User avatar
ineuw
Level 4
Level 4
Posts: 276
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

Re: Previously unknown errors with a fresh reinstall.

Post by ineuw » Sat Oct 13, 2018 7:28 pm

thx-1138 wrote:
Sat Oct 13, 2018 1:21 am
try this, see if it makes any difference... (do not blacklist the i915 / video modules etc)...
thx-1138, thanks for the link. The symptoms are identical and followed the instructions to the letter, but unfortunately, it didn't help. First removed the entry I added to the black list, and removed xserver-xorg-video-intel, rebooted and there was no change. Then modified the GRUB_CMDLINE_LINUX_DEFAULT="video=SVIDEO-1:d quiet splash", updated the grub and rebooted with no effect. If you or anyone can think of some other solution, it would be much appreciated.
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit with LM 18 Cinnamon 4gb RAM.

User avatar
ineuw
Level 4
Level 4
Posts: 276
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

Re: Previously unknown errors with a fresh reinstall.

Post by ineuw » Sat Oct 13, 2018 8:02 pm

Looked through the logs, and found the following which may provide a clue. The log is /var/log/gpu-manager.log.

Code: Select all

log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /run/u-d-c-nvidia-was-loaded file
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/4.15.0-36-generic/updates/dkms
Looking for amdgpu modules in /lib/modules/4.15.0-36-generic/updates/dkms
Is nvidia loaded? no
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? no
Is nvidia kernel module available? no
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:2a02
BusID "PCI:0@0:2:0"
Is boot vga? yes
Vendor/Device Id: 8086:2a03
BusID "PCI:0@0:2:1"
Is boot vga? no
Error: can't access /sys/bus/pci/devices/0000:00:02.1/driver
The device is not bound to any driver.
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card0", driven by "i915"
Found "/dev/dri/card0", driven by "i915"
output 0:
	card0-LVDS-1
Number of connected outputs for /dev/dri/card0: 1
Does it require offloading? yes
last cards number = 2
Has amd? no
Has intel? yes
Has nvidia? no
How many cards? 2
Has the system changed? No
Intel IGP detected
Desktop system detected
or laptop with open drivers
Nothing to do
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit with LM 18 Cinnamon 4gb RAM.

User avatar
thx-1138
Level 6
Level 6
Posts: 1288
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Previously unknown errors with a fresh reinstall.

Post by thx-1138 » Sun Oct 14, 2018 1:06 am

...ineuw, i'm afraid i don't personally have any other suggestions to make. The gory details for GM965 are here & here.

It does strike me as odd though that this happens now under both 18.3 & 19 - especially if you say it worked fine with 18.3 before.
But that's also an older Macbook, and i don't have any experience at all with such (ie. how they handle UEFI / Secure Boot etc...)

Mute Ant
Level 13
Level 13
Posts: 4948
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: Previously unknown errors with a fresh reinstall.

Post by Mute Ant » Sun Oct 14, 2018 1:15 am

"...this happens now under both 18.3 & 19..." New defect with more than one OS? Perhaps the common factor is a difficult-to-read hard drive? The accessory Disks can do a read-only benchmark for you.
Tommy reports the scan of zircon and opal storage is complete. When shall we go today?

User avatar
ineuw
Level 4
Level 4
Posts: 276
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

Re: Previously unknown errors with a fresh reinstall.

Post by ineuw » Sun Oct 14, 2018 2:28 am

Thanks to you both for the input. The drive is a 120Gb Patriot SSD. It is about two years old and it might be the reason so I will check this with the Disks software. LM18.3 worked well but that was a gradual update from previous LM18 version and not a clean install. So, perhaps it had an older driver which was not changed(?). Also, I haven't used the laptop for 60 days (according the last backup which I deleted) because I started with LM19, then went back to LM18.3 and then again LM19.
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit with LM 18 Cinnamon 4gb RAM.

Post Reply

Return to “Newbie Questions”