ALC256 sound - Internal Microphone not working on Linux (Mint and Ubuntu)

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 6:17 pm

MrEen wrote:
Fri Oct 12, 2018 6:04 pm
I have to head out for a bit. Check your BIOS as well to make sure the sound input isn't disabled or something.
I believe that wouldn't matter cause it works in windows

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Fri Oct 12, 2018 6:18 pm

MrEen wrote:
Fri Oct 12, 2018 5:50 pm
Give this a try. apt install alsa-tools-gui and once it's installed hdajackretask

I'm guessing you will not have to select the device in the box in the upper left, but wherever it shows the internal mic, click on Override then test the mic. If that works, click on Install boot override.

I don't have experience using that app, so if it doesn't work you might try searching for how others got things working with it.
I tried overriding the offline connections and that also didn't help

User avatar
MrEen
Level 6
Level 6
Posts: 1487
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Fri Oct 12, 2018 7:01 pm

That dmesg is your issue. I have no idea why it keeps trying to reconfigure over and over. Let's see if a sound related reload will help. Do each of these one at a time:

Code: Select all

apt remove --purge alsa-base pulseaudio
apt install alsa-base pulseaudio
sudo alsa force-reload
Then test your sound. If no difference, boot into Windows and do a complete shutdown, wait 10 seconds then power back up and boot to Mint.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 3:22 am

Sadly nothing has changed, microphone still doesn't work.

I have done this and when I try the old command I get this result
IMG_20181013_083638-min(1).jpeg
Because I got this message and had to reinstall cinnamon.
screenshot_1.png
this is the new output
Last edited by esc11 on Sat Oct 13, 2018 7:18 am, edited 1 time in total.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 7:01 am

Now bluetooth devices won't connect.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 7:39 am

https://ubuntuforums.org/showthread.php?t=2348201

It seems like they found a package which solved the same problem with Asus and Ubuntu

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 7:58 am

So I just ran a Ubuntu live usb and I have the same situation with Ubuntu.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 9:00 am

So after adding this line of code
"options snd-hda-intel model=laptop-dmic,headset-mic"
to /etc/modprobe.d/alsa-base.conf
my internal mic is being recognised and I can edit the levels in alsamixer.
However it still doesn't work and a headset mic is not recognised.
screenshot_2.png
But still not recognised in this app

User avatar
MrEen
Level 6
Level 6
Posts: 1487
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Sat Oct 13, 2018 12:01 pm

I see in the new dmesg output that you did the DKMS Alsa upgrade. Is that something you just tried or had you done it before starting this thread?

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 4:35 pm

It's something that I tried.
I will be honest though. Now my sound is now working properly between internal speakers and headphones, my bluetooth is not working and my microphone is still not working.
I have literally tried everything on all the google searches that are in some way connected with this problem and none of them have brought me to a solution.
I now know that many people who have a Realtek ALC256 sound card seem to have this problem.
Some people get a solution but it never seems to be a complete solution.
I guess the problem is too small for Linux (Mint, Ubuntu and Mate) to take note of and fix this Bug.

User avatar
sebastjava
Level 2
Level 2
Posts: 65
Joined: Wed Jun 28, 2017 8:01 pm
Location: Montréal
Contact:

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by sebastjava » Sat Oct 13, 2018 4:41 pm

I had a somewhat similar problem more than a year ago. I am not sure i remember precisely what happened. It was about the internal speaker. You may say it is not the same thing but it had to do with this /etc/modprobe.d/alsa-base.conf file, just like yours.

I made a short tutorial about fixing the speaker on my Asus notebook: Asus Eee Pc X101ch and Intel Atom: Fix The Speaker And Microphone!

Yes, again, i know it is not the same computer nor the same problem. But you might find it interesting to know what i experienced before. I started to have a clue about what was going on when i "messed" with the alsamixer controls. I turned up some "headphone" volume control and... the speaker was not dead anymore. So i knew there was some output "jack" mismatch... So i searched through the web and tried a few different options snd-hda-intel (...) at the end of this /etc/modprobe.d/alsa-base.conf file. Restarting the computer for each new test. I solved the problem this way.

Mr Een seems to know much more about this than i do, but just in case you got no other thing to try, and lots a spare time, i suggest you keep trying different options with this /etc/modprobe.d/alsa-base.conf file. And, at the same time, try messing around with all the controls in alsamixer... If you find something interesting, then we could later make permanent changes in alsamixer.

I will be offline for a while. Let us know if you find something...
Last edited by sebastjava on Sun Oct 14, 2018 11:54 am, edited 2 times in total.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 4:43 pm

https://bugs.launchpad.net/ubuntu/+sour ... ug/1596381
Here there are various people who had the same problem and some reported that "comment 8" solved there problem.
(for those who face this problem, hopefully this helps)

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 4:46 pm

sebastjava wrote:
Sat Oct 13, 2018 4:41 pm
I had a somewhat similar problem more than a year ago. I am not sure i remember precisely what happened. It was about the internal speaker. You may say it is not the same thing but it had to do with this /etc/modprobe.d/alsa-base.conf file, just like yours.

I made a short tutorial about fixing the speaker on my Asus notebook: viewtopic.php?f=42&t=264417

Yes, again, i know it is not the same computer nor the same problem. But you might find it interesting to know what i experienced before. I started to have a clue about what was going on when i "messed" with the alsamixer controls. I turned up some "headphone" volume control and... the speaker was not dead anymore. So i knew there was some output "jack" mismatch... So i searched through the web and tried a few different options snd-hda-intel (...) at the end of this /etc/modprobe.d/alsa-base.conf file. Restarting the computer for each new test.

Mr Een seems to know much more about this than i do, but just in case you got no other thing to try, and lots a spare time, i suggest you keep trying different options with this /etc/modprobe.d/alsa-base.conf file. And, at the same time, try messing around with all the controls in alsamixer... If you find something interesting, then we could later make permanent changes in alsamixer.

I will be offline for a while. Let us know if you find something...
Thanks, I will keep trying.

User avatar
MrEen
Level 6
Level 6
Posts: 1487
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Sat Oct 13, 2018 5:45 pm

Hi esc11.

Let's see the output of inxi -Fxz please. I missed that this was a new computer and I suspect your hardware might actually be a little too new to get things working correctly at this time.

@sebastjava
I have only learned what I know by trying to help people here with lots of Googling and am somewhat amazed at the myriad of sound issues/resolutions there are in Linux. When I started doing this, I didn't even have any trouble with my sound, although that has changed at times, all self-induced.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 6:30 pm

System: Host: Esc Kernel: 4.18.14-041814-generic x86_64
bits: 64 gcc: 8.2.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: laptop System: Acer product: Swift SF314-54 v: V1.07 serial: N/A
Mobo: KBL model: Strongbow_KL v: V1.07 serial: N/A
UEFI: Insyde v: V1.07 date: 05/25/2018
Battery BAT0: charge: 10.3 Wh 20.3% condition: 50.5/50.8 Wh (99%)
model: SMP-SDI3320 AC14B7K status: Discharging
CPU: Quad core Intel Core i5-8250U (-MT-MCP-)
arch: Kaby Lake rev.10 cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 14400
clock speeds: max: 3400 MHz 1: 799 MHz 2: 799 MHz 3: 800 MHz
4: 800 MHz 5: 800 MHz 6: 800 MHz 7: 800 MHz 8: 800 MHz
Graphics: Card: Intel UHD Graphics 620 bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.01hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio: Card Intel Sunrise Point-LP HD Audio
driver: snd_hda_intel bus-ID: 00:1f.3
Sound: ALSA v: k4.18.14-041814-generic
Network: Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Drives: HDD Total Size: 1014.6GB (1.6% used)
ID-1: /dev/nvme0n1 model: INTEL_MEMPEK1J016GA size: 14.4GB
ID-2: /dev/sda model: TOSHIBA_MQ04ABF1 size: 1000.2GB
Partition: ID-1: / size: 689G used: 16G (3%) fs: ext4 dev: /dev/sda2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 36.0C mobo: 30.0C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 241 Uptime: 1:51 Memory: 1911.1/3828.1MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sat Oct 13, 2018 6:33 pm


User avatar
MrEen
Level 6
Level 6
Posts: 1487
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Sat Oct 13, 2018 7:58 pm

See if answer #22 in your second URL helps.

esc11
Level 1
Level 1
Posts: 28
Joined: Fri Oct 12, 2018 5:15 am

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by esc11 » Sun Oct 14, 2018 3:25 am

I don't want to be rude but why would I post the url if I didn't try what it says.
I am just trying to give you an indication of everything I have done to avoid redundant answers.

User avatar
MrEen
Level 6
Level 6
Posts: 1487
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Sun Oct 14, 2018 11:38 am

Understood.

Regarding your inxi, specifically this part:
Audio: Card Intel Sunrise Point-LP HD Audio
driver: snd_hda_intel bus-ID: 00:1f.3
This has been a problematic setup for many with Linux. In the cases I've tried to help, if fixed have all been resolved with vastly different techniques. Most recently, the user that started this thread started on 18, upgraded to 19 then did the DKMS thing, but was eventually fixed by reinstalling 18.3.

Another user had to wait until the Bionic version of the DKMS thing was released to finally get sound after working on it for months.

Both of those had no sound at all. There have been a bunch of others with other issues and sometimes just doing a complete shutdown on the Windows side fixed them. Other times they just booted up one day and it suddenly worked.

I know it must be very frustrating and I wish I had some command to give you to get it working, but all we can do is keep on trying.

When we get to the point we're at now, everything is just a shot in the dark.

One thing I'd like you to try is downloading and running the alsa info script and see if that points to anything obvious. See here for instructions.

User avatar
MrEen
Level 6
Level 6
Posts: 1487
Joined: Mon Jun 12, 2017 8:39 pm

Re: Linux Mint Cinnamon 19 - Internal Microphone not working

Post by MrEen » Sun Oct 14, 2018 11:48 am

One other thing worth trying is instead of model=laptop-dmic, see if model=laptop-amic in the alsa-base.conf file helps.

Or model=inv-dmic is another possibility. This one actually sounds promising, although it's probably because I don't understand what it means.

Post Reply

Return to “Hardware Support”