Epson WF-2530 cannot print anymore after upgrading to Mint 19

Forum rules
Before you post please read this
Post Reply
pennydata
Level 1
Level 1
Posts: 2
Joined: Thu Oct 11, 2018 6:57 am

Epson WF-2530 cannot print anymore after upgrading to Mint 19

Post by pennydata » Sat Oct 13, 2018 5:24 pm

Good evening,

as far as I've read there's a bit of trouble in making some printers work under Linux 19 Tara, even mine doesn't work anymore since I've installed the new O.S.
I've installed the proper drivers from the epson site, just the way I did on Mint 16 17 18.

The printer is installed and I can setup every features on system-config-printer.


Unfortunately documents can't be printed:

- If I launch the print by USB cable the Epson loads the paper and writes "UNIR" in capitals, then it stops suddenly.
- If I try by wifi the documents stand still and diagnotics say "Waiting for job to complete." and "job-printer-state-massage Filter Failed"




my

Code: Select all

inxi -Fxz
is

Code: Select all

System:    Host: hp255g5 Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Hewlett-Packard product: HP 255 G5 Notebook PC v: Type1ProductConfigId serial: N/A
           Mobo: Hewlett-Packard model: 82F6 v: 40.38 serial: N/A
           UEFI: Insyde v: F.21 date: 10/27/2016
Battery    BAT1: charge: 10.9 Wh 37.9% condition: 28.8/31.1 Wh (93%)
           model: Hewlett-Packard PABAS0241231 status: Charging
CPU:       Quad core AMD E2-7110 APU with AMD Radeon R2 Graphics (-MCP-) 
           arch: Puma rev.1 cache: 2048 KB
           
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 14372
           clock speeds: max: 1800 MHz 1: 1261 MHz 2: 1186 MHz 3: 1187 MHz
           4: 1207 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R3 Graphics]
           bus-ID: 00:01.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: AMD MULLINS (DRM 2.50.0 / 4.15.0-20-generic, LLVM 6.0.0)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Intel Wireless 3165 driver: iwlwifi bus-ID: 02:00.0
           IF: wlo1 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: eno1 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (75.1% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 83G used: 14G (17%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 376G used: 337G (95%) fs: ext4 dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.6C mobo: 20.0C gpu: 52.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 198 Uptime: 15 min Memory: 1217.3/3408.5MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 



my

Code: Select all

lpinfo -v
is

Code: Select all

network https
network ipp
network ipps
network lpd
network http
direct hp
network beh
file cups-brf:/
network socket
network smb
direct hpfax
network dnssd://EPSON%20WF-2530%20Series._ipp._tcp.local/?uuid=cfe92100-67c4-11d4-a45f-b0e8926aefc1
network lpd://192.168.1.25:515/PASSTHRU
network ipp://EPSON6AEFC1.local:631/Epson_IPP_Printer




my

Code: Select all

service cups status 
is

Code: Select all

● cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2018-10-13 22:55:29 CEST; 27min ago
     Docs: man:cupsd(8)
 Main PID: 3035 (cupsd)
    Tasks: 2 (limit: 3945)
   CGroup: /system.slice/cups.service
           ├─3035 /usr/sbin/cupsd -l
           └─3047 /usr/lib/cups/notifier/dbus dbus://

ott 13 22:55:29 hp255g5 systemd[1]: Started CUPS Scheduler.
ott 13 23:13:20 hp255g5 /hpfax[5584]: [5584]: error: Failed to create /var/spool/cups/tmp/.hplip 
Attachments
epsondrivers.png

Post Reply

Return to “Printers & Scanners”