Ctrl+Alt+Retroceso no me funciona en LM19

Spanish Forum

Moderator: JCSenar

Post Reply
rainerhg7
Level 1
Level 1
Posts: 8
Joined: Sat Feb 03, 2018 10:27 am

Ctrl+Alt+Retroceso no me funciona en LM19

Post by rainerhg7 » Mon Nov 05, 2018 2:08 pm

La combinación de teclas [Control] + [Alt] + [Retroceso⇦ ] no funcionan para cerrar sesión en Mint19; ¿alguno sabe como se podría establecer nuevamente este atajo?
Last edited by JCSenar on Sat Nov 10, 2018 3:05 pm, edited 1 time in total.
Reason: Título corregido

User avatar
tomeu
Level 4
Level 4
Posts: 287
Joined: Wed Mar 29, 2017 12:03 pm

Re: Ctrl+Alt+Retroceso no funciona en LM19

Post by tomeu » Tue Nov 06, 2018 4:42 am

rainerhg7 wrote:
Mon Nov 05, 2018 2:08 pm
La combinación de teclas [Control] + [Alt] + [Retroceso⇦ ] no funcionan para cerrar sesión en Mint19; ¿alguno sabe como se podría establecer nuevamente este atajo?
El título no es muy afortunado. Te aseguro que funcionan perfectamente en LM 19, otra cosa es que no te funcione a tí, o que en determinados supuestos no esté funcionando.
Por ejemplo, en ocasiones se me ha bloqueado el equipo y esa combinación de teclas, ni ninguna otra, me ha funcionado
Si usas "Cinnamon" tienes lo de atajos de teclado en "Centro de Control" → "Hardware" → "Teclado" → "Atajos de teclado"
Linux Mint Tara 19 64bits Cinnamon 3.8.9

rainerhg7
Level 1
Level 1
Posts: 8
Joined: Sat Feb 03, 2018 10:27 am

Re: Ctrl+Alt+Retroceso no funciona en LM19

Post by rainerhg7 » Fri Nov 09, 2018 4:32 pm

Estoy en Mate, y en los ajustes de atajos no figura esta acción, y desconozco los comandos utilizados para cerrar sesión (para agregar un atajo propio). El atajo no funciona desde el primer día.
Por cierto, yo no escribí el título de esta publicación.

User avatar
JCSenar
Level 9
Level 9
Posts: 2780
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Ctrl+Alt+Retroceso no funciona en LM19

Post by JCSenar » Fri Nov 09, 2018 4:53 pm

tomeu wrote:
Tue Nov 06, 2018 4:42 am
El título no es muy afortunado
:shock:
rainerhg7 wrote:
Fri Nov 09, 2018 4:32 pm
Por cierto, yo no escribí el título de esta publicación.
Cierto. Ya no recuerdo qué era lo que ponía pero lo cambié yo porque no describía el problema que planteabas.

Estoy probando LM 19 Mate y Ctrl+Alt+Retroceso funciona bien. Me va a la pantalla de inicio de sesión. Algún problema hay en la configuración de tu sistema.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
JOPETA
Level 13
Level 13
Posts: 4798
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ctrl+Alt+Retroceso no funciona en LM19

Post by JOPETA » Fri Nov 09, 2018 5:15 pm

Recuerdo que en alguna edición con mate creo que se activaba en la aplicaciones al incio. Has comproabado que existe en Menú>Centro de Control>Aplicaciones al inicio y si existe está activada? . Sobre porque a ti no y los demás si ademas de lo comentado por tomeu y en la msma onda, una distribución inadecuada o alterada del teclado (básicamente que la telcla Alt o el Ctrl estén deshubicadas o hayan sido desactivadas para determinadas cosas) ... ¿Has instalado otro escritorio sobre mate?
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

rainerhg7
Level 1
Level 1
Posts: 8
Joined: Sat Feb 03, 2018 10:27 am

Re: Ctrl+Alt+Retroceso no funciona en LM19

Post by rainerhg7 » Fri Nov 09, 2018 8:50 pm

Hola, gracias por su atención.
En Aplicaciones al inicio no encuentro nada parecido. He probado con las variaciones de distribución de teclado español, y en todas funcionan las teclas [Alt] y [Ctrl]. Tampoco he instalado otro escritorio.
En otra página encontré esta solución: crear un atajo a la orden:

Code: Select all

pkill -KILL -u miusuario
con esto mato todos los procesos activos incluyendo la sesión. Pero es radical.
Después, consultando las páginas de manual lo encontré (por fin :D ) :

Code: Select all

mate-session-save --logout
Gracias.
PD: ese 'man' habla sólo inglés (el comando).

User avatar
JOPETA
Level 13
Level 13
Posts: 4798
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ctrl+Alt+Retroceso no funciona en LM19

Post by JOPETA » Sat Nov 10, 2018 3:05 am

Eso está bien :D , pero son formas de cerrar sesión no de restituir la funcionalidad del atajo de teclado que es lo que reza el título. Para cerrar sesión recurriendo a abrir una ventana y ejecutar una orden (lo siguiente sería crear un acceso directo o botón o un script que ejecutar desde la terminal mediante un alias) ¿para eso no están ya los accesos del menú y los elementos gráficos del panel que además te dan tiempo para pensar si realmente quieres cerrar o no?

Creo que en eso tomueu ya te ha orientado desde el inicio, no sólo debes comprobar que no tienes ese atajo sino que deberás crearlo en tal caso. Menú>Centro de Control>Combinaciones de teclas> en el apartado Desktop buscar la opciónTerminar sesión, cerrar sesión o Salir de la sesión y haz clic en el campo correspondiente y presionar la combinación de teclas.

Si no estuvieras esa opción de Terminar, cerrar o Salir[/i] de la sesión que no se cómo vendrá en Mint 19) o estuviera desactivada este debe ser el problema... Has debido modificar las opciones de cerrar sesión por ejemplo al instalar un elemento gráfico externo en el panel (botón de cerrar sesión o apagar) o tal vez en un dock como cairo... o un compositor como compiz, que usen otro atajo de teclado para ello o hallan definido otra función con ese atajo y por lo tanto si te deja restituir el atajo dejaría de funcionar. Si está cualquiera de esas opciones desactivada o tratar de usar el predeterminado o puedes definir un nuevo atajo.

PD: He encontrado la instalación donde me aparece el script atando cabos por compiz,cairo y sobre todo por instalaciones modificadas a saco Es un sistema muy trastornado por lo que le hice al pobre, por lo que dudo que te sea de utilidad (por supuesto no lo es de forma generalizada) y es algo más que mas que un simple "logout".

Lo que hace me parece entender es reasignar la combinación a Alt+Ctrl+Back space para ejecutar "algo" que parece una modificación de otro algo preexistente. Seguro que si le echas un ojo a man setxkbmap en el apartado -option name tu lo entiendes mejor que yo.( no me atrevo ni a traducirlo)
-option name
Specifies the name of an option to determine the components which make up the keyboard description; multiple options may be specified, one per -option flag. Note that setxkbmap adds options specified in the command line to the options that were set before (as saved in root window properties). If you want to replace all previously specified options, use the -option flag with an empty argument first.
El man no suele proprocionarse en español a diferencia del comando -help o comando --help. aunque suele ser mas escueto en contenido como en este caso y sin traducir.

Como no se de donde sale ese algo (name en el manual) en mi caso no es cuestión de lanzar códigos que no se saben donde van a parar. Devuelve el resultado del siguiente código en la terminal para confirma/descartar si es tu caso

Code: Select all

setxkbmap -query
Last edited by JOPETA on Sat Nov 10, 2018 1:24 pm, edited 6 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

User avatar
tomeu
Level 4
Level 4
Posts: 287
Joined: Wed Mar 29, 2017 12:03 pm

Re: Ctrl+Alt+Retroceso no funciona en LM19

Post by tomeu » Sat Nov 10, 2018 11:30 am

JCSenar wrote:
Fri Nov 09, 2018 4:53 pm
tomeu wrote:
Tue Nov 06, 2018 4:42 am
El título no es muy afortunado
:shock:
Con toda humildad, creo que "en LM19" no es correcto e invita a confusión: da a entender que el fallo es propio de la distribución "Tara" y no del usuario o de la forma dfe tener configurado el entorno de escritorio
Linux Mint Tara 19 64bits Cinnamon 3.8.9

User avatar
JOPETA
Level 13
Level 13
Posts: 4798
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ctrl+Alt+Retroceso no me funciona en LM19

Post by JOPETA » Sat Nov 10, 2018 5:25 pm

Gracias JCSenar tema zanjado. :D
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

User avatar
JOPETA
Level 13
Level 13
Posts: 4798
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Ctrl+Alt+Retroceso no funciona

Post by JOPETA » Sat Nov 10, 2018 6:05 pm

Sobre el tema en cuestión, por resumir el chequeo previo propuesto
a) Comprobar las combinaciones del teclado. Sigo sin entender como ha podido desaparecer las opción de Cerrar/terminar Salir de la sesión si esta opción está prefijado que se cree por defecto para cualquier usuario (al igual que los controles multimedia, etc) y no sólo en Mate también en todos los escritorios por lo menos en Mint. Me extraña no que se haya desactivado por algún motivo, sino que además se haya eliminado. ¿Estas seguro que no existe tal entrada no en desktop (escritorio) sino en ninguna parte?
cambiar combinación.png
b)Comprobar las opciones de la distribución del teclado instalada Otra posibilidad que hay que descartar y que se trató un tanto a la ligera, sin entrar en materia. (Menú>Centro de Control>Teclado> Distribuciones> Selecciona la que tengas actualmente> Clic en Opciones...> Despliega la opción Secuencia de teclas para matar el servidor X y comprueba que tienes activada la casilla de Control+Alt +Retroceso, claro si te aparece.
opciones del teclado.png
Es a la modificación de estas opciones a las que me refería, con independencia del idioma regional o variante instalad
c) Comprobar que no existe ya una orden al inicio para ello (Menú>Centro de Cotrol Aplicaciones al incio). En la instalación de pruebas donde me aparece el código de restitución del atajo Ctrl+Alt+Backspace yo no intervine en ello por lo que entiendo que lo desactivó el atajo (hay mucho donde elegir en una instalación de pruebas cairo, compiz, la propia instalación de mate sobre otro escritorio, o un condicionante impuesto por el propio PC (en mi caso fue en un portátil mas antiguo..) fué quien lo restituyó ¿Por qué a ti no?
aplicaciones al inicio.png
Si todo lo anterior ha sido descartado,debes comprobar la existencia del archivo /usr/share/X11/xkb/symbols/terminate. Si no lo tienes no va a funcionar. Si lo tienes, para restituir la funcionalidad del atajo Ctrl+Alt+Retroceso:
1)En Menú>Centro de Control>Aplicaciones al inicio haz clic en Añadir (+).

2)Nómbralo como quieras (Ctrl Alt Backspace no es una mala opción y es la que pone)

32)Copia y pega el siguiente código en la orden a ejecutar

Code: Select all

setxkbmap -option terminate:ctrl_alt_bksp
4)Si quieres una aclaración/descripción es que permite reiniciar Xorg con Ctrl+Alt+Backspace que es lo que pone.

5)Clic en el botón de Añadir y asegúrate que queda activado
Cierra sesión de forma normal (botones del panel o accesos del Menú, por ejemplo) o reinicia para comprobar que funciona. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”