Mic doesn't record Mint 18.3 Gateway LT31

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
CutRightSharpening
Level 2
Level 2
Posts: 58
Joined: Sat Jan 04, 2014 11:05 pm

Mic doesn't record Mint 18.3 Gateway LT31

Post by CutRightSharpening » Wed Nov 07, 2018 9:23 pm

Looked at a bunch of posts. Tried those things that looked like they might apply.

I get good sound from the speakers on this tablet, that was one of the reason I bought it.

Never before tried to record anything but the microphone records when the device is booted into Win 7.

If I go into the sound setup through preferences and jack the input to maximum, the level meter barely twitches and audio with a video recording using the internal camera with VLC is just above the threshold of being heard.

Plugged in a audio-technica ATR3350 that also worked in Win 7 and it doesn't even show up in the audio input devices list even though plugging it in causes the level meter to start really bouncing even with the mic is turned off. Reboot with the mic plugged in didn't change anything.
I

User avatar
MrEen
Level 7
Level 7
Posts: 1732
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by MrEen » Wed Nov 07, 2018 9:55 pm

Hi CutRightSharpening.

My hunch is to run alsamixer in the terminal. You may need to press F6 to select the appropriate sound card. Is there a Mic column and does it have 2 numbers at the bottom like this: 100<>100? If so, you probably need to drop one side to 0 (I never remember if it's the left or right side) using the z key or the c key. The q key and e key will raise each side if you lowered the wrong one first. Test the mic with either side lowered to zero and if that doesn't help add the results of inxi -Fxz and arecord -l to your next post.

Good luck.

User avatar
MrEen
Level 7
Level 7
Posts: 1732
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by MrEen » Wed Nov 07, 2018 10:02 pm

Regarding the audio-technica ATR3350, my guess there is it's probably not configured properly.

My suggestion is to install and run PulseAudio Volume Control and navigate to the Configuration tab where that can be set up properly.

CutRightSharpening
Level 2
Level 2
Posts: 58
Joined: Sat Jan 04, 2014 11:05 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by CutRightSharpening » Wed Nov 07, 2018 11:02 pm

crs@crs-LT31 ~ $ inxi -Fxz
System: Host: crs-LT31 Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: Gateway product: LT31
Mobo: Gateway model: SJM11-YK
Bios: Phoenix v: v1.3307 date: 05/31/2010
CPU: Dual core AMD Athlon X2 L310 (-MCP-) cache: 1024 KB
flags: (lm nx sse sse2 sse3 svm) bmips: 4788
clock speeds: max: 1197 MHz 1: 1197 MHz 2: 1197 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270]
bus-ID: 01:05.0
Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
GLX Renderer: Gallium 0.4 on ATI RS690
GLX Version: 2.1 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: a000 bus-ID: 03:00.0
IF: enp3s0 state: down mac: <filter>
Card-2: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
driver: ath9k bus-ID: 04:00.0
IF: wlp4s0 state: up mac: <filter>
Drives: HDD Total Size: 288.8GB (11.6% used)
ID-1: /dev/sda model: Hitachi_HTS54501 size: 160.0GB
ID-2: USB /dev/sdb model: USB_2.0_FD size: 128.8GB
Partition: ID-1: / size: 81G used: 6.6G (9%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 1.87GB used: 0.03GB (2%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 64.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 183 Uptime: 54 min Memory: 863.1/1745.2MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
crs@crs-LT31 ~ $
I

CutRightSharpening
Level 2
Level 2
Posts: 58
Joined: Sat Jan 04, 2014 11:05 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by CutRightSharpening » Wed Nov 07, 2018 11:03 pm

crs@crs-LT31 ~ $ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC272X Analog [ALC272X Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
crs@crs-LT31 ~ $
I

CutRightSharpening
Level 2
Level 2
Posts: 58
Joined: Sat Jan 04, 2014 11:05 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by CutRightSharpening » Wed Nov 07, 2018 11:04 pm

MrEen wrote:
Wed Nov 07, 2018 9:55 pm
Hi CutRightSharpening.

My hunch is to run alsamixer in the terminal. You may need to press F6 to select the appropriate sound card. Is there a Mic column and does it have 2 numbers at the bottom like this: 100<>100? If so, you probably need to drop one side to 0 (I never remember if it's the left or right side) using the z key or the c key. The q key and e key will raise each side if you lowered the wrong one first. Test the mic with either side lowered to zero and if that doesn't help add the results of inxi -Fxz and arecord -l to your next post.

Good luck.
tried it both ways.. No worky. I hate mucking around in terminal.
I

CutRightSharpening
Level 2
Level 2
Posts: 58
Joined: Sat Jan 04, 2014 11:05 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by CutRightSharpening » Wed Nov 07, 2018 11:06 pm

MrEen wrote:
Wed Nov 07, 2018 10:02 pm
Regarding the audio-technica ATR3350, my guess there is it's probably not configured properly.

My suggestion is to install and run PulseAudio Volume Control and navigate to the Configuration tab where that can be set up properly.
This made no difference but I suspect either the internal mic setting need to get right,, or VLC isn't seeing the external mic
I

User avatar
MrEen
Level 7
Level 7
Posts: 1732
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by MrEen » Wed Nov 07, 2018 11:19 pm

One thing I forgot to mention while in alsamixer, arrow over to Auto-mute and click up or down arrows until it says disabled.

If that makes no difference, use your File Manager to go to /home/yourusername/.config/pulse and delete all the files there (they'll get recreated after the next step.) Then in the terminal (sorry, but it's a lot faster than a reboot) run pulseaudio -k then wait a few seconds and try testing the mic again.

I'm afraid I have to go now, but will check on your progress tomorrow.

Good luck.

CutRightSharpening
Level 2
Level 2
Posts: 58
Joined: Sat Jan 04, 2014 11:05 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by CutRightSharpening » Thu Nov 08, 2018 10:19 pm

MrEen wrote:
Wed Nov 07, 2018 11:19 pm


I'm afraid I have to go now, but will check on your progress tomorrow.

Good luck.
Don't rush. I am not going to have time to mess with this until Saturday afternoon South Texas time.
Even then not sure what will happen. Hard drive started whining last time I booted it up. I was an early buyer so it is approaching 9 years old and it spent 5 years banging around in and out of my work vehicle 3-4 days a week. If the HD dies I have found a sweet deal on a 500GB SSD. May do it even if the HD doesn't die since the plan is for this to go back into the work vehicle for use making and showing training and demonstration videos of how I sharpen beauty and barber shears. Doing this right will pay for itself since I get 50$/hr when I am training someone and I am selling videos for 20$+ shipping.
I

User avatar
MrEen
Level 7
Level 7
Posts: 1732
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by MrEen » Thu Nov 08, 2018 11:03 pm

Assuming Auto-Mute is now disabled and deleting the files in ~/.config/pulse did not help, I have 2 different suggestions.

1. Upgrade your kernel. I think you should probably do this regardless as I'm pretty certain 4.10 is no longer supported. If you are hiding level 4 updates in your Update Manager, you'll have to unhide them to get the kernel upgrade option to appear.

2. If that didn't get the mic working, you'll need to modify a file that will require administrator privileges. The file is /etc/modeprobe.d/alsa-base.conf and the way I normally tell people how to open it is in the terminal with gksudo xed /etc/modeprobe.d/alsa-base.conf, but you can also use your File Manager and navigate to /etc/modprobe.d then right click in the window and select Open as Root then in the root window open alsa-base.conf for editing. Scroll to the bottom of the file and add this line:

Code: Select all

options snd-hda-intel model=laptop-amic
Then save the file and reboot. If that didn't make any difference, redo the above and change the line to:

Code: Select all

options snd-hda-intel model=laptop-dmic
Again, save and reboot.

Let us know if this helps, and good luck.

CutRightSharpening
Level 2
Level 2
Posts: 58
Joined: Sat Jan 04, 2014 11:05 pm

Re: Mic doesn't record Mint 18.3 Gateway LT31

Post by CutRightSharpening » Fri Nov 09, 2018 9:27 am

MrEen wrote:
Thu Nov 08, 2018 11:03 pm
Assuming Auto-Mute is now disabled and deleting the files in ~/.config/pulse did not help, I have 2 different suggestions.

1. Upgrade your kernel. I think you should probably do this regardless as I'm pretty certain 4.10 is no longer supported. If you are hiding level 4 updates in your Update Manager, you'll have to unhide them to get the kernel upgrade option to appear.

Ok,, Tried booting it just to see what the HD is doing.. Much grinding and whining. So, putting this on hold until I get the new Hard drive installed and the WIN OS cloned to it...

If the kernel could be the problem I might as well completely upgrade the Release I think. I chose 18 because that was really the first Mint version (one of the few Linux Versions at all) that seemed to boot and run on this device. I had just never tried to record any audio until the new business opportunity presented itself. As I understand it, Gateway has a history of not playing well with Linux.

----------------------------------------------11/10/18-------------------------------
To those providing suggestions. I have a new 500 GB SSD on the way. should get here 3-5 days. Then I have to get the old HD and the new SSD into town to a geek to do the clone.. That is usually 3 days.
In the mean time I will download Mint 19 and make the ISO usb since the Gateway has no optical drive.
See you all in about 10 days I think.
I

Post Reply

Return to “Hardware Support”