Mint 19 install fail on Skylake motherboard - log files huge

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
mintismyfav
Level 1
Level 1
Posts: 2
Joined: Sun Nov 11, 2018 12:44 am

Mint 19 install fail on Skylake motherboard - log files huge

Post by mintismyfav » Sun Nov 11, 2018 1:11 am

Hello! I began using Linux about 2 yr ago, with Linux Mint. The OS and this Forum has been fantastic! I have always been able to find answers to all my questions to get started with Mint on this forum....until now. Thus, my first post.

I have a Dell XPS 8900 desktop that has the Skylake ASrock motherboard. There is a known problem in installing Linux Mint on these motherboards, as it will cause the var/log/syslog file to become enormous, eventually filling the entire USB installation disk or any HD that it's been installed on. This is due to a gpe6f acpi error that is described elsewhere in this forum.

I'll describe the fix below that has worked for Linux Mint 18.1 to 18.3, but the problem is that this does NOT work for Linux Mint 19. In Linux Mint 19, the file / folder “/etc/rc.local” no longer exists. When I searched main file system, the only similar file that is found is “rc.local.service” found at “/lib/systemd/system”. It references rc.local, but I cannot seem to open or alter the rc.local file to make the gpe6F error fix in Mint 19.

Can anyone please tell me how I can access and change rc.local or the equivalent file in Mint 19 to apply the fix for Skylake motherboards gpe6F error that fills var/log/syslog? Or, the new fix required under Mint 19? If possible, please give the most step-by-step explanation of where to find or change the files, any fix required, etc as I am still fairly new to navigating Linux. Thanks!

The permanent fix for this on Linux Mint 18.1 to 18.3 that I have used over the past year is by adding the text: "echo 'disable' > /sys/firmware/acpi/interrupts/gpe6F" into the /etc/rc.local file. To do this, I enter the file system as root from the terminal to be able to edit that file:
to edit this file with admin privileges, you can type "gksu xed /etc/rc.local" in terminal.
- that opens the /etc/rc.local file. Then copy and paste code:
echo "disable" > /sys/firmware/acpi/interrupts/gpe6F
- add that to the /etc/rc.local file text just before the final “exit 0” line.

Thanks!!

User avatar
smurphos
Level 8
Level 8
Posts: 2042
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Mint 19 install fail on Skylake motherboard - log files huge

Post by smurphos » Sun Nov 11, 2018 2:13 am

See here for setting up a systemd service to achieve the same workaround - also mentions the issue was permanently fixed by applying a bios update.....

https://gist.github.com/StefanoBelli/0a ... e8799dffa2

By the way can you share your inxi -Fxz output - it might help other users with the same issue/motherboard who are unaware of the fix to locate this thread by search.

mintismyfav
Level 1
Level 1
Posts: 2
Joined: Sun Nov 11, 2018 12:44 am

Re: Mint 19 install fail on Skylake motherboard - log files huge

Post by mintismyfav » Sun Nov 11, 2018 3:18 am

Hi Smurphos,

Thank you very much for a very quick reply and a link to that web page. I've installed Mint 19 via USB onto a HD connected to my laptop, then made the changes noted in your link. When then attaching that HD to my Dell XPS 8900 desktop (skylake processor), everything now works fine and the var/log files are not being filled with errors anymore.

I appreciate your help!

Post Reply

Return to “Installation & Boot”