LMDE 2 (betsy) - microphone doesn't work

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
baklazan
Level 1
Level 1
Posts: 3
Joined: Sun Nov 25, 2018 6:24 pm

LMDE 2 (betsy) - microphone doesn't work

Post by baklazan » Sun Nov 25, 2018 6:36 pm

I've bought external microphone (front tower jack) and have no idea what can I do to make it working. I have already tried every possible setting in sound preference, but without success. Deleting .config/pulse didn't work out.

Code: Select all

$ lspci | grep Audio
00:1f.3 Audio device: Intel Corporation Device a170 (rev 31)
01:00.1 Audio device: NVIDIA Corporation Device 0fb9 (rev a1
Pavucontrol (as a root):
Zrzut ekranu z 2018-11-25 23-32-25.png
Sound preferences:
Zrzut ekranu z 2018-11-25 23-32-04.png
Do you have any suggestions which might help?
Last edited by karlchen on Sun Nov 25, 2018 7:13 pm, edited 1 time in total.
Reason: Changed title to specify "LMDE 2", instead of "Linux Mint 2". Moving thread to LMDE 2 subforum

User avatar
MrEen
Level 8
Level 8
Posts: 2017
Joined: Mon Jun 12, 2017 8:39 pm

Re: LMDE 2 (betsy) - microphone doesn't work

Post by MrEen » Sun Nov 25, 2018 7:24 pm

Hi baklazan, and welcome to the forum.

First, do not run pavucontrol as root or you'll end up with more problems. Just type pavucontrol into the terminal, or select PulseAudio Volume Control from the Menu.

In case some permissions are already messed up, type this into the terminal: sudo chown -Rc $USER:$USER $HOME

Now with the microphone plugged in, does it show on the Input Devices tab of pavucontrol?

baklazan
Level 1
Level 1
Posts: 3
Joined: Sun Nov 25, 2018 6:24 pm

Re: LMDE 2 (betsy) - microphone doesn't work

Post by baklazan » Mon Nov 26, 2018 4:48 pm

Thanks for your answer.
Unfortunately there are only monitors shown.
Zrzut ekranu z 2018-11-26 21-47-20.png
Zrzut ekranu z 2018-11-26 21-46-11.png

User avatar
MrEen
Level 8
Level 8
Posts: 2017
Joined: Mon Jun 12, 2017 8:39 pm

Re: LMDE 2 (betsy) - microphone doesn't work

Post by MrEen » Mon Nov 26, 2018 7:06 pm

Make sure the last tab (Configuration) has Analog Stereo Duplex for the profile that is not HDMI.

If it presently says Analog Stereo Output, that would explain why the microphone isn't showing up.

baklazan
Level 1
Level 1
Posts: 3
Joined: Sun Nov 25, 2018 6:24 pm

Re: LMDE 2 (betsy) - microphone doesn't work

Post by baklazan » Sun Dec 16, 2018 6:47 am

It is Analog Stereo Duplex. Sound preferences recognize if mic is plugged in to front or back jack, but still record nothing or just a hum.

Maybe it's time to reinstall the system, especially LMDE 2 support ends.

User avatar
MrEen
Level 8
Level 8
Posts: 2017
Joined: Mon Jun 12, 2017 8:39 pm

Re: LMDE 2 (betsy) - microphone doesn't work

Post by MrEen » Sun Dec 16, 2018 3:47 pm

Yeah, it's almost time to install anew.

You could also check alsamixer (type that into the terminal.) You may need to press F6 to select the built-in card, then see if the mic is muted or too low. Use arrow keys to select columns and raise/lower levels. Use the m key to toggle mute. Muted columns show MM at the bottom. You may also need to adjust Mic Boost, but don't set it too high.

Post Reply

Return to “Hardware Support”