[SOLVED] Sound Blaster Audigy Rx unable to acquire microphone

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
Vortigern
Level 1
Level 1
Posts: 8
Joined: Tue Dec 18, 2018 4:16 pm

[SOLVED] Sound Blaster Audigy Rx unable to acquire microphone

Post by Vortigern »

Hi,
I have Sound Blaster Audigy Rx and I've just tried to acquire a stereo microphone but I failed.
I've tried both the Mic1 and Mic2: I was able to hear my voice on the speakers, when using an high capture gain, but no sound was passed to the system, meaning I could not use it for skype, record audio, steam voice chat etc. Also on "Audio" panel, no matter the input gain and how loud I speak, the bar is always grayed out.

I've tried to turn up all possible volumes even from "alsamixer" in the CLI with no luck.
I do have another issue: in order to use the microphone I've had to use a USB audio card and now the Sound Blaster is not the preferred device: each time I restart the computer I have to set right output device.

How can I solve those issues?

I'm running Linux Mint 19 Cinnamon 64bit.
Here below the device and system spec

Code: Select all

$ lspci -vvv -s 09:00.0
09:00.0 Multimedia audio controller: Creative Labs CA0108/CA10300 [Sound Blaster Audigy Series]
	Subsystem: Creative Labs SB1550 Audigy 5/Rx
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32 (500ns min, 5000ns max)
	Interrupt: pin A routed to IRQ 16
	Region 0: I/O ports at b000 [size=64]
	Capabilities: <access denied>
	Kernel driver in use: snd_emu10k1
	Kernel modules: snd_emu10k1

Code: Select all

$ inxi -Fxz
System:    Host: i7-4790K Kernel: 4.15.0-42-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 2.24.32) Distro: Linux Mint 19 Tara
Machine:   Device: desktop Mobo: ASRock model: Z97 Extreme6 serial: N/A
           UEFI [Legacy]: American Megatrends v: P2.80 date: 03/06/2018
CPU:       Quad core Intel Core i7-4790K (-MT-MCP-) arch: Haswell rev.3 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 31990
           clock speeds: max: 4400 MHz 1: 1756 MHz 2: 1537 MHz 3: 1459 MHz 4: 1447 MHz 5: 1409 MHz 6: 1477 MHz
           7: 1364 MHz 8: 1463 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 960] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 version: 4.6.0 NVIDIA 390.77 Direct Render: Yes
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel bus-ID: 01:00.1 Sound: ALSA v: k4.15.0-42-generic
           Card-2 Creative Labs CA0108/CA10300 [Sound Blaster Audigy Series]
           driver: snd_emu10k1 port: b000 bus-ID: 09:00.0
           Card-3 C-Media CM108 Audio Controller driver: USB Audio usb-ID: 003-004
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1756.4GB (62.8% used)
           ID-1: /dev/sda model: Crucial_CT256M55 size: 256.1GB
           ID-2: /dev/sdb model: WDC_WD10EURS size: 1000.2GB
           ID-3: /dev/sdc model: WDC_WD5000AACS size: 500.1GB
Partition: ID-1: / size: 234G used: 54G (25%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 1.07GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A gpu: 0.0:30C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 284 Uptime: 35 min Memory: 2521.7/15988.9MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Last edited by Vortigern on Thu Feb 07, 2019 4:32 pm, edited 1 time in total.
User avatar
MrEen
Level 21
Level 21
Posts: 14131
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound Blaster Audigy Rx unable to acquire microphone

Post by MrEen »

Hi Vortigern, and welcome to the forum.

Install and run PulseAudio Volume Control (pavucontrol.)

On the Output Devices tab enable the check mark for the device you want as default. That should prevent having to change things after a reboot.

To get the mic working, first go to the Configuration tab and make sure the Profile includes Input or Duplex. If the SB card is set to Output only, that would explain why the mic isn't working. Then you can check the Input Devices tab to see if it recognizes the mic being plugged in. You can also set the default input here by enabling the appropriate check mark.

Good luck.
Vortigern
Level 1
Level 1
Posts: 8
Joined: Tue Dec 18, 2018 4:16 pm

Re: Sound Blaster Audigy Rx unable to acquire microphone

Post by Vortigern »

Hi MrEen,
thank you for answering; here below the outcome:
Install and run PulseAudio Volume Control (pavucontrol.)

On the Output Devices tab enable the check mark for the device you want as default. That should prevent having to change things after a reboot.
This does not work: I've configured the soundblaster as main device but each time I reboot the system it switches back to another card.
Is there another way to select the deafult audio output device?
To get the mic working, first go to the Configuration tab and make sure the Profile includes Input or Duplex. If the SB card is set to Output only, that would explain why the mic isn't working. Then you can check the Input Devices tab to see if it recognizes the mic being plugged in. You can also set the default input here by enabling the appropriate check mark.
That doesn't work as well, I've already set the SB as both output/input device, but this not solves the issue.

Cheers
Vortigern
Level 1
Level 1
Posts: 8
Joined: Tue Dec 18, 2018 4:16 pm

Re: Sound Blaster Audigy Rx unable to acquire microphone

Post by Vortigern »

I've found a solution for the biggest issue: acquiring Mic with the Sound Blaster Audigy Rx
  • $ alsamixer
  • "F6" then select the in/output device
  • "F4" switch to capture mode
  • "Analog Mix" must be enabled
Schermata del 2019-01-02 17-40-36.png
User avatar
MrEen
Level 21
Level 21
Posts: 14131
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sound Blaster Audigy Rx unable to acquire microphone

Post by MrEen »

Delete the files in ~/.config/pulse and run pulseaudio -k in the terminal. Wait a moment, then play with your sound settings to get them set as you want. See if they stick after a reboot after that. If not, we can edit default.pa to make it stick, but I think what I've given you should work.

Nice work getting the mic issue solved!
Vortigern
Level 1
Level 1
Posts: 8
Joined: Tue Dec 18, 2018 4:16 pm

Re: Sound Blaster Audigy Rx unable to acquire microphone

Post by Vortigern »

Dear MrEen,
thank you very much for your reply.
I've tried first to delete the pulse configuration files as you suggested:

Code: Select all

$ rm -r ~/.config/pulse/
$ pulseaudio -k
Unfortunately it didn't work.
I've than had a look at the /etc/pulse/default.pa file and I've modified the files in order not to automatically use the hot-plugged devices:

Code: Select all

$ sudo nano /etc/pulse/default.pa

### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect
#.endif
It worked! Thank you very much for your help!
User avatar
MrEen
Level 21
Level 21
Posts: 14131
Joined: Mon Jun 12, 2017 8:39 pm

Re: [SOLVED] Sound Blaster Audigy Rx unable to acquire microphone

Post by MrEen »

Hi again Vortigern. That's great that you got the issue solved the way you did!

In fact, I think you got where you needed to be in fewer steps than if we followed the path I was heading down. Pretty sure I was thinking of setting defaults at the bottom of default.pa, that would still have been ignored in your use case.

Thanks for coming back and posting your solution. I'm sure it'll help others in the future.

Take care.
Post Reply

Return to “Hardware Support”