Cannot upgrade from 19 to 19.1

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
User avatar
bscho
Level 1
Level 1
Posts: 33
Joined: Sun Dec 23, 2012 3:52 pm
Location: London
Contact:

Cannot upgrade from 19 to 19.1

Post by bscho »

I have upgraded on my laptop and it worked OK.

But cannot get it to upgrade on my Desktop. The update manager just keeps saying system is up to date

It says in the How to upgrade:
If the upgrade is not available to you, check that you have the latest versions of mintupdate and mint-upgrade-info installed and restart the Update Manager. If the latest versions are not yet available in your mirrors, switch to the default repositories.

Well I did a sudo apt install mintupdate and a sudo apt install mint-upgrade-info and still have had no luck.

Any ideas on how to tell it to put the upgrade in the edit box?
User avatar
philotux
Level 5
Level 5
Posts: 828
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: Cannot upgrade from 19 to 19.1

Post by philotux »

bscho wrote:
Thu Dec 20, 2018 1:01 pm
If the upgrade is not available to you, check that you have the latest versions of mintupdate and mint-upgrade-info installed and restart the Update Manager. If the latest versions are not yet available in your mirrors, switch to the default repositories.
Did you do this? If not, open Software Sources and click "Restore default settings", update the APT cache by clicking OK at the top right
After that run Update Manager and see if you have the updates to those packages.
User avatar
karlchen
Level 22
Level 22
Posts: 15332
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Cannot upgrade from 19 to 19.1

Post by karlchen »

Hello, bscho.

The desktop machine is really running Mint 19? Check with inxi -S
Provided it is, use software sources in order to switch from any local mirror servers, which you may have selected for Mint and Ubuntu, to the default main servers. Then refresh you Update Manager once more.

Best regards,
Karl
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 10.00 64-bit
Slade - Cum on Feel the Noize
User avatar
bscho
Level 1
Level 1
Posts: 33
Joined: Sun Dec 23, 2012 3:52 pm
Location: London
Contact:

Re: Cannot upgrade from 19 to 19.1

Post by bscho »

Did what Philotux suggested no joy.

Did the last inxi -S and got :

Code: Select all

System:    Host: barry-To-be-filled-by-O-E-M Kernel: 4.15.0-43-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.6.7  Distro: Linux Mint 18.3 Sylvia
Odd really as I had updated to 19 a while back
User avatar
philotux
Level 5
Level 5
Posts: 828
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: Cannot upgrade from 19 to 19.1

Post by philotux »

bscho wrote:
Thu Dec 20, 2018 1:42 pm
System: Host: barry-To-be-filled-by-O-E-M Kernel: 4.15.0-43-generic x86_64 (64 bit)
Desktop: Cinnamon 3.6.7 Distro: Linux Mint 18.3 Sylvia

Odd really as I had updated to 19 a while back
Check your official repositories to see if they are for LM 19 (tara/bionic).

Code: Select all

cat /etc/apt/sources.list.d/official-package-repositories.list
Or as well:

Code: Select all

cat /etc/lsb-release
User avatar
bscho
Level 1
Level 1
Posts: 33
Joined: Sun Dec 23, 2012 3:52 pm
Location: London
Contact:

Re: Cannot upgrade from 19 to 19.1

Post by bscho »

Do not seem to be I had this:

Code: Select all

barry@barry-To-be-filled-by-O-E-M ~ $ cat /etc/apt/sources.list.d/official-package-repositories.list
deb https://mirrors.ukfast.co.uk/sites/linuxmint.com/packages sylvia main upstream import backport 

deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ xenial partner

Code: Select all

barry@barry-To-be-filled-by-O-E-M ~ $ cat /etc/lsb-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=18.3
DISTRIB_CODENAME=sylvia
DISTRIB_DESCRIPTION="Linux Mint 18.3 Sylvia"
barry@barry-To-be-filled-by-O-E-M ~ $


Can I do something about this?
User avatar
philotux
Level 5
Level 5
Posts: 828
Joined: Sat Jul 21, 2018 11:14 am
Location: Utopia

Re: Cannot upgrade from 19 to 19.1

Post by philotux »

There is of course an upgrade path from 18.3 to 19. But when it comes to upgrades between major releases, a fresh install is what I have seen being recommended by experienced forum members.
User avatar
Pierre
Level 20
Level 20
Posts: 12222
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Cannot upgrade from 19 to 19.1

Post by Pierre »

you would indeed be better to just do a clean installation of LM19.1
- rather than messing around with that 'upgrade' process.
sometimes, this method is Just Plain Easier to do.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
Post Reply