Installing LAMP

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
jluczynski
Level 1
Level 1
Posts: 1
Joined: Tue Jan 08, 2019 11:17 pm

Installing LAMP

Post by jluczynski » Tue Jan 08, 2019 11:20 pm

Hi, i have been trying to install LAMP to work on some dev projects but every tutorial or video I have watched has not been successful. I am missing some files that will not allow any installs and have tried getting those files with no luck. Below is just a small part of the errors I am getting:
atlas@atlas:~$ sudo apt-get install apache2
Reading package lists... Done
Building dependency tree
Reading state information... Done
apache2 is already the newest version (2.4.37-1).
apache2 set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
gconf2 : Depends: gconf-service (= 3.2.6-5)
libgstreamer-gl1.0-0 : Depends: libgstreamer1.0-0 (>= 1.14.4) but 1.14.1-1~ubuntu18.04.1 is to be installed
libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.22.5-1) but 2.22.4-0ubuntu0.18.04.1 is to be installed
vlc : Depends: vlc-bin (= 3.0.5-1) but 3.0.4-1ubuntu0.2 is to be installed
Depends: vlc-plugin-base (= 3.0.5-1) but 3.0.4-1ubuntu0.2 is to be installed
vlc-plugin-qt : Depends: libvlccore9 (>= 3.0.5) but 3.0.4-1ubuntu0.2 is to be installed
vlc-plugin-video-output : Depends: libavcodec58 (>= 7:4.0)
Depends: libavutil56 (>= 7:4.0) but it is not going to be installed
Depends: libplacebo6 (>= 0.4.0) but it is not going to be installed
Depends: libvlccore9 (>= 3.0.5) but 3.0.4-1ubuntu0.2 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).



Any thoughts or fixes I can use to install the packages I need?

shini_fluke
Level 1
Level 1
Posts: 2
Joined: Mon Jan 14, 2019 2:01 pm

Re: Installing LAMP

Post by shini_fluke » Mon Jan 14, 2019 2:15 pm

you just have to install it with the -f parameter this will attempt to correct a system which has broken dependencies so basically you just have to run 'apt --fix-broken install in order to get it working.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5717
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Installing LAMP

Post by administrollaattori » Mon Jan 14, 2019 4:17 pm

Your system and repos are?

Code: Select all

inxi -Sr

Post Reply

Return to “Newbie Questions”