[SOLVED] [LM19.1] How to install libc6 >= 2.28?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Enkidu
Level 1
Level 1
Posts: 30
Joined: Sat Apr 14, 2012 7:58 am

[SOLVED] [LM19.1] How to install libc6 >= 2.28?

Post by Enkidu » Sun Jan 13, 2019 7:35 pm

Hi,

I just set up a new system using LM19.1 cinnamon and did all updates.

Now while an installation, I get a dependency problem that I need to install libc6 >= 2.28. Installed is only 2.27.

How can I upgrade to 2.28? Tnx!


I was not able to google where to get it from and how to install it... :(


Tnx in advance,
Enkidu
Last edited by Moem on Sat Apr 20, 2019 5:24 am, edited 1 time in total.
Reason: Marked this as [SOLVED] for you; please note that you can and should do this for your own topics. Thanks!
Linux Mint 16, 64bit, Cinnamon, fully encrypted (luks) on Lenovo Thinpad T520 (Intel i7, 16GB RAM, 750GB SSHD)

User avatar
jimallyn
Level 18
Level 18
Posts: 8894
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: [LM19.1] How to install libc6 >= 2.28?

Post by jimallyn » Mon Jan 14, 2019 4:25 am

Just curious, what program were you trying to install that requires libc6>= 2.28? Is it a program from the standard Mint repositories?
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

Hoser Rob
Level 14
Level 14
Posts: 5151
Joined: Sat Dec 15, 2012 8:57 am

Re: [LM19.1] How to install libc6 >= 2.28?

Post by Hoser Rob » Mon Jan 14, 2019 8:50 am

I'd actually assume you're trying to install something via ppa that wants a newer version of libc6.

WHat is it, and just HOW badly do you need a newer version via ppa? Because libc6 is a dependency for a ridiculous amount of the software you already have instaled and installing a newer version is going to seriously break your OS. The reason is that backwards compatibility in Linux, unlike in Windows, is almost non existent.

Linux newbies are usually advised to avoid ppas unless ABSOLUTELY necessary, and just wanting the newest version of everything is not considered a valid reason. This sort of thing is why. I have very, very few ppa sources and none wanted to remove anything. If they had I woiuild have aborted the install.

Enkidu
Level 1
Level 1
Posts: 30
Joined: Sat Apr 14, 2012 7:58 am

Re: [LM19.1] How to install libc6 >= 2.28?

Post by Enkidu » Mon Jan 14, 2019 4:26 pm

Sorry, solved my problem. I used the wrong repo. :(


Cheers,
Enkidu
Linux Mint 16, 64bit, Cinnamon, fully encrypted (luks) on Lenovo Thinpad T520 (Intel i7, 16GB RAM, 750GB SSHD)

bmunday
Level 1
Level 1
Posts: 1
Joined: Thu Apr 11, 2019 2:42 pm

Re: [LM19.1] How to install libc6 >= 2.28?

Post by bmunday » Thu Apr 11, 2019 3:09 pm

I have the same need, to install libc6 >=2.28, in relation to installing Palemoon browser, as I need to test a bunch of IP cameras that have java viewers and Palemoon supports java... heh. maybe there is another good javaable browser that doesnt need such a new version of libc6?

aquaboy
Level 1
Level 1
Posts: 2
Joined: Tue Apr 16, 2019 9:47 am

Re: [LM19.1] How to install libc6 >= 2.28?

Post by aquaboy » Sat Apr 20, 2019 12:35 am

Same here, I want install Palemoon as Firefox is a ram hog and my legacy extensions don't work with it.

User avatar
Moem
Level 18
Level 18
Posts: 8674
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: [LM19.1] How to install libc6 >= 2.28?

Post by Moem » Sat Apr 20, 2019 5:23 am

aquaboy wrote:
Sat Apr 20, 2019 12:35 am
Same here, I want install Palemoon as Firefox is a ram hog and my legacy extensions don't work with it.
Then you might want to try Waterfox, assuming you are on 64-bits. But new questions should really go in their own thread. Don't piggyback on existing topics.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

Post Reply

Return to “Software & Applications”