Grub error: unknown filesystem

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
afilk
Level 1
Level 1
Posts: 11
Joined: Sun Aug 30, 2015 9:59 pm

Grub error: unknown filesystem

Post by afilk » Mon Jan 14, 2019 1:00 am

Hi everybody,

I have just started having an issue where upon trying to boot Mint I get this error messageerror: unknown filesystem and am then shown a grub rescue prompt. I followed this guidehttps://mintguide.org/system/186-repair ... guyos.html, and was able to successfully boot up Mint until I got to the last terminal command.

Code: Select all

 ~ $ sudo grub-install /dev/sda
Installing for i386-pc platform.
grub-install.real: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install.real: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
grub-install.real: error: will not proceed with blocklists.
I've had this issue twice now when trying to boot my Linux, both times following that guide, but receiving an error message with the last command. I am guessing based on some error messages I've seen that this is related to the fact that I boot Mint in Legacy mode and Windows in UEFI. I have had it that way for years now and its never caused me trouble until recently, seems like it was maybe related to a Windows update.

I would really prefer not to have to reinstall Mint, and am pretty unfamiliar with all of this so some super basic advice would be great. I included some of the boot info that boot repair spat out. I am running Linux Mint 18.3 Cinnamon 32-bit, and Windows 10.

Code: Select all

ot Info Script 8f991e4 + Boot-Repair extra info      [Boot-Info 25oct2017]


============================= Boot Info Summary: ===============================

 => Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 
    553201456 of the same hard drive for core.img. core.img is at this 
    location and looks for (,gpt8)/boot/grub. It also embeds following 
    components:
    
    modules
    ---------------------------------------------------------------------------
    fshelp ext2 part_gpt biosdisk
    ---------------------------------------------------------------------------

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /EFI/Boot/bootx64.efi /EFI/Microsoft/Boot/bootmgfw.efi 
                       /EFI/Microsoft/Boot/bootmgr.efi 
                       /EFI/Microsoft/Boot/memtest.efi

sda2: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 8/2012: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda3: __________________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 
    Mounting failed:   mount: unknown filesystem type ''

sda4: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda5: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /Windows/System32/winload.exe

sda6: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Linux Mint 18.3
    Boot files:        /boot/grub/grub.cfg /etc/fstab 
                       /boot/grub/i386-pc/core.img

sda7: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        

sda8: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sda9: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                   1   976,773,167   976,773,167  ee GPT


GUID Partition Table detected.

Partition  Attrs   Start Sector    End Sector  # of Sectors System
/dev/sda1                 2,048     1,026,047     1,024,000 EFI System partition
/dev/sda2      R      1,026,048     1,107,967        81,920 -
/dev/sda3             1,107,968     1,370,111       262,144 Microsoft Reserved Partition (Windows)
/dev/sda4      R      1,370,112     2,373,631     1,003,520 Windows Recovery Environment (Windows)
/dev/sda5             2,373,632   527,300,607   524,926,976 Data partition (Windows/Linux)
/dev/sda6           527,300,608   624,957,439    97,656,832 Data partition (Linux)
/dev/sda7           624,957,440   944,082,943   319,125,504 Data partition (Linux)
/dev/sda8           944,082,944   959,707,135    15,624,192 Swap partition (Linux)
/dev/sda9      R    960,628,736   976,771,119    16,142,384 Windows Recovery Environment (Windows)

Attributes: R=Required, N=No Block IO, B=Legacy BIOS Bootable, +=More bits set

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/sda1        BC1E-64F8                              vfat       ESP
/dev/sda2        BA99-9B89                              vfat       DIAGS
/dev/sda3                                                          
/dev/sda4        78DC9B99DC9B4FEC                       ntfs       WINRETOOLS
/dev/sda5        01D0DE209309FF10                       ntfs       OS
/dev/sda6        9fa7f5f8-d05e-4bb0-96e9-b2bf1d3868e6   ext4       
/dev/sda7        16c4d71f-6e94-432f-be31-2d3c72356d74   ext4       
/dev/sda8        1f446046-db8c-40f3-9572-e95807347773   swap       
/dev/sda9        1C6E00D86E00AC98                       ntfs       PBR Image

hcentaur13
Level 4
Level 4
Posts: 463
Joined: Sat May 18, 2013 5:13 pm

Re: Grub error: unknown filesystem

Post by hcentaur13 » Mon Jan 14, 2019 4:26 am

partition type msdos and GPT are highly incompatible! GPT is not msdos. GPT requires grub in /efi, not MBR.

In last century partition table was the only partition type. It gets outdated now based on its unuseable limits:
Max. number of partitions: 4
max size of drive and partitions: 4 TB
only ready to install 1 operating system in MBR

New partiution type GPT knows none of these limits.
boot is located in its own partition of type FAT32. Where each installed OS gets its own directory< in tat describes the bootinformation of the OS and the bootloader. The MBR is useless.

Up to Mint 18.3 mint live boots in default to mbr, using partition type msdos. Booting mbr needs the installed system to boot to MBR too. Some mainboard manufacturer producing buggy BIOS. You have to boot manually and never use the default settings to get the installation medium right booting up.

Show into the BIOS boot menue. Any installation medium shows there 2 entries. One wirh UEFI and one without UEFI in its name. To get it booted right you have to select manually the right one to set up the installer to install the right installation method.

Since Mint 19 even Mint installation medium boots in default in UEFI mode and installs Mint for UEFI and create grub in /efi/UBUNTU when booted in default (UEFI).

When installed in UEFI it makes no sense to install grub in MBR.

However when you have to fix grub then you should have supergrub https://www.supergrubdisk.org/ ready and boot that up to get your installed linux up and running.

Another way is https://sourceforge.net/projects/refind/. That finds any installed OS and lets UEFI boot it when installed with gdebi.

In your installed linux you will type in a terminal
sudo grub-install
sudo update-grub
to reinstall grub.

grub-install will find the right location and type when called without parameters.

gm10
Level 18
Level 18
Posts: 8163
Joined: Thu Jun 21, 2018 5:11 pm

Re: Grub error: unknown filesystem

Post by gm10 » Mon Jan 14, 2019 5:47 am

hcentaur13 wrote:
Mon Jan 14, 2019 4:26 am
GPT requires grub in /efi, not MBR.
That's not correct, GRUB can MBR-boot from GPT just fine, but the MBR is too small to hold all of GRUB on GPT drives, so it needs a tiny extra partition (usually 1 MB although only 30k or so are needed) for storage, and as OP's error message and bootinfo shows, that partition is missing.

That does however make it doubtful that OP ever successfully booted in legacy mode and the question is why they not simply boot in UEFI mode?

afilk
Level 1
Level 1
Posts: 11
Joined: Sun Aug 30, 2015 9:59 pm

Re: Grub error: unknown filesystem

Post by afilk » Mon Jan 14, 2019 1:54 pm

gm10 wrote:
Mon Jan 14, 2019 5:47 am
That does however make it doubtful that OP ever successfully booted in legacy mode and the question is why they not simply boot in UEFI mode?
I really didn't understand the boot modes when I installed my linux system (honestly I still don't really understand them), and if I just left my start up in legacy boot mode mint started up totally fine, so I never really tried to dig into it that much after unintentionally installing in Legacy mode. I would just go into the advanced boot options to switch to booting UEFI for windows when I wanted it. I recently tried to reset my windows partition so perhaps I erased my boot drive or something in the process? I know that booting in UEFI would probably be ideal, but even if I could get the Legacy boot working again I would be happy with that. I would just rather not have to go into this grub recovery mode every time I boot.


A lot of @hcentaur13 's comments went a bit over my head. I don't really know what GPT or mdos is or which I'm using. Is MBR the same thing as Legacy?
hcentaur13 wrote:
Mon Jan 14, 2019 4:26 am

However when you have to fix grub then you should have supergrub https://www.supergrubdisk.org/ ready and boot that up to get your installed linux up and running.

Another way is https://sourceforge.net/projects/refind/. That finds any installed OS and lets UEFI boot it when installed with gdebi.

In your installed linux you will type in a terminal
sudo grub-install
sudo update-grub
to reinstall grub.

grub-install will find the right location and type when called without parameters.
My linux is already up and running. After running through the guide in my original post I got linux to start up, the problem is just persisting each time I turn on my computer. Do I still need to use one of those programs then? What do I do with them?

I'm not sure if I'm just doing this too early and need to do something else first, but I tried doing sudo grub-install without an option as you suggested and am still getting an error message

Code: Select all

Installing for i386-pc platform.
grub-install.real: error: install device isn't specified.
If there is a resource you could point me to about how to make these suggested fixes that would be greatly appreciated. I don't really understand my problem well enough to know what I should be looking for.

gm10
Level 18
Level 18
Posts: 8163
Joined: Thu Jun 21, 2018 5:11 pm

Re: Grub error: unknown filesystem

Post by gm10 » Mon Jan 14, 2019 4:52 pm

afilk wrote:
Mon Jan 14, 2019 1:54 pm
gm10 wrote:
Mon Jan 14, 2019 5:47 am
That does however make it doubtful that OP ever successfully booted in legacy mode and the question is why they not simply boot in UEFI mode?
I really didn't understand the boot modes when I installed my linux system (honestly I still don't really understand them), and if I just left my start up in legacy boot mode mint started up totally fine, so I never really tried to dig into it that much after unintentionally installing in Legacy mode. I would just go into the advanced boot options to switch to booting UEFI for windows when I wanted it. I recently tried to reset my windows partition so perhaps I erased my boot drive or something in the process? I know that booting in UEFI would probably be ideal, but even if I could get the Legacy boot working again I would be happy with that. I would just rather not have to go into this grub recovery mode every time I boot.
I'm not familiar with resetting Windows leading to partitions getting erased but I wouldn't rule it out. GRUB has most certainly always needed a BIOS boot partition on a GPT device so if you ever successfully booted via GRUB you must have "lost" that partition somehow. However, your partition table looks consistent, all partitions are aligned, that's why I said I doubted you ever really booted in legacy mode.

Anyway, see if you can boot the installation medium in UEFI mode and if that works (as it should), then I suggest to simply run https://help.ubuntu.com/community/Boot-Repair to set you up for UEFI booting. It should set it up such that you can select both Linux and Windows from the GRUB menu then.

afilk
Level 1
Level 1
Posts: 11
Joined: Sun Aug 30, 2015 9:59 pm

Re: Grub error: unknown filesystem

Post by afilk » Tue Jan 15, 2019 2:58 am

I burnt a iso image of the boot repair onto a USB as you suggested and tried to run from that. But I wasn't able to get it to boot from UEFI, just Legacy which gave me a message about needing to be in UEFI. The USB didn't show up in my boot manager when I was using UEFI. I even tried using the windows infrastructure that let's you boot from a USB to no eval. I have successfully booted the same USB in UEFI mode before as a Windows recovery drive though. Are there limitations on which format UEFI can boot from? I was using FAT32.

If not any other ideas on how to get it booting?

gm10
Level 18
Level 18
Posts: 8163
Joined: Thu Jun 21, 2018 5:11 pm

Re: Grub error: unknown filesystem

Post by gm10 » Tue Jan 15, 2019 6:16 am

Interesting, but what I actually said was to boot the Linux Mint installation medium, maybe you'll have more luck with that one (if it works you can then install boot-repair to the Linux Mint live environment as explained in the article I linked).

You can also try and go to your UEFI's settings and disable secure boot. Also make sure USB boot isn't explicitly blocked there, many UEFIs have that option.

jglen490
Level 5
Level 5
Posts: 578
Joined: Sat Jul 15, 2017 9:57 pm

Re: Grub error: unknown filesystem

Post by jglen490 » Wed Jan 16, 2019 6:21 pm

gm10 wrote:
Tue Jan 15, 2019 6:16 am
Interesting, but what I actually said was to boot the Linux Mint installation medium, maybe you'll have more luck with that one (if it works you can then install boot-repair to the Linux Mint live environment as explained in the article I linked).

You can also try and go to your UEFI's settings and disable secure boot. Also make sure USB boot isn't explicitly blocked there, many UEFIs have that option.
I don't disagree at all, but if the UEFI firmware for the motherboard references either secure boot, or fast boot, or both - make sure each entry is disabled. If UEFI is enabled in the firmware, rather than Legacy, the best solution is to use the GPT partitioning table on disk and to absolutely setup an EFI partition (fat32, about 500MB), and tell the installer to place the boot files into that EFI partition and not the MBR location. It's safe and it works and both Windows and Linux can coexist on that disk. If the EFI partition already exists because of a Windows install, or a previous Linux install with EFI, you should be in good shape. After telling the installer to build that EFI partition, if it didn't previously exist it will automatically set all the flags (to that partition) that the motherboard's firmware is looking for. It's different, but it's not terribly difficult - just remember a few, simple extra steps.

You, when installing, tell the installer where to install tha boot files on the same screen as you use to set up the partitions. There's a box near the bottom of the screen with an entry that usually defaults to the MBR (i.e., /dev/sda), but can be changed to the partition where EFI is (i.e., /dev/sda1).
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

gm10
Level 18
Level 18
Posts: 8163
Joined: Thu Jun 21, 2018 5:11 pm

Re: Grub error: unknown filesystem

Post by gm10 » Wed Jan 16, 2019 7:52 pm

jglen490 wrote:
Wed Jan 16, 2019 6:21 pm
I don't disagree at all,
I actually somewhat disagree with you. Not with any of the factual content of your post, mind you, but with the application to the OP's situation. He's already got both operating systems installed, he's just trying to recover the boot loader. So he should not use the installer in this situation.

afilk
Level 1
Level 1
Posts: 11
Joined: Sun Aug 30, 2015 9:59 pm

Re: Grub error: unknown filesystem

Post by afilk » Thu Jan 17, 2019 1:19 am

Well I've tried to boot a live installation drive on a usb and am still running into the same issue i did with the boot drive. I can only boot it in legacy mode and can't make any repairs in that mode. I was definitely in UEFI secure boot off, and have tried booting in a variety of ways and different methods to write the iso image with different formats. No luck. I couldn't find any boot settings limiting USB booting, and I have boot this same USB drive in UEFI mode before as a windows installation drive, so I'm unsure what is happening there.

Is there a way to just fix up legacy boot so that I don't get grub errors, since I haven't been successful UEFI booting my drives?

gm10
Level 18
Level 18
Posts: 8163
Joined: Thu Jun 21, 2018 5:11 pm

Re: Grub error: unknown filesystem

Post by gm10 » Thu Jan 17, 2019 3:49 am

afilk wrote:
Thu Jan 17, 2019 1:19 am
Well I've tried to boot a live installation drive on a usb and am still running into the same issue i did with the boot drive. I can only boot it in legacy mode and can't make any repairs in that mode.
There's a known issue with the Mint 64-bit installation media on devices with a 32-bit UEFI, that might explain your trouble to boot the USB. Maybe post your inxi -SMp output.

But what did you mean you couldn't make any repairs? Did you install boot-repair and run it? What did it say? You got the log?

You can even force an UEFI boot using boot-repair (maybe it's just the USB that it doesn't let you boot that way). For that run boot-repair again, then under Advanced options go to the GRUB location tab and force a separate /boot/efi partition, selecting /dev/sda1 (should be pre-selected).

User avatar
arvy
Level 4
Level 4
Posts: 319
Joined: Sat Mar 26, 2016 11:22 am

Re: Grub error: unknown filesystem

Post by arvy » Thu Jan 17, 2019 6:20 am

afilk wrote:
Tue Jan 15, 2019 2:58 am
I have successfully booted the same USB in UEFI mode before as a Windows recovery drive though. Are there limitations on which format UEFI can boot from? I was using FAT32.
When you say "I was using FAT32", does that mean that you used something else when you created your Mint installation media on the USB stick? If so that could explain its UEFI booting issues. Although some UEFI systems can "see", read and boot from other partition formats, FAT partitions (either 12, 16 or 32) are the only ones that are supported as a consistent requirement for all of them.

Although I generally use MBR booting myself, as you already have Windows installed for UEFI-GPT booting, gm10's recommendation to get Mint properly set up to boot the same way seems like the best advice in the circumstances. A "mixture" of the two on the same system is almost always problematic.
System: Asus ROG Maximus XI Code mobo, Intel i9-9900K CPU, Nvidia GTX1080 GPU, 32 GB DDR4-3600 RAM, Sumsung Pro 2x512GB NVMe & 3x1TB SSD, Mint 19.1 x64 Cinnamon

gm10
Level 18
Level 18
Posts: 8163
Joined: Thu Jun 21, 2018 5:11 pm

Re: Grub error: unknown filesystem

Post by gm10 » Thu Jan 17, 2019 6:31 am

arvy wrote:
Thu Jan 17, 2019 6:20 am
When you say "I was using FAT32", does that mean that you used something else when you created your Mint installation media on the USB stick? If so that could explain its UEFI booting issues.
Good point, I hadn't caught that. You should write the Mint .iso unmodified to the USB, the official installation instructions recommend this tool: https://www.balena.io/etcher/, or if you do it from within your LM18.3 you can simply use "USB Image Writer" from the menu.

jglen490
Level 5
Level 5
Posts: 578
Joined: Sat Jul 15, 2017 9:57 pm

Re: Grub error: unknown filesystem

Post by jglen490 » Thu Jan 17, 2019 1:48 pm

When installing something, especially and OS, from a device where you boot to that device directly from the motherboard's firmware (UEFI, BIOS) a very basic filesystem works the best for the firmware to understand the structure. It's not that fat32 is superior to anything else, but rather it's very basic and common.

When booting an install device - apply the KIS(S) principle.
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

User avatar
arvy
Level 4
Level 4
Posts: 319
Joined: Sat Mar 26, 2016 11:22 am

Re: Grub error: unknown filesystem

Post by arvy » Thu Jan 17, 2019 5:45 pm

It's not a question of anyone's judgement about the relative simplicity of various file systems. It's just a matter of being aware that the UEFI specs require the ability to read and boot from FAT partitions as I said. The specs don't prohibit other capabilities, but if you use any other boot partition format, there is no similar assurance that your system will be able to understand and boot from it in UEFI mode. Additional limitations on removable flash drive formatting are also imposed by OS handling capabilities. Until very recently, for example, Windows was able to "see" and mount only a single partition on any removable flash drive regardless of its format.
System: Asus ROG Maximus XI Code mobo, Intel i9-9900K CPU, Nvidia GTX1080 GPU, 32 GB DDR4-3600 RAM, Sumsung Pro 2x512GB NVMe & 3x1TB SSD, Mint 19.1 x64 Cinnamon

Post Reply

Return to “Installation & Boot”