Wake-on-lan not persistent [Solved]

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read how to get help
Post Reply
robeirne
Level 1
Level 1
Posts: 1
Joined: Mon Jan 14, 2019 2:13 am

Wake-on-lan not persistent [Solved]

Post by robeirne » Mon Jan 14, 2019 2:56 am

I have spent 2 frustrating days solving this so I thought I would record my findings. I have 3 computers (2 desktops with the same motherboard/NIC) and an old core2duo laptop all running Mint 19 Mate. On the laptop WOL works fine after enabling it with

Code: Select all

sudo ethtool -s enp0sxx wol g
and is persistent after shutdowns. The same was not true for the 2 desktops. I tried the procedure as described in the tutorial but it was not persistent and the "Wake-on:" would always revert to "d" after a shutdown.

After trying numerous methods to solve this I finally found the following post in this forum. Creating the executable file in /etc/network/if-up.d/ solved the problem. Both computers now start when requested.

I hope this can help someone else

Post Reply

Return to “Other networking topics”