Linux Mint 18.3 Freeze during Shutdown. [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
yodajamir
Level 1
Level 1
Posts: 4
Joined: Mon Jan 14, 2019 11:40 am

Linux Mint 18.3 Freeze during Shutdown. [SOLVED]

Post by yodajamir » Mon Jan 14, 2019 12:04 pm

I installed Linux Mint 18.3 and deleted my windows 7. But when I shut down the laptop, the Linux icon appears and it just stays frozen like that from the third dot. I tried following some online solutions but so it isn't helping and more so, I am so new at this that I don't know how to do the ones they suggest.

Anyhow, this is my system (I had to google the command to get this too) :

Code: Select all

System:    Host: Aspire-E3-112M Kernel: 4.15.0-43-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Acer product: Aspire E3-112M v: V1.16
           Mobo: Acer model: R2 v: Type2 - A01 Board Version Bios: Insyde v: V1.16 date: 10/20/2015
CPU:       Dual core Intel Celeron N2840 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8663
           clock speeds: max: 2582 MHz 1: 1652 MHz 2: 1790 MHz
Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel Bay Trail GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-43-generic
Network:   Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.5% used) ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 66G used: 7.8G (13%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 4.17GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 186 Uptime: 33 min Memory: 1304.2/3830.8MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
I hope someone can help me with this annoying problem.
Last edited by yodajamir on Tue Jan 15, 2019 1:05 am, edited 2 times in total.

deepakdeshp
Level 15
Level 15
Posts: 5505
Joined: Sun Aug 09, 2015 10:00 am

Re: Linux Mint 18.3 Freeze during Shutdown.

Post by deepakdeshp » Mon Jan 14, 2019 12:12 pm

What about init 0 or shutdown 0 commands from terminal?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
administrollaattori
Level 15
Level 15
Posts: 5877
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Linux Mint 18.3 Freeze during Shutdown.

Post by administrollaattori » Mon Jan 14, 2019 12:12 pm

Add pci=nomsi option to the /etc/default/grub lines

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="pci=nomsi"
GRUB_CMDLINE_LINUX="pci=nomsi"

Code: Select all

gksu xdg-open /etc/default/grub
After editing, run

Code: Select all

sudo update-grub
PS. Changes are working from the second shutdown.

yodajamir
Level 1
Level 1
Posts: 4
Joined: Mon Jan 14, 2019 11:40 am

Re: Linux Mint 18.3 Freeze during Shutdown.

Post by yodajamir » Mon Jan 14, 2019 12:27 pm

administrollaattori wrote:
Mon Jan 14, 2019 12:12 pm
Add pci=nomsi option to the /etc/default/grub lines

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="pci=nomsi"
GRUB_CMDLINE_LINUX="pci=nomsi"

Code: Select all

gksu xdg-open /etc/default/grub
After editing, run

Code: Select all

sudo update-grub
PS. Changes are working from the second shutdown.
Hi, thanks. I tried this and it works-ish. As in while botting up or shutting down, some weird 'Matrix' movie like codes come up on the screen but it does shut down.

Below is the code, after I did the edit you suggested. Is this correct?

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="pci=nomsi"
GRUB_CMDLINE_LINUX="pci=nomsi"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1" 
Last edited by yodajamir on Mon Jan 14, 2019 1:13 pm, edited 1 time in total.

yodajamir
Level 1
Level 1
Posts: 4
Joined: Mon Jan 14, 2019 11:40 am

Re: Linux Mint 18.3 Freeze during Shutdown.

Post by yodajamir » Mon Jan 14, 2019 12:40 pm

deepakdeshp wrote:
Mon Jan 14, 2019 12:12 pm
What about init 0 or shutdown 0 commands from terminal?
Thanks. But this didn't work. Same frozen screen. Had to force shutdown.

sleeper12
Level 5
Level 5
Posts: 803
Joined: Thu May 25, 2017 3:22 pm

Re: Linux Mint 18.3 Freeze during Shutdown.

Post by sleeper12 » Mon Jan 14, 2019 1:11 pm


yodajamir
Level 1
Level 1
Posts: 4
Joined: Mon Jan 14, 2019 11:40 am

Re: Linux Mint 18.3 Freeze during Shutdown.

Post by yodajamir » Mon Jan 14, 2019 1:23 pm

Thank. Tried it, but it gave me this:

Code: Select all

pangmalu@Aspire-E3-112M ~ $ sudo gedit /etc/default/grub/
[sudo] password for pangmalu: 
sudo: gedit: command not found 

sleeper12
Level 5
Level 5
Posts: 803
Joined: Thu May 25, 2017 3:22 pm

Re: Linux Mint 18.3 Freeze during Shutdown.

Post by sleeper12 » Mon Jan 14, 2019 2:08 pm

Guess you don't have gedit installed. You can install it in Package Manager if you want to try that fix again.

User avatar
administrollaattori
Level 15
Level 15
Posts: 5877
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Linux Mint 18.3 Freeze during Shutdown. [SOLVED]

Post by administrollaattori » Tue Jan 15, 2019 4:50 pm

Just a comment: Do not use sudo program, because it causes privilege problems. Use gksu in Mint 18 and xed admin:// in Mint 19.

sleeper12
Level 5
Level 5
Posts: 803
Joined: Thu May 25, 2017 3:22 pm

Re: Linux Mint 18.3 Freeze during Shutdown. [SOLVED]

Post by sleeper12 » Tue Jan 15, 2019 5:06 pm

Marked solved, how I dunno. :roll:

Post Reply

Return to “Newbie Questions”