Trying to compile Mate's QtWebEngine package from source, getting errors

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
very
Level 1
Level 1
Posts: 17
Joined: Sat Jun 10, 2017 9:50 pm

Trying to compile Mate's QtWebEngine package from source, getting errors

Post by very » Mon Jan 14, 2019 6:10 pm

I start by getting the package libqt5webengine5 from source:

Code: Select all

apt-get source libqt5webengine5
I got an error early on that it could not find the Netscape Portable Runtime library files so I figured out i needed this package:

Code: Select all

sudo apt-get install libnspr4-dev
Then I start compiling

Code: Select all

$ qmake qtwebengine.pro
$ make
and it runs for a while until it get to the directory

Code: Select all

qtwebengine-opensource-src-5.9.5+dfsg/src/core/
and it throws this error:

Code: Select all

Project ERROR: Unknown module(s) in QT_PRIVATE: quick-private
I narrowed it down to this command, but I can't figure out what it means:

Code: Select all

/usr/lib/qt5/bin/qmake -o Makefile.core_generator ./qtwebengine-opensource-src-5.9.5+dfsg/src/core/core_generator.pro
Project ERROR: Unknown module(s) in QT_PRIVATE: quick-private
I've tried installing all the libqt5quick* packages that I could find, but none of them are fixing this. Does anyone have any clues that can drop me? Thx

very
Level 1
Level 1
Posts: 17
Joined: Sat Jun 10, 2017 9:50 pm

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by very » Sat Feb 02, 2019 10:01 pm

still getting the same error, i have no idea why I can't compile this from source.

gm10
Level 18
Level 18
Posts: 8163
Joined: Thu Jun 21, 2018 5:11 pm

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by gm10 » Sun Feb 03, 2019 3:15 am

To get dependencies needed to build the package, run:

Code: Select all

apt build-dep libqt5webengine5

very
Level 1
Level 1
Posts: 17
Joined: Sat Jun 10, 2017 9:50 pm

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by very » Sun Apr 07, 2019 12:17 pm

Okay, getting a little bit further, still getting errors through, (this is a fresh build environment)

Code: Select all

mint@mint-vbox:~/qtwebengine-opensource-src-5.9.5+dfsg$ qmake qtwebengine.pro 
Info: creating stash file /home/mint/qtwebengine-opensource-src-5.9.5+dfsg/.qmake.stash
Info: creating cache file /home/mint/qtwebengine-opensource-src-5.9.5+dfsg/.qmake.cache

Running configuration tests...
Checking for ALSA... yes
Checking for embedded... no
Checking for PulseAudio >= 0.9.10... yes
Checking for Python 2... /usr/bin/python2
Checking for system ninja... yes
Checking for opus... yes
Checking for re2... yes
Checking for libwebp and libwebpdemux... yes
Done running configuration tests.

Configure summary:

Qt WebEngine:
  Embedded build ......................... no
  Pepper Plugins ......................... yes
  Printing and PDF ....................... yes
  Proprietary Codecs ..................... no
  Spellchecker ........................... yes
  WebRTC ................................. yes
  Using system ninja ..................... yes
  ALSA ................................... yes
  PulseAudio ............................. yes
  System libraries:
    re2 .................................. yes
    ICU .................................. no
    libwebp and libwebpdemux ............. yes
    Opus ................................. yes
    ffmpeg ............................... no

Qt is now configured for building. Just run 'make'.
Once everything is built, Qt is installed.
You should NOT run 'make install'.
Note that this build cannot be deployed to other machines or devices.

Prior to reconfiguration, make sure you remove any leftovers from
the previous build.

Running configure tests
Checking for alsa... yes
Checking for khr... yes
Checking for libvpx... no
Checking for re2... yes
Checking for snappy... yes
Checking for winversion... no
Compatible system libvpx not found. Using Chromium's copy.
System library dependencies:
  Optional system libraries used ..... libwebp opus re2 harfbuzz minizip zlib libxslt libxml2 libevent jsoncpp protobuf snappy
  Optional bundled libraries used .... ffmpeg icu libvpx
Configurable features:
  Geolocation ........................ Enabled
  Certificate handling ............... Using system NSS
Then the make...

Code: Select all

mint@mint-vbox:~/qtwebengine-opensource-src-5.9.5+dfsg$ make
...
...
make[3]: Entering directory '/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core'
make[3]: Nothing to be done for 'first'.
make[3]: Leaving directory '/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core'
( test -e Makefile.gn_run || /usr/lib/qt5/bin/qmake -o Makefile.gn_run /home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core/gn_run.pro ) && make -f Makefile.gn_run 
Running python /home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/3rdparty/chromium/build/linux/unbundle/replace_gn_files.py --system-libraries re2 yasm
Project MESSAGE: Running: /home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/3rdparty/chromium/tools/gn/out/Release/gn gen /home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core/Release --script-executable=/usr/bin/python2 --args='use_qt=true is_component_build=false is_shared=true enable_media_router=false enable_nacl=false enable_remoting=false enable_web_speech=false use_experimental_allocator_shim=false use_allocator="none" v8_use_external_startup_data=false treat_warnings_as_errors=false enable_basic_printing=true enable_print_preview=true enable_pdf=true enable_plugins=true enable_widevine=true enable_spellcheck=true enable_webrtc=true symbol_level=0 remove_webcore_debug_symbols=true remove_v8base_debug_symbols=true use_cups=false use_gconf=false use_gio=false use_gnome_keyring=false use_kerberos=false linux_use_bundled_binutils=false use_nss_certs=true use_openssl_certs=false no_delete_null_pointer_checks=true is_clang=false custom_toolchain="/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/toolchain:target" host_toolchain="/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/toolchain:host" host_cpu="x64" pkg_config="pkg-config" use_system_zlib=true use_system_minizip=true use_system_libpng=true use_system_libjpeg=true use_system_harfbuzz=true use_pulseaudio=true use_alsa=true use_system_libffi=false use_system_libevent=true use_system_libwebp=true use_system_libxml=true use_system_libxslt=true use_system_opus=true use_system_snappy=true use_system_re2=true use_system_re2=true use_system_yasm=true linux_link_libpci=true use_sysroot=false enable_session_service=false enable_notifications=false toolkit_views=false use_gold=false is_debug=false qtwebengine_target="/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core/Release:QtWebEngineCore"' --root=/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/3rdparty/chromium 
ERROR at the command-line "--args":1:1300: Build argument has no effect.
use_qt=true is_component_build=false is_shared=true enable_media_router=false enable_nacl=false enable_remoting=false enable_web_speech=false use_experimental_allocator_shim=false use_allocator="none" v8_use_external_startup_data=false treat_warnings_as_errors=false enable_basic_printing=true enable_print_preview=true enable_pdf=true enable_plugins=true enable_widevine=true enable_spellcheck=true enable_webrtc=true symbol_level=0 remove_webcore_debug_symbols=true remove_v8base_debug_symbols=true use_cups=false use_gconf=false use_gio=false use_gnome_keyring=false use_kerberos=false linux_use_bundled_binutils=false use_nss_certs=true use_openssl_certs=false no_delete_null_pointer_checks=true is_clang=false custom_toolchain="/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/toolchain:target" host_toolchain="/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/toolchain:host" host_cpu="x64" pkg_config="pkg-config" use_system_zlib=true use_system_minizip=true use_system_libpng=true use_system_libjpeg=true use_system_harfbuzz=true use_pulseaudio=true use_alsa=true use_system_libffi=false use_system_libevent=true use_system_libwebp=true use_system_libxml=true use_system_libxslt=true use_system_opus=true use_system_snappy=true use_system_re2=true use_system_re2=true use_system_yasm=true linux_link_libpci=true use_sysroot=false enable_session_service=false enable_notifications=false toolkit_views=false use_gold=false is_debug=false qtwebengine_target="/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core/Release:QtWebEngineCore"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   ^---
The variable "use_system_yasm" was set as a build argument
but never appeared in a declare_args() block in any buildfile.

To view possible args, run "gn args --list <builddir>"
Done. Made 5319 targets from 1129 files in 30927ms
make[3]: Entering directory '/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core'
ninja  -C /home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core/Release QtWebEngineCore
ninja: Entering directory `/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core/Release'
ninja: error: '../../3rdparty/chromium/third_party/WebKit/Source/devtools/front_end/audits2_worker/lighthouse/lighthouse-background.js', needed by 'obj/third_party/WebKit/Source/devtools/generate_devtools_grd.inputdeps.stamp', missing and no known rule to make it
Makefile.gn_run:320: recipe for target 'run_ninja' failed
make[3]: *** [run_ninja] Error 1
make[3]: Leaving directory '/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core'
Makefile:80: recipe for target 'sub-gn_run-pro-make_first' failed
make[2]: *** [sub-gn_run-pro-make_first] Error 2
make[2]: Leaving directory '/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src/core'
Makefile:78: recipe for target 'sub-core-make_first' failed
make[1]: *** [sub-core-make_first] Error 2
make[1]: Leaving directory '/home/mint/qtwebengine-opensource-src-5.9.5+dfsg/src'
Makefile:46: recipe for target 'sub-src-make_first' failed
make: *** [sub-src-make_first] Error 2

User avatar
phd21
Level 19
Level 19
Posts: 9026
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by phd21 » Sun Apr 07, 2019 1:36 pm

Hi very,

I just read your post and the good replies to it. Here are my thoughts on this as well.

OOC (Out of curiosity), why are you trying to compile QTWebEngine when the current version for your version of Linux Mint is in the Software Manager or Synaptic Package Manager (SPM)?
Last edited by phd21 on Mon Apr 08, 2019 10:56 am, edited 1 time in total.
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

very
Level 1
Level 1
Posts: 17
Joined: Sat Jun 10, 2017 9:50 pm

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by very » Mon Apr 08, 2019 10:10 am

Ah, yes, I would like to eventually like to modify the functionality of the engine itself. But before I can do that, I need to get it to compile without modification first. And I've been having trouble getting that to work.

User avatar
phd21
Level 19
Level 19
Posts: 9026
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by phd21 » Mon Apr 08, 2019 11:05 am

Hi very,

Okay, that is "very" ambitious of you (pardon the pun).

I have tried to compile QtWebEngine before but there are many options for this including various proprietary video and audio codecs that are not included with the various QT versions which fortunately the Linux Mint repositories have included. These proprietary video and audio codecs must be installed before compiling for QTWebEngine to use.

I have noticed that one of the Linux Mint editions either Mate or Xfce for some reason is using a slightly older version of QT than the other Linux Mint editions?

The last time I tried this was for the "QT Webflix app" for playing Netflix and other streaming services which by the way works well in Linux Mint 19.x without having to compile QtWebEngine.

gort818/qtwebflix: A qt webengine program for netflix
- review the github "issues" tab as well
https://github.com/gort818/qtwebflix

Here is what I could find on this.

QtWebEngine/How to Try - Qt Wiki
https://wiki.qt.io/QtWebEngine/How_to_Try

How to Compile Qt from Source Code on Linux | ICS
https://www.ics.com/blog/how-compile-qt ... code-linux

Cross Compiling Qt 5.10.1 for Raspberry Pi 3 on Ubuntu 18.04 LTS – Vitorian LLC
http://www.vitorian.com/archives/653


Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

very
Level 1
Level 1
Posts: 17
Joined: Sat Jun 10, 2017 9:50 pm

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by very » Fri May 03, 2019 7:20 pm

Okay, thanks for the help with this. I think I will try to see if it compiles on a fresh install of Cinnamon, like you said maybe the version is off with Mate. I appreciate the advice, it's funny how hard it is to do this one simple thing, most foss projects are relatively easy to compile.

User avatar
phd21
Level 19
Level 19
Posts: 9026
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by phd21 » Fri May 03, 2019 7:54 pm

Hi very,

You are "very" welcome...

Let us know how it goes. I still do not know why you need to compile this as Linux Mint 19.x does have a good recent version already available in the Software Manager or Synaptic Package Manager (SPM).
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

very
Level 1
Level 1
Posts: 17
Joined: Sat Jun 10, 2017 9:50 pm

Re: Trying to compile Mate's QtWebEngine package from source, getting errors

Post by very » Tue May 07, 2019 5:20 pm

I greatly appreciate your help with this, thank you, but trying to compile on the Linux Mint Cinnamon gave the same error.

The reason I want to compile this from source is to make modifications to the engine itself. But i won't be able to make changes to the engine if I can't get the un-modified version to compile first.

Post Reply

Return to “Software & Applications”