gscanbus failing...

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
stychokiller
Level 1
Level 1
Posts: 36
Joined: Tue Jun 30, 2015 1:00 am

gscanbus failing...

Post by stychokiller » Wed Feb 13, 2019 12:28 am

trying to run gscanbus reports the following:
(gscanbus:24782): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
A bunch of other programs have reported the same error! :x
A fresh compile and install of gscanbus from apt-get source gscanbus STILL results in the same error!
What values do I have to set GTK_FLAGS and/or GTK_LIBS to in order to correct this? :?: ./configure says it will honor
these settings, but neither GTK_FLAGS or GTK_LIBS are currently defined, and I have no idea what they should be in order
to get gscanbus compiled with GTK+2.x or GTK+ 3 symbols exclusively. :x
This problem and others just like it are from the Mate V19 repositories. :?
Can Gtk+ 2.x packages be removed completely via Synaptic in order to solve these issues? :?:
"Time flies like an arrow, fruit flies like a banana!"

stychokiller
Level 1
Level 1
Posts: 36
Joined: Tue Jun 30, 2015 1:00 am

Re: gscanbus failing...

Post by stychokiller » Wed Feb 13, 2019 7:29 pm

Further info:
gscanbus won't compile using GTK+-3 components :roll: , it will compile with GTK+-2 components, but it won't
run :x and displays the error message I already mentioned.
"Time flies like an arrow, fruit flies like a banana!"

Post Reply

Return to “Software & Applications”