Wireless problems with Lenovo ideapad 330

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
gacanovic
Level 1
Level 1
Posts: 3
Joined: Sun Mar 10, 2019 10:18 am

Wireless problems with Lenovo ideapad 330

Post by gacanovic » Sun Mar 10, 2019 10:29 am

Hello, all
i`m new to Linux and i just found this forum and i hope it will help me. Today, i installed Linux Mint 19.1 , Cinnamon edition on my new Lenovo ideapad 330 laptop, but my wifi is not working at all. I tried few options that i found on this forum but did not have any succes, so i decided to open up this thread. Here is my inxi:

Code: Select all

System:
  Host: stefan-komp Kernel: 4.15.0-46-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.9 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: LENOVO product: 81D6 v: Lenovo ideapad 330-15AST 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <filter> 
  UEFI [Legacy]: LENOVO v: 8UCN09WW date: 07/27/2018 
Battery:
  ID-1: BAT0 charge: 20.5 Wh condition: 31.0/30.0 Wh (103%) 
  model: SMP L17M2PB7 status: Discharging 
CPU:
  Topology: Dual Core model: AMD A6-9225 RADEON R4 5 COMPUTE CORES 2C+3G 
  bits: 64 type: MCP arch: Excavator L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 10400 
  Speed: 1667 MHz min/max: 1300/2600 MHz Core speeds (MHz): 1: 1939 2: 1901 
Graphics:
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo 
  driver: amdgpu v: kernel bus ID: 00:01.0 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD STONEY (DRM 3.23.0 4.15.0-46-generic LLVM 7.0.0) 
  v: 4.5 Mesa 18.2.2 direct render: Yes 
Audio:
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 
  Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:09.2 
  Sound Server: ALSA v: k4.15.0-46-generic 
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: N/A port: 2000 bus ID: 01:00.0 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo 
  driver: r8169 v: 2.3LK-NAPI port: 1000 bus ID: 02:00.0 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 119.24 GiB used: 6.95 GiB (5.8%) 
  ID-1: /dev/sda vendor: SK Hynix model: HFS128G32TNF-N3A0A size: 119.24 GiB 
Partition:
  ID-1: / size: 27.37 GiB used: 6.50 GiB (23.8%) fs: ext4 dev: /dev/sda1 
  ID-2: /home size: 85.21 GiB used: 228.6 MiB (0.3%) fs: ext4 dev: /dev/sda2 
  ID-3: swap-1 size: 4.22 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0 
Sensors:
  System Temperatures: cpu: 38.1 C mobo: N/A gpu: amdgpu temp: 38 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 185 Uptime: 5m Memory: 3.04 GiB used: 1.06 GiB (34.8%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27
Last edited by JeremyB on Sun Mar 10, 2019 10:30 am, edited 1 time in total.
Reason: code tags

JeremyB
Level 20
Level 20
Posts: 11121
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless problems with Lenovo ideapad 330

Post by JeremyB » Sun Mar 10, 2019 10:35 am

Check results for mokutil --sb-state as if it says Secure Boot is enabled, it will need to be disabled for the fix to work, that will require a reboot and going into BIOS settings, just disable Secure Boot, leave the Secure Boot keys alone
Then in terminal

Code: Select all

sudo apt install git dkms build-essential
git clone https://github.com/tomaspinho/rtl8821ce.git
cd rtl8821ce
sudo ./dkms-install.sh
Reboot, if it doesn't work check rfkill list if it has an ideapad entry showing hard block yes, then do

Code: Select all

git clone https://github.com/jeremyb31/ideapad-laptop.git
sudo dkms add ./ideapad-laptop
sudo dkms install ideapad-laptop/1.0
echo "options ideapad_laptop override_has_hw_rfkill_switch=0" | sudo tee /etc/modprobe.d/ideapad_laptop.conf
Reboot again

gacanovic
Level 1
Level 1
Posts: 3
Joined: Sun Mar 10, 2019 10:18 am

Re: Wireless problems with Lenovo ideapad 330

Post by gacanovic » Sun Mar 10, 2019 10:37 am

When i run Secure boot test i get this message.
EFI variables are not supported on this system.

JeremyB
Level 20
Level 20
Posts: 11121
Joined: Fri Feb 21, 2014 8:17 am

Re: Wireless problems with Lenovo ideapad 330

Post by JeremyB » Sun Mar 10, 2019 10:42 am

Good, just run the other commands

gacanovic
Level 1
Level 1
Posts: 3
Joined: Sun Mar 10, 2019 10:18 am

Re: Wireless problems with Lenovo ideapad 330

Post by gacanovic » Sun Mar 10, 2019 10:51 am

Worked great after first step. Thanks a lot Jeremy.

Post Reply

Return to “Wireless”