Timeshift not restoring settings, configurations and customisations

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Arti
Level 1
Level 1
Posts: 1
Joined: Wed Apr 17, 2019 12:35 pm

Timeshift not restoring settings, configurations and customisations

Post by Arti » Wed Apr 17, 2019 12:50 pm

I am using Mint 19 64-bit Cinnamon and I have a 250gb SSD dual boot but the windows install has corrupted and since I don't use it anyway I am trying to set up a 120gb SSD as a Linux Mint only system.
I was able to do this and it booted fine (after a boot repair!) but for reasons I don't understand, although Timeshift restored all the installed programs from my 250gb drive it did not restore the settings, configurations and customisations in the programs e.g. my Thunderbird accounts, Firefox settings, etc.,not even my desktop screen settings, panel settings, etc? I tried re-installing Mint and restoring again but same problem. I even tried setting up the 120gb drive as a dual boot (it was, and worked, previously) but same problem with Timeshift. I have restored from Timeshift many times very successfully and this is the first time this has happened. Any ideas anyone, please!

Code: Select all

System:    Host: MissionControl Kernel: 4.15.0-47-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu2)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: ASUSTeK product: N53SM v: 1.0 serial: N/A
           Mobo: ASUSTeK model: N53SM v: 1.0 serial: N/A
           UEFI: American Megatrends v: N53SM.202 date: 11/03/2011
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Wireless Keyboard K270 status: Discharging
           hidpp__1: charge: N/A condition: NA/NA Wh
           model: Logitech Wireless Mouse M185 status: Discharging
CPU:       Quad core Intel Core i7-2670QM (-MT-MCP-) 
           arch: Sandy Bridge rev.7 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17560
           clock speeds: max: 3100 MHz 1: 2865 MHz 2: 2322 MHz 3: 2709 MHz
           4: 3063 MHz 5: 1611 MHz 6: 2470 MHz 7: 1913 MHz 8: 1759 MHz
Graphics:  Card: Intel 2nd Generation Core Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1440x900@59.89hz
           OpenGL: renderer: llvmpipe (LLVM 7.0, 256 bits)
           version: 3.3 Mesa 18.2.8 Direct Render: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-47-generic
Network:   Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
           driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: a000 bus-ID: 05:00.0
           IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1250.3GB (3.4% used)
           ID-1: /dev/sda model: Samsung_SSD_860 size: 250.1GB
           ID-2: /dev/sdb model: TOSHIBA_MQ01ABD1 size: 1000.2GB
Partition: ID-1: / size: 92G used: 40G (46%) fs: ext4 dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 72.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 3400
Info:      Processes: 252 Uptime: 1:39 Memory: 2570.7/15943.9MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56

ajgringo619
Level 6
Level 6
Posts: 1314
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California

Re: Timeshift not restoring settings, configurations and customisations

Post by ajgringo619 » Wed Apr 17, 2019 1:56 pm

That's because Timeshift, by default, does not backup your home directory, where all of your customizations are stored.
Mint 19.2 Cinnamon
kernel 5.0.0-25-generic
AMD FX-8350 Eight-Core w/16 GB RAM
Nvidia GeForce 960 w/2GB RAM (430.40)
Image

Post Reply

Return to “Software & Applications”