loosing external SATA/eSATA RAID box

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
oldgranola
Level 4
Level 4
Posts: 429
Joined: Fri Sep 05, 2014 1:39 am

loosing external SATA/eSATA RAID box

Post by oldgranola »

Thought I had this solved per previous post but nope. I keep loosing an Startech external RAID mode 1 box connected via SATA. Its a 2 x 1-TB 6Gbps disc setup using ext4. Using new-ish 6Gbps cables, on SATA board port 4 to an output chassis SATA port to the box. Sometimes I can get it to come up by rebooting the box, sometimes I have to reboot the whole computer which makes me think its not just the box controller. I am looking for help in discovering if it is indeed the box or system or connection or some setting somewhere. If one knows how to access the box's controller/port multiplyer, that would be great also.

Linux Mint 19.1 cinnamon kernel 4.18.0-18. Hardware/system info is in the following:
lsblk and hwinfo summary while RAID box is working as drive 'sdf'

Code: Select all

fun@fun2:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0   512M  0 part 
├─sda2   8:2    0 122.5G  0 part 
├─sda3   8:3    0   3.2G  0 part 
├─sda4   8:4    0     1M  0 part 
└─sda5   8:5    0   222G  0 part /
sdf      8:80   0 931.5G  0 disk 
sr0     11:0    1  1024M  0 rom  

fun@fun2:~$ sudo hwinfo --short
[sudo] password for fun:           
cpu:                                                            
                       AMD A8-6600K APU with Radeon(tm) HD Graphics, 4120 MHz
                       AMD A8-6600K APU with Radeon(tm) HD Graphics, 4120 MHz
                       AMD A8-6600K APU with Radeon(tm) HD Graphics, 4120 MHz
                       AMD A8-6600K APU with Radeon(tm) HD Graphics, 4120 MHz
keyboard:
  /dev/input/event2    AT Translated Set 2 keyboard
mouse:
  /dev/input/mice      Microsoft Trackball Optical
monitor:
                       LG ELECTRONICS LG TV RVU
graphics card:
                       ATI Curacao PRO [Radeon R7 370 / R9 270/370 OEM]
sound:
                       ATI Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
                       AMD FCH Azalia Controller
storage:
                       AMD FCH SATA Controller [AHCI mode]
network:
  enp4s0               Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
network interface:
  enp4s0               Ethernet network interface
  lo                   Loopback network interface
disk:
  /dev/sdf             SSI H/W RAID1
  /dev/sdd             Generic USB SM Reader
  /dev/sdb             Generic USB SD Reader
  /dev/sde             Generic USB MS Reader
  /dev/sdc             Generic USB CF Reader
  /dev/sda             ST3500320AS
partition:
  /dev/sda1            Partition
  /dev/sda2            Partition
  /dev/sda3            Partition
  /dev/sda4            Partition
  /dev/sda5            Partition
cdrom:
  /dev/sr0             HL-DT-ST DVDRAM GH22NS50
usb controller:
                       AMD FCH USB EHCI Controller
                       AMD FCH USB XHCI Controller
                       AMD FCH USB OHCI Controller
                       AMD FCH USB EHCI Controller
                       AMD FCH USB OHCI Controller
                       AMD FCH USB XHCI Controller
bios:
                       BIOS
bridge:
                       AMD Family 15h (Models 10h-1fh) Processor Function 3
                       AMD Family 15h (Models 10h-1fh) Processor Function 1
                       AMD FCH LPC Bridge
                       AMD Family 15h (Models 10h-1fh) Processor Root Complex
                       AMD Family 15h (Models 10h-1fh) Processor Function 4
                       AMD Hudson PCI to PCI bridge (PCIE port 2)
                       AMD Family 15h (Models 10h-1fh) Processor Function 2
                       AMD Hudson PCI to PCI bridge (PCIE port 0)
                       AMD Family 15h (Models 10h-1fh) Processor Function 0
                       AMD FCH PCI Bridge
                       AMD Family 15h (Models 10h-1fh) Processor Root Port
                       AMD Family 15h (Models 10h-1fh) Processor Function 5
hub:
                       Linux Foundation 3.0 root hub
                       Linux Foundation 1.1 root hub
                       Linux Foundation 2.0 root hub
                       Linux Foundation 1.1 root hub
                       Linux Foundation 3.0 root hub
                       Linux Foundation 2.0 root hub
                       Linux Foundation 2.0 root hub
                       Linux Foundation 2.0 root hub
memory:
                       Main Memory
unknown:
                       FPU
                       DMA controller
                       PIC
                       Keyboard controller
                       PS/2 Controller
                       AMD Family 15h (Models 10h-1fh) I/O Memory Management Unit
                       AMD FCH SMBus Controller
  /dev/ttyS0   
But Here's the DMESG which shows the dang box both up and then the errors when it gets dumped:

Code: Select all

dmesg -T | grep -iE '(ata|ahci)'
[Sat Apr 27 15:06:34 2019] BIOS-e820: [mem 0x00000000dd3cb000-0x00000000dd3dafff] ACPI data
[Sat Apr 27 15:06:34 2019] NODE_DATA(0) allocated [mem 0x31efd3000-0x31effdfff]
[Sat Apr 27 15:06:34 2019] Memory: 12169920K/12522296K available (12300K kernel code, 2633K rwdata, 4360K rodata, 2464K init, 2340K bss, 352376K reserved, 0K cma-reserved)
[Sat Apr 27 15:06:34 2019] libata version 3.00 loaded.
[Sat Apr 27 15:06:35 2019] acpi_cpufreq: overriding BIOS provided _PSD data
[Sat Apr 27 15:06:35 2019] Write protecting the kernel read-only data: 20480k
[Sat Apr 27 15:06:35 2019] ahci 0000:00:11.0: version 3.0
[Sat Apr 27 15:06:35 2019] ahci 0000:00:11.0: AHCI 0001.0300 32 slots 6 ports 6 Gbps 0x3f impl SATA mode
[Sat Apr 27 15:06:35 2019] ahci 0000:00:11.0: flags: 64bit ncq sntf ilck pm led clo pmp pio 
[Sat Apr 27 15:06:35 2019] scsi host0: ahci
[Sat Apr 27 15:06:35 2019] scsi host1: ahci
[Sat Apr 27 15:06:35 2019] scsi host2: ahci
[Sat Apr 27 15:06:35 2019] scsi host3: ahci
[Sat Apr 27 15:06:35 2019] scsi host4: ahci
[Sat Apr 27 15:06:35 2019] scsi host5: ahci
[Sat Apr 27 15:06:35 2019] ata1: SATA max UDMA/133 abar m2048@0xfeb0c000 port 0xfeb0c100 irq 35
[Sat Apr 27 15:06:35 2019] ata2: SATA max UDMA/133 abar m2048@0xfeb0c000 port 0xfeb0c180 irq 35
[Sat Apr 27 15:06:35 2019] ata3: SATA max UDMA/133 abar m2048@0xfeb0c000 port 0xfeb0c200 irq 35
[Sat Apr 27 15:06:35 2019] ata4: SATA max UDMA/133 abar m2048@0xfeb0c000 port 0xfeb0c280 irq 35
[Sat Apr 27 15:06:35 2019] ata5: SATA max UDMA/133 abar m2048@0xfeb0c000 port 0xfeb0c300 irq 35
[Sat Apr 27 15:06:35 2019] ata6: SATA max UDMA/133 abar m2048@0xfeb0c000 port 0xfeb0c380 irq 35
[Sat Apr 27 15:06:36 2019] ata3: SATA link down (SStatus 0 SControl 300)
[Sat Apr 27 15:06:36 2019] ata6: SATA link down (SStatus 0 SControl 300)
[Sat Apr 27 15:06:36 2019] ata5: SATA link down (SStatus 0 SControl 300)
[Sat Apr 27 15:06:36 2019] ata4: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 15:06:36 2019] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[Sat Apr 27 15:06:36 2019] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[Sat Apr 27 15:06:36 2019] ata4.15: Port Multiplier 1.2, 0x197b:0x0562 r0, 2 ports, feat 0x5/0xf
[Sat Apr 27 15:06:36 2019] ata4.00: hard resetting link
[Sat Apr 27 15:06:36 2019] ata1.00: ATA-8: ST3500320AS, SD15, max UDMA/133
[Sat Apr 27 15:06:36 2019] ata1.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 32)
[Sat Apr 27 15:06:36 2019] ata2.00: ATAPI: HL-DT-ST DVDRAM GH22NS50, TN01, max UDMA/100
[Sat Apr 27 15:06:36 2019] ata1.00: configured for UDMA/133
[Sat Apr 27 15:06:36 2019] scsi 0:0:0:0: Direct-Access     ATA      ST3500320AS      SD15 PQ: 0 ANSI: 5
[Sat Apr 27 15:06:36 2019] ata2.00: configured for UDMA/100
[Sat Apr 27 15:06:36 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sat Apr 27 15:06:36 2019] ata4.01: hard resetting link
[Sat Apr 27 15:06:37 2019] ata4.01: failed to resume link (SControl 0)
[Sat Apr 27 15:06:37 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sat Apr 27 15:06:37 2019] ata4.00: ATA-7: SSI H/W RAID1, 13211030, max UDMA/133
[Sat Apr 27 15:06:37 2019] ata4.00: 1953431552 sectors, multi 1: LBA48 
[Sat Apr 27 15:06:37 2019] ata4.00: configured for UDMA/133
[Sat Apr 27 15:06:37 2019] ata4: EH complete
[Sat Apr 27 15:06:37 2019] scsi 3:0:0:0: Direct-Access     ATA      SSI H/W RAID1    1030 PQ: 0 ANSI: 5
[Sat Apr 27 15:06:39 2019] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null)
[Sat Apr 27 15:27:29 2019] EXT4-fs (sdf): mounted filesystem with ordered data mode. Opts: (null)
[Sat Apr 27 22:47:07 2019] ata4.00: failed to read SCR 1 (Emask=0x40)
[Sat Apr 27 22:47:07 2019] ata4.01: failed to read SCR 1 (Emask=0x40)
[Sat Apr 27 22:47:07 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 22:47:08 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sat Apr 27 22:47:09 2019] ata4.01: failed to resume link (SControl 0)
[Sat Apr 27 22:47:09 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sat Apr 27 22:47:09 2019] ata4.00: configured for UDMA/133
[Sat Apr 27 22:57:14 2019] ata4.00: failed to read SCR 1 (Emask=0x40)
[Sat Apr 27 22:57:14 2019] ata4.01: failed to read SCR 1 (Emask=0x40)
[Sat Apr 27 22:57:15 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 22:57:15 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sat Apr 27 22:57:16 2019] ata4.01: failed to resume link (SControl 0)
[Sat Apr 27 22:57:16 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sat Apr 27 22:57:16 2019] ata4.00: configured for UDMA/133
[Sat Apr 27 23:07:07 2019] ata4.00: failed to read SCR 1 (Emask=0x40)
[Sat Apr 27 23:07:07 2019] ata4.01: failed to read SCR 1 (Emask=0x40)
[Sat Apr 27 23:07:07 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:07:08 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sat Apr 27 23:07:09 2019] ata4.01: failed to resume link (SControl 0)
[Sat Apr 27 23:07:09 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sat Apr 27 23:07:09 2019] ata4.00: configured for UDMA/133
[Sat Apr 27 23:17:07 2019] ata4.00: failed to read SCR 1 (Emask=0x40)
[Sat Apr 27 23:17:07 2019] ata4.01: failed to read SCR 1 (Emask=0x40)
[Sat Apr 27 23:17:07 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:17:08 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sat Apr 27 23:17:09 2019] ata4.01: failed to resume link (SControl 0)
[Sat Apr 27 23:17:09 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sat Apr 27 23:17:09 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[Sat Apr 27 23:17:09 2019] ata4.00: revalidation failed (errno=-5)
[Sat Apr 27 23:17:09 2019] ata4.15: hard resetting link
[Sat Apr 27 23:17:09 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:17:13 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sat Apr 27 23:17:13 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[Sat Apr 27 23:17:13 2019] ata4.00: revalidation failed (errno=-5)
[Sat Apr 27 23:17:13 2019] ata4.15: hard resetting link
[Sat Apr 27 23:17:14 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:17:19 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sat Apr 27 23:17:20 2019] ata4.01: failed to resume link (SControl 0)
[Sat Apr 27 23:17:20 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sat Apr 27 23:17:20 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[Sat Apr 27 23:17:20 2019] ata4.00: revalidation failed (errno=-5)
[Sat Apr 27 23:17:20 2019] ata4.00: failed to recover link after 3 tries, disabling
[Sat Apr 27 23:17:20 2019] ata4.00: disabled
[Sat Apr 27 23:17:20 2019] ata4.15: hard resetting link
[Sat Apr 27 23:17:21 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:17:21 2019] ata4.00: failed to read SCR 0 (Emask=0x40)
[Sat Apr 27 23:17:21 2019] ata4.00: failed to write SCR 1 (Emask=0x40)
[Sat Apr 27 23:17:21 2019] ata4.00: failed to clear SError.N (errno=-5)
[Sat Apr 27 23:17:21 2019] ata4.15: hard resetting link
[Sat Apr 27 23:17:21 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:17:22 2019] ata4.00: failed to read SCR 0 (Emask=0x100)
[Sat Apr 27 23:17:22 2019] ata4.00: failed to write SCR 1 (Emask=0x40)
[Sat Apr 27 23:17:22 2019] ata4.00: failed to clear SError.N (errno=-5)
[Sat Apr 27 23:17:22 2019] ata4.15: hard resetting link
[Sat Apr 27 23:17:22 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:17:23 2019] ata4.00: failed to read SCR 0 (Emask=0x40)
[Sat Apr 27 23:17:23 2019] ata4.00: failed to write SCR 1 (Emask=0x40)
[Sat Apr 27 23:17:23 2019] ata4.00: failed to clear SError.N (errno=-5)
[Sat Apr 27 23:17:23 2019] ata4.15: hard resetting link
[Sat Apr 27 23:17:23 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:17:23 2019] ata4.00: failed to read SCR 0 (Emask=0x40)
[Sat Apr 27 23:17:23 2019] ata4.00: failed to write SCR 1 (Emask=0x40)
[Sat Apr 27 23:17:23 2019] ata4.00: failed to clear SError.N (errno=-5)
[Sat Apr 27 23:17:23 2019] ata4: failed to recover PMP after 5 tries, giving up
[Sat Apr 27 23:17:23 2019] ata4.15: Port Multiplier detaching
[Sat Apr 27 23:17:23 2019] ata4.00: disabled
[Sat Apr 27 23:17:24 2019] ata4: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sat Apr 27 23:17:24 2019] ata4: EH complete
[Sat Apr 27 23:17:24 2019] ata4.00: detaching (SCSI 3:0:0:0)
[Sun Apr 28 10:27:47 2019] ata4: SATA link down (SStatus 0 SControl 300)
[Sun Apr 28 10:27:55 2019] ata4: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:27:55 2019] ata4.15: Port Multiplier 1.2, 0x197b:0x0562 r0, 2 ports, feat 0x5/0xf
[Sun Apr 28 10:27:55 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:27:55 2019] ata4.00: ATA-7: SSI H/W RAID1, 13211030, max UDMA/133
[Sun Apr 28 10:27:55 2019] ata4.00: 1953431552 sectors, multi 1: LBA48 
[Sun Apr 28 10:27:55 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[Sun Apr 28 10:27:55 2019] ata4.00: revalidation failed (errno=-5)
[Sun Apr 28 10:27:55 2019] ata4.15: hard resetting link
[Sun Apr 28 10:27:56 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:01 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:28:02 2019] ata4.01: failed to resume link (SControl 0)
[Sun Apr 28 10:28:02 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sun Apr 28 10:28:07 2019] ata4.00: qc timeout (cmd 0xec)
[Sun Apr 28 10:28:07 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[Sun Apr 28 10:28:07 2019] ata4.00: revalidation failed (errno=-5)
[Sun Apr 28 10:28:07 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:08 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:08 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:28:08 2019] ata4.00: configured for UDMA/133
[Sun Apr 28 10:28:08 2019] ata4: EH complete
[Sun Apr 28 10:28:08 2019] scsi 3:0:0:0: Direct-Access     ATA      SSI H/W RAID1    1030 PQ: 0 ANSI: 5
[Sun Apr 28 10:28:08 2019] ata4.00: failed to read SCR 1 (Emask=0x40)
[Sun Apr 28 10:28:08 2019] ata4.01: failed to read SCR 1 (Emask=0x40)
[Sun Apr 28 10:28:08 2019] ata4.00: exception Emask 0x100 SAct 0x0 SErr 0x0 action 0x6 frozen
[Sun Apr 28 10:28:08 2019] ata4.00: failed command: READ DMA
[Sun Apr 28 10:28:08 2019] ata4.00: cmd c8/00:08:00:00:00/00:00:00:00:00/e0 tag 17 dma 4096 in
[Sun Apr 28 10:28:08 2019] ata4.00: status: { DRDY ERR }
[Sun Apr 28 10:28:08 2019] ata4.00: error: { ABRT }
[Sun Apr 28 10:28:09 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:09 2019] ata4.00: hard resetting link
[Sun Apr 28 10:28:09 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:28:10 2019] ata4.01: failed to resume link (SControl 0)
[Sun Apr 28 10:28:10 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sun Apr 28 10:28:10 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[Sun Apr 28 10:28:10 2019] ata4.00: revalidation failed (errno=-5)
[Sun Apr 28 10:28:10 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:11 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:14 2019] ata4.00: hard resetting link
[Sun Apr 28 10:28:15 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:28:20 2019] ata4.00: qc timeout (cmd 0xec)
[Sun Apr 28 10:28:20 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x4)
[Sun Apr 28 10:28:20 2019] ata4.00: revalidation failed (errno=-5)
[Sun Apr 28 10:28:20 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:20 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:20 2019] ata4.00: hard resetting link
[Sun Apr 28 10:28:21 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:28:22 2019] ata4.01: failed to resume link (SControl 0)
[Sun Apr 28 10:28:22 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sun Apr 28 10:28:22 2019] ata4.00: configured for UDMA/133
[Sun Apr 28 10:28:22 2019] ata4: EH complete
[Sun Apr 28 10:28:22 2019] ata4.00: failed to read SCR 1 (Emask=0x40)
[Sun Apr 28 10:28:22 2019] ata4.01: failed to read SCR 1 (Emask=0x40)
[Sun Apr 28 10:28:22 2019] ata4.00: exception Emask 0x100 SAct 0x0 SErr 0x0 action 0x6 frozen
[Sun Apr 28 10:28:22 2019] ata4.00: failed command: READ DMA
[Sun Apr 28 10:28:22 2019] ata4.00: cmd c8/00:08:00:00:00/00:00:00:00:00/e0 tag 18 dma 4096 in
[Sun Apr 28 10:28:22 2019] ata4.00: status: { DRDY ERR }
[Sun Apr 28 10:28:22 2019] ata4.00: error: { ABRT }
[Sun Apr 28 10:28:22 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:22 2019] ata4.00: hard resetting link
[Sun Apr 28 10:28:23 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:28:24 2019] ata4.01: failed to resume link (SControl 0)
[Sun Apr 28 10:28:24 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sun Apr 28 10:28:24 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[Sun Apr 28 10:28:24 2019] ata4.00: revalidation failed (errno=-5)
[Sun Apr 28 10:28:24 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:25 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:28 2019] ata4.00: hard resetting link
[Sun Apr 28 10:28:29 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:28:29 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[Sun Apr 28 10:28:29 2019] ata4.00: revalidation failed (errno=-5)
[Sun Apr 28 10:28:29 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:29 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:34 2019] ata4.00: hard resetting link
[Sun Apr 28 10:28:34 2019] ata4.00: SATA link up 3.0 Gbps (SStatus 123 SControl 330)
[Sun Apr 28 10:28:35 2019] ata4.01: failed to resume link (SControl 0)
[Sun Apr 28 10:28:35 2019] ata4.01: SATA link down (SStatus 0 SControl 0)
[Sun Apr 28 10:28:35 2019] ata4.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[Sun Apr 28 10:28:35 2019] ata4.00: revalidation failed (errno=-5)
[Sun Apr 28 10:28:35 2019] ata4.00: failed to recover link after 3 tries, disabling
[Sun Apr 28 10:28:35 2019] ata4.00: disabled
[Sun Apr 28 10:28:35 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:36 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:36 2019] ata4.00: failed to read SCR 0 (Emask=0x40)
[Sun Apr 28 10:28:36 2019] ata4.00: failed to write SCR 1 (Emask=0x40)
[Sun Apr 28 10:28:36 2019] ata4.00: failed to clear SError.N (errno=-5)
[Sun Apr 28 10:28:36 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:37 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:37 2019] ata4.00: failed to read SCR 0 (Emask=0x40)
[Sun Apr 28 10:28:37 2019] ata4.00: failed to write SCR 1 (Emask=0x40)
[Sun Apr 28 10:28:37 2019] ata4.00: failed to clear SError.N (errno=-5)
[Sun Apr 28 10:28:37 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:37 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:38 2019] ata4.00: failed to read SCR 0 (Emask=0x100)
[Sun Apr 28 10:28:38 2019] ata4.00: failed to write SCR 1 (Emask=0x40)
[Sun Apr 28 10:28:38 2019] ata4.00: failed to clear SError.N (errno=-5)
[Sun Apr 28 10:28:38 2019] ata4.15: hard resetting link
[Sun Apr 28 10:28:38 2019] ata4.15: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:39 2019] ata4.00: failed to read SCR 0 (Emask=0x40)
[Sun Apr 28 10:28:39 2019] ata4.00: failed to write SCR 1 (Emask=0x40)
[Sun Apr 28 10:28:39 2019] ata4.00: failed to clear SError.N (errno=-5)
[Sun Apr 28 10:28:39 2019] ata4: failed to recover PMP after 5 tries, giving up
[Sun Apr 28 10:28:39 2019] ata4.15: Port Multiplier detaching
[Sun Apr 28 10:28:39 2019] ata4.00: disabled
[Sun Apr 28 10:28:39 2019] ata4: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[Sun Apr 28 10:28:39 2019] ata4: EH complete
[Sun Apr 28 10:28:39 2019] ata4.00: detaching (SCSI 3:0:0:0)
fun@fun2:~$ 

It seems to loose it at
Sat Apr 27 22:47:07 2019] ata4.00: failed to read SCR 1 (Emask=0x40)
, not long after getting it to mount.
I suppose I'll have to get another box but any help on how make it more stable, access the box directly to manage, further commands to diagnose would be great. Thanks.
btw, I have a similar box as a NAS on ethernet which works but this SATA box does not have an ethernet connector and I was hoping it would be basically an extended part of this system
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob

oldgranola
Level 4
Level 4
Posts: 429
Joined: Fri Sep 05, 2014 1:39 am

Re: loosing external SATA/eSATA RAID box

Post by oldgranola »

so discovered hdparm...

Code: Select all

sudo hdparm -I /dev/sdf

/dev/sdf:

ATA device, with non-removable media
	Model Number:       SSI H/W RAID1                           
	Serial Number:      'redacted by me' $ sudo hdparm -I /dev/sdf

/dev/sdf:

ATA device, with non-removable media
	Model Number:       SSI H/W RAID1                           
	Serial Number:      'redacted by me'
	Firmware Revision:  13211030
Standards:
	Supported: 7 6 5 4 
	Likely used: 7
Configuration:
	Logical		max	current
	cylinders	16383	16383
	heads		16	16
	sectors/track	63	63
	--
	CHS current addressable sectors:    16514064
	LBA    user addressable sectors:   268435455
	LBA48  user addressable sectors:  1953431552
	Logical  Sector size:                   512 bytes
	Physical Sector size:                   512 bytes
	device size with M = 1024*1024:      953824 MBytes
	device size with M = 1000*1000:     1000156 MBytes (1000 GB)
	cache/buffer size  = unknown
Capabilities:
	LBA, IORDY(can be disabled)
	Standby timer values: spec'd by Vendor, no device specific minimum
	R/W multiple sector transfer: Max = 1	Current = 1
	Advanced power management level: 254
	DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
	     Cycle time: min=120ns recommended=120ns
	PIO: pio0 pio1 pio2 pio3 pio4 
	     Cycle time: no flow control=240ns  IORDY flow control=120ns
Commands/features:
	Enabled	Supported:
	   *	SMART feature set
	    	Security Mode feature set
	   *	Power Management feature set
	    	Write cache
	    	Look-ahead
	   *	Host Protected Area feature set
	   *	WRITE_BUFFER command
	   *	READ_BUFFER command
	   *	NOP cmd
	   *	Advanced Power Management feature set
	    	SET_MAX security extension
	   *	48-bit Address feature set
	   *	Mandatory FLUSH_CACHE
	   *	FLUSH_CACHE_EXT
	   *	WRITE_{DMA|MULTIPLE}_FUA_EXT
	   *	Gen1 signaling speed (1.5Gb/s)
	   *	Gen2 signaling speed (3.0Gb/s)
	   *	Gen3 signaling speed (6.0Gb/s)
	   *	Software settings preservation
4B
	Firmware Revision:  13211030
Standards:
	Supported: 7 6 5 4 
	Likely used: 7
Configuration:
	Logical		max	current
	cylinders	16383	16383
	heads		16	16
	sectors/track	63	63
	--
	CHS current addressable sectors:    16514064
	LBA    user addressable sectors:   268435455
	LBA48  user addressable sectors:  1953431552
	Logical  Sector size:                   512 bytes
	Physical Sector size:                   512 bytes
	device size with M = 1024*1024:      953824 MBytes
	device size with M = 1000*1000:     1000156 MBytes (1000 GB)
	cache/buffer size  = unknown
Capabilities:
	LBA, IORDY(can be disabled)
	Standby timer values: spec'd by Vendor, no device specific minimum
	R/W multiple sector transfer: Max = 1	Current = 1
	Advanced power management level: 254
	DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
	     Cycle time: min=120ns recommended=120ns
	PIO: pio0 pio1 pio2 pio3 pio4 
	     Cycle time: no flow control=240ns  IORDY flow control=120ns
Commands/features:
	Enabled	Supported:
	   *	SMART feature set
	    	Security Mode feature set
	   *	Power Management feature set
	    	Write cache
	    	Look-ahead
	   *	Host Protected Area feature set
	   *	WRITE_BUFFER command
	   *	READ_BUFFER command
	   *	NOP cmd
	   *	Advanced Power Management feature set
	    	SET_MAX security extension
	   *	48-bit Address feature set
	   *	Mandatory FLUSH_CACHE
	   *	FLUSH_CACHE_EXT
	   *	WRITE_{DMA|MULTIPLE}_FUA_EXT
	   *	Gen1 signaling speed (1.5Gb/s)
	   *	Gen2 signaling speed (3.0Gb/s)
	   *	Gen3 signaling speed (6.0Gb/s)
	   *	Software settings preservation
---------------------------------
Check advanced power management...
$ sudo hdparm -B /dev/sdf

/dev/sdf:
 APM_level	= 254
sudo hdparm -B /dev/sdf gave 254 which I understand is the highest IO level for advanced power management. Could going to sleep be the problem? Any sense in turning it off with 255? I think that would revert the sata to ata-7, loosing speed management correct?
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob

oldgranola
Level 4
Level 4
Posts: 429
Joined: Fri Sep 05, 2014 1:39 am

Re: loosing external SATA/eSATA RAID box

Post by oldgranola »

argh! it even disconnects after an hour if forced to 255 ata-7 via hdparm. No clue.
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob

Post Reply

Return to “Hardware Support”