Error running Mendeley Desktop

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
carloscps
Level 1
Level 1
Posts: 1
Joined: Mon Jun 03, 2019 9:33 am

Error running Mendeley Desktop

Post by carloscps » Mon Jun 03, 2019 9:36 am

Hello!

I've installed Mendeley Desktop 1.19.4 (via .deb file using GDebi Package Installer). It appears to be successfully installed, but when I try to run the software, I get these messages:

/usr/bin/../../opt/mendeleydesktop/bin/mendeleydesktop: /lib/i386-linux-gnu/libdbus-1.so.3: no version information available (required by /usr/bin/../../opt/mendeleydesktop/lib/qt/libQt5WebEngineCore.so.5)
/usr/bin/../../opt/mendeleydesktop/bin/mendeleydesktop: relocation error: /usr/bin/../../opt/mendeleydesktop/lib/qt/libQt5WebEngineCore.so.5: symbol _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEED1Ev, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

I'm using Linux Mint 17 Qiana, Cinnamon 32-bit

I appreciate any help I can get!

deepakdeshp
Level 14
Level 14
Posts: 5252
Joined: Sun Aug 09, 2015 10:00 am

Re: Error running Mendeley Desktop

Post by deepakdeshp » Mon Jun 03, 2019 4:28 pm

Just to say that Mint 17,.x is out of support now.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

deepakdeshp
Level 14
Level 14
Posts: 5252
Joined: Sun Aug 09, 2015 10:00 am

Re: Error running Mendeley Desktop

Post by deepakdeshp » Sat Jul 13, 2019 8:27 am

Usually only one desktop runs on a machine smoothly. Two or more may create problem.
Mint 17 is out of support now and won't get any updates. Please upgrade to 18 or preferably 19 which will be supported for 4 to 5 years.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
karlchen
Level 20
Level 20
Posts: 10859
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Error running Mendeley Desktop

Post by karlchen » Sat Jul 13, 2019 8:59 am

supported for 4 to 5 years.
It is very easy retrieving when the official support for each available Mint release will end precisely on this Mint webpage: Linux Mint Releases
--
Usually only one desktop runs on a machine smoothly. Two or more may create problem.
Though I have not quite figured out what Mendeley Desktop is precisely, this webpage does not read as if it were a desktop environment like Cinnamon, Mate, KDE or xfce. seems to be more like a toolbox to me. Maybe I'm wrong ...
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Ubuntu 18.04.2 32-bit Mate Desktop, Total Commander 9.22a 32-bit
Windows? - 1 window in every room

Hoser Rob
Level 14
Level 14
Posts: 5278
Joined: Sat Dec 15, 2012 8:57 am

Re: Error running Mendeley Desktop

Post by Hoser Rob » Sat Jul 13, 2019 10:04 am

Not only is Mint 17 end of life (you need to install a newer release ASAP, you're asking to be hacked), according to their dl page ...

https://www.mendeley.com/download-desktop/Linux/

... the Ubuntu versions supported are 16.04 and 17.04. Mint 17 is Ubuntu 14.04 based, and given the general lack of backwards compatibility in Linux, it's not 100% a surprise it doesn;'t work.

I don;t know much about this product but I'm not bowled over by their Linux docs on their site.

User avatar
trytip
Level 10
Level 10
Posts: 3405
Joined: Tue Jul 05, 2016 1:20 pm

Re: Error running Mendeley Desktop

Post by trytip » Sat Jul 13, 2019 11:30 am

i wouldn't go screaming the sky is falling, i too have mint 17.3 mate and will keep it as a souvenir on my backup pc, and NO, no one will hack me i'm positive of that.

but installing this desktop is not a good idea. first of all they require "To use Mendeley you’ll need to register." and i don't like that but they also track you on their site with optimizely.com and use high prices for document storage starting from $55 for 5GB, that's way too much considering you can get 15GB for free from a google account.
Image

deepakdeshp
Level 14
Level 14
Posts: 5252
Joined: Sun Aug 09, 2015 10:00 am

Re: Error running Mendeley Desktop

Post by deepakdeshp » Sat Jul 13, 2019 5:12 pm

trytip wrote:
Sat Jul 13, 2019 11:30 am
i wouldn't go screaming the sky is falling, i too have mint 17.3 mate and will keep it as a souvenir on my backup pc, and NO, no one will hack me i'm positive of that.

but installing this desktop is not a good idea. first of all they require "To use Mendeley you’ll need to register." and i don't like that but they also track you on their site with optimizely.com and use high prices for document storage starting from $55 for 5GB, that's way too much considering you can get 15GB for free from a google account.
Why the insistence on 17.3? It's not getting any updates after all. Isn't it better to upgrade to 18 or 19?
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Hoser Rob
Level 14
Level 14
Posts: 5278
Joined: Sat Dec 15, 2012 8:57 am

Re: Error running Mendeley Desktop

Post by Hoser Rob » Sun Jul 14, 2019 9:29 am

trytip wrote:
Sat Jul 13, 2019 11:30 am
i wouldn't go screaming the sky is falling, i too have mint 17.3 mate and will keep it as a souvenir on my backup pc, and NO, no one will hack me i'm positive of that...
That isn't the case here IMO nor is it the case with the vast majority of people of people running it asking questions here, as is patently made obvious by the fact that they want to install software on it.

User avatar
trytip
Level 10
Level 10
Posts: 3405
Joined: Tue Jul 05, 2016 1:20 pm

Re: Error running Mendeley Desktop

Post by trytip » Sun Jul 14, 2019 11:51 am

deepakdeshp wrote:
Sat Jul 13, 2019 5:12 pm
Why the insistence on 17.3? It's not getting any updates after all. Isn't it better to upgrade to 18 or 19?
i'm sentimental like that. i do have an updated mint 19.1 cinnamon with amd ryzen in it, but the mint 17.3 mate i spent a long time customizing it to look like a polished silver heirloom :lol: so i will keep it on my 2007 pc until the day it doesn't boot, it's the perfect companion for that since i'm only able to use 3.25 GB RAM. it served me well since 2009 and i don't want to throw it away. i'm not in the least worried about being hacked. if i was running windows 3.1 maybe i'd worry a little but not from a distro that just had an EOL

Image

Image
Image

gm10
Level 17
Level 17
Posts: 7469
Joined: Thu Jun 21, 2018 5:11 pm

Re: Error running Mendeley Desktop

Post by gm10 » Sun Jul 14, 2019 1:47 pm

deepakdeshp wrote:
Sat Jul 13, 2019 5:12 pm
Why the insistence on 17.3? It's not getting any updates after all. Isn't it better to upgrade to 18 or 19?
To be exact it's still receiving ESM support from Ubuntu but that - as well as the regular support - only ever affect a small part of the repository, so I agree that you should always update as soon as possible if that is a concern (which it should be for most regular desktop use cases).
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

Post Reply

Return to “Software & Applications”