Time is not correct

Questions about other topics - please check if your question fits better in another category before posting here
Forum rules
Before you post please read how to get help
Post Reply
Arp
Level 3
Level 3
Posts: 125
Joined: Mon Mar 11, 2013 8:41 am

Time is not correct

Post by Arp »

Hi,

I run Mint 19.1 cinnamon. I do have the ntp service running, also restarted it, but it shows more than it actually is. It looks a bit like it is showing UTC+4 instead of UTC+2. How can I check the reason for that? Optimally, only in the terminal, since I work remotely on it. How can I see which region is set? Ideally, it should also still work with ntp, so I don't have to set the time everytime it changes to/from DST.

Thanks.
User avatar
Pierre
Level 20
Level 20
Posts: 10599
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Time is not correct

Post by Pierre »

in Terminal type timedatectl to see what those settings are currently, set to.

you can then use that command with an appendix to reset those settings:
https://www.maketecheasier.com/timedate ... ate-linux/
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
User avatar
karlchen
Level 21
Level 21
Posts: 12825
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Time is not correct

Post by karlchen »

Hello, Arp.

After I had installed Mint 19.1 only 2 days ago and rebooted, I came across the problem as well.
In fact, the cause is that on Mint 19.1 both services are enabled: ntp service and systemd-timesyncd.service.
On genuine Ubuntu 18.04 ntp is not even installed.
On Mint 19.1 ntp and timesyncd get into each other's way.
The solution in my case was to stop and to disable the ntp service and to restart the timesyncd service.
This is done with the help of the command systemctl.

Here are the commandlines:
Stopping the ntp service, disabling it and checking its status:

Code: Select all

systemctl status ntp.service
sudo systemctl stop ntp.service
sudo systemctl disable ntp.service
systemctl status ntp.service
Starting the service systemd-timesyncd and checking its status:

Code: Select all

systemctl status systemd-timesyncd.service
sudo systemctl start systemd-timesyncd.service
systemctl status systemd-timesyncd.service
Regards,
Karl
Last edited by karlchen on Fri Jun 21, 2019 12:23 pm, edited 3 times in total.
Reason: added the commandlines used here to disable ntp.service and to restart timesyncd
Image
Linux Mint 19.3 64-bit Cinnamon, Total Commander 9.51 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)
Post Reply

Return to “Other topics”