steam wont launch error Linux Mint 64 bit

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
ttautel01
Level 1
Level 1
Posts: 1
Joined: Sun Jul 14, 2019 2:08 am

steam wont launch error Linux Mint 64 bit

Post by ttautel01 » Sun Jul 14, 2019 2:18 am

I just recently got a new graphics card and initially steam and all its games would open and run (although it was horrible resolution and very slow running). Now it was time to I went to Nvidia official website and they say my system should be using driver version 430.34 but the latest version on https://launchpad.net/~graphics-drivers ... ubuntu/ppa was 430.26, after download steam ceased to respond when i clicked on it to open. I then downloaded 418.56 driver to see if that would work any better, when i click on steam now i get the small steam update box which disappears quickly and steam never opens. Ive looked everywhere but all the solutions are for Ubuntu which i suppose is different from mint and none of them have worked for me. I dont know much about whats going on and desperately need help from the community. please forgive any ignorance, im new to this.

EDIT: idk what it means but i know i have x86_64-linux-gnu and not i386 although i did download i386 libraries accidentally when trying to use solutions that worked for other people

Code: Select all

tyler@Tylers-computer:~$ steam
Running Steam on linuxmint 19.1 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
[2019-07-14 01:19:50] Startup - updater built Jun 17 2019 23:31:08
SteamUpdateUI: An X Error occurred
X Error of failed request:  GLXBadContext
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  154 (GLX)
Minor opcode of failed request:  3 (X_GLXCreateContext)
Value in failed request:  0x0
Serial number of failed request:  42
xerror_handler: X failed, continuing
Major opcode of failed request:  154 (GLX)
Minor opcode of failed request:  6 (X_GLXIsDirect)
Serial number of failed request:  43
xerror_handler: X failed, continuing
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2019-07-14 01:19:50] Checking for update on startup
[2019-07-14 01:19:50] Checking for available updates...
[2019-07-14 01:19:50] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2019-07-14 01:19:51] Download skipped: /client/steam_client_ubuntu12 version 1560817063, installed version 1560817063
[2019-07-14 01:19:51] Nothing to do
[2019-07-14 01:19:51] Verifying installation...
[2019-07-14 01:19:51] Performing checksum verification of executable files
[2019-07-14 01:19:51] Verification complete
tyler@Tylers-computer:~$ 


Code: Select all

tyler@Tylers-computer:~$ inxi -F
System:
  Host: Tylers-computer Kernel: 4.15.0-20-generic x86_64 bits: 64 
  Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME Z270-AR v: Rev 1.xx 
  serial: <root required> UEFI: American Megatrends v: 0604 date: 12/08/2016 
CPU:
  Topology: Quad Core model: Intel Core i5-7600K bits: 64 type: MCP 
  L2 cache: 6144 KiB 
  Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
Graphics:
  Device-1: NVIDIA driver: nvidia v: 418.56 
  Display: x11 server: X.Org 1.19.6 driver: nvidia 
  resolution: 1680x1050~60Hz 
  OpenGL: renderer: GeForce GTX 1660/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56 
Audio:
  Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel 
  Device-2: NVIDIA driver: snd_hda_intel 
  Device-3: Logitech H600 [Wireless Headset] type: USB 
  driver: hid-generic,snd-usb-audio,usbhid 
  Sound Server: ALSA v: k4.15.0-20-generic 
Network:
  Device-1: Intel Ethernet I219-V driver: e1000e 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full 
  mac: 2c:4d:54:f0:3a:ac 
Drives:
  Local Storage: total: 939.13 GiB used: 339.07 GiB (36.1%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08WN4A0 
  size: 931.51 GiB 
  ID-2: /dev/sdb type: USB model: General UDisk size: 7.62 GiB 
Partition:
  ID-1: / size: 915.40 GiB used: 338.97 GiB (37.0%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 247 Uptime: 6d 18h 40m Memory: 15.60 GiB used: 7.93 GiB (50.9%) 
  Shell: bash inxi: 3.0.27 

Post Reply

Return to “Software & Applications”