[SOLVED] Wi-Fi not working Lenovo S130 on Linux Mint 19.1 MATE

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 4
Joined: Thu Aug 01, 2019 7:43 am

[SOLVED] Wi-Fi not working Lenovo S130 on Linux Mint 19.1 MATE

Post by crabbycrabby » Thu Aug 01, 2019 8:00 am

EDIT: solved following instructions found here: viewtopic.php?f=90&t=273099&start=20

specifically this command:

cd rtl8821ce
make clean
sudo make install


I have installed Mint MATE to replace Windows 10. I can't seem to connect to the WiFi - think it's a drivers issue? When I look in drive manager it says 'no proprietry drivers'. Anyway, I'm totally new to Linux so would love help! Thanks in advance.

Results of inxi -Fxz

Code: Select all

  Host: izzy-Lenovo-ideapad-S130-11IGM Kernel: 4.15.0-20-generic x86_64 
  bits: 64 compiler: gcc v: 7.3.0 Desktop: MATE 1.20.1 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
  Type: Laptop System: LENOVO product: 81J1 v: Lenovo ideapad S130-11IGM 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32802WIN serial: <filter> 
  UEFI: LENOVO v: 9HCN17WW date: 08/06/2018 
  ID-1: BAT1 charge: 30.3 Wh condition: 30.3/32.2 Wh (94%) 
  model: LENOVO BASE-BAT status: Charging 
  Topology: Dual Core model: Intel Celeron N4000 bits: 64 type: MCP 
  arch: Goldmont Plus rev: 1 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 4377 
  Speed: 865 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 1022 2: 1174 
  Device-1: Intel vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 600 (Geminilake 2x6) 
  v: 4.5 Mesa 19.0.2 direct render: Yes 
  Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:0e.0 
  Sound Server: ALSA v: k4.15.0-20-generic 
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: N/A port: 1000 bus ID: 03:00.0 
  Device-2: ASIX AX88772B type: USB driver: asix bus ID: 1-1:2 
  IF: enx00b56d0ddbbf state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 43.96 GiB used: 15.05 GiB (34.2%) 
  ID-1: /dev/mmcblk0 model: DF4032 size: 29.12 GiB 
  ID-2: /dev/sda type: USB vendor: Verbatim model: 0302 size: 14.84 GiB 
  ID-1: / size: 28.04 GiB used: 15.05 GiB (53.6%) fs: ext4 
  dev: /dev/mmcblk0p2 
  System Temperatures: cpu: 39.0 C mobo: 10.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 183 Uptime: 46m Memory: 3.67 GiB used: 1.60 GiB (43.6%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.27 
I also retrieved this following instructions from another post and wonder if it'll be helpful: https://termbin.com/7v3n
Last edited by Moem on Thu Aug 01, 2019 8:40 am, edited 1 time in total.
Reason: Adding [code] tags instead of [c] tags. They retain some formatting that makes your output easier to read.

Post Reply

Return to “Wireless”