timeshift retrograde issue on dual boot system (grub)

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
oldgranola
Level 4
Level 4
Posts: 382
Joined: Fri Sep 05, 2014 1:39 am

timeshift retrograde issue on dual boot system (grub)

Post by oldgranola » Mon Aug 26, 2019 1:23 pm

Hello,
Had to downgrade from LMcinnamon 19.2 back to 19.1 due to cinnamon crashes (I found an rsync image after all) using timeshift from a 19.2 live USB in fallback mode (cinnamon crashes with that also -boo). However then I couldn't boot. The grub menu still showed the various 19.2 options without 19.1 as before downgrade and none of those would work of course. I believe this is owing to having a multi-boot system with Manjaro KDE being the last to be quite recently added which therefore likely owns the boot sector. I had to boot into Manjaro (very nice OS) and updated grub from there which then allowed me to see and boot LM19.1 (with all 19.2 gone)

1. Is there a way to configure timeshift while restoring so that doesn't happen?

2. So how do I re-own the boot sector so I can update grub from LM19.1? I've done it before elsewhere but I forget

Thanks!
Disk info follows, current LM19.1 is on sda5

Code: Select all

sudo fdisk -l
Device         Start       End   Sectors   Size Type
/dev/sda1       2048   1050623   1048576   512M EFI System
/dev/sda2    1050624 257880063 256829440 122.5G Linux filesystem
/dev/sda3  970078208 976771071   6692864   3.2G Linux swap
/dev/sda4  504641536 504643583      2048     1M BIOS boot
/dev/sda5  504643584 970078207 465434624   222G Linux filesystem
fun@fun2:~$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0   512M  0 part 
├─sda2   8:2    0 122.5G  0 part 
├─sda3   8:3    0   3.2G  0 part 
├─sda4   8:4    0     1M  0 part 
└─sda5   8:5    0   222G  0 part /
sr0     11:0    1  1024M  0 rom  
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob

User avatar
blueocean
Level 5
Level 5
Posts: 964
Joined: Sun Jul 08, 2018 11:50 pm

Re: timeshift retrograde issue on dual boot system (grub)

Post by blueocean » Sun Oct 13, 2019 8:40 pm

It is your dual boot. Timeshift works well for a single Linux system or a dual Win/Linux setup. You might run this boot repair:
viewtopic.php?f=46&t=303545
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

User avatar
pbear
Level 9
Level 9
Posts: 2747
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: timeshift retrograde issue on dual boot system (grub)

Post by pbear » Sun Oct 13, 2019 10:48 pm

oldgranola wrote:
Mon Aug 26, 2019 1:23 pm
The grub menu still showed the various 19.2 options without 19.1 as before downgrade and none of those would work of course. I believe this is owing to having a multi-boot system with Manjaro KDE being the last to be quite recently added which therefore likely owns the boot sector. I had to boot into Manjaro (very nice OS) and updated grub from there which then allowed me to see and boot LM19.1 (with all 19.2 gone)

1. Is there a way to configure timeshift while restoring so that doesn't happen?

2. So how do I re-own the boot sector so I can update grub from LM19.1? I've done it before elsewhere but I forget
My understanding is that Manjaro can't be booted from Mint's Grub, so Manjaro has to be primary. Explanation here. The way you restore a Timeshift snapshot of Mint without disturbing that is to unselect reinstallation of Grub, which is one of the options on the restore dialogue.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

User avatar
blueocean
Level 5
Level 5
Posts: 964
Joined: Sun Jul 08, 2018 11:50 pm

Re: timeshift retrograde issue on dual boot system (grub)

Post by blueocean » Sun Oct 13, 2019 11:57 pm

pbear wrote
"The way you restore a Timeshift snapshot of Mint without disturbing that is to unselect reinstallation of Grub, which is one of the options on the restore dialogue."
That's good to know. I hadn't seen that option with the rsync restore. I'm most familiar with Btrfs and there is no such option.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

Post Reply

Return to “Installation & Boot”