Disable mouse acceleration

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
kirayagami

Disable mouse acceleration

Post by kirayagami » Wed Aug 28, 2019 4:38 am

Hi all
Anyone know how to disable mouse acceleration in Linux mint cinnamon 19.1 for a touchpad?
Thanks
Last edited by Moem on Wed Aug 28, 2019 4:59 am, edited 1 time in total.
Reason: Apparently you don't actually want to disable your mouse.

User avatar
Moem
Level 19
Level 19
Posts: 9374
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Disable mouse acceleration

Post by Moem » Wed Aug 28, 2019 5:01 am

Does this settings window not work for you?
touchpad.png
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

vittopascu
Level 1
Level 1
Posts: 23
Joined: Mon Mar 11, 2019 7:01 pm

Re: Disable mouse acceleration

Post by vittopascu » Sun Sep 08, 2019 1:38 pm

Ok after a lot of digging and trial & error I finally figured it out. This method works on Linux Mint 19.2 Cinnamon, I am using a Logitech M590 wireless mouse, with one of those Logitech unifying receivers.

The Xorg configuration files are stored in /usr/share/X11/xorg.conf.d, so change to that directory and create a new file:

Code: Select all

sudo gedit 90-mouse_accel.conf
or some similar name that you like. If you don't have gedit you can install it quickly (it's always handy to have) or use nano instead. In the file you copy and paste the following:

Code: Select all

Section "InputClass"
        Identifier "Mouse With No Acceleration"
        MatchDriver "libinput"
        MatchIsPointer "yes"
        Option "AccelProfile" "flat"
EndSection
What you write in "identifier" does not matter. Save & log out and in again. Now you can use the "Acceleration" slider in the Cinnamon mouse settings as if it were a classic "Pointer Speed" slider in windows. I think that this extends to the touchpad too, but I am not sure. I actually kind-of like acceleration on the touchpad so we will see if I can fine-tune it better.

To verify that the setting is working type:

Code: Select all

xinput list
and identify the device number of your mouse, for example in my case I had:

Code: Select all

$ xinput list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech K400 Plus                      	id=8	[slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:406b	id=9	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ UVC Camera (046d:0825)                  	id=10	[slave  keyboard (3)]
    ↳ Logitech USB Keyboard                   	id=11	[slave  keyboard (3)]
    ↳ Logitech USB Keyboard                   	id=12	[slave  keyboard (3)]
    ↳ Logitech K400 Plus                      	id=13	[slave  keyboard (3)]
    ↳ Logitech Unifying Device. Wireless PID:406b	id=14	[slave  keyboard (3)]
Rather obscurely my mouse is device Nr. 9, the k400 is a wireless keyboard with integrated touchpad, but we are not interested in that. Now you would type

Code: Select all

xinput list-propr 9
or whatever your device ID is, and within the output you should find these 2 entries:

Code: Select all

...
libinput Accel Speed (299):	0.662651     # or something representing your pointer speed
...
libinput Accel Profile Enabled (302):	0, 1    # if 0, 1 means flat profile, 1, 0 means accelerated profile
...
Verify that, if you slide the Acceleration setting in the mouse settings and then run the previous command, you will find that the Accel Speed entry will vary accordingly between -1 and 1. I have the feeling it's not as "flat" as in windows, but by far the best I could ever get out of Linux :) :)
Last edited by vittopascu on Fri Sep 13, 2019 5:42 pm, edited 2 times in total.

User avatar
Spearmint2
Level 16
Level 16
Posts: 6807
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Disable mouse acceleration

Post by Spearmint2 » Sun Sep 08, 2019 4:02 pm

Your preferred method is how it's in MATE. The mouse control program has those options available, and stopping acceleration works for me.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

Post Reply

Return to “Newbie Questions”