[SOLVED] Wifi disappeared

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
igor_cdm
Level 1
Level 1
Posts: 2
Joined: Fri Sep 27, 2019 5:09 pm

[SOLVED] Wifi disappeared

Post by igor_cdm » Sat Sep 28, 2019 4:23 pm

Hi, i'm new to Linux Mint (using it for 2 weeks now) and everything was working fine. in my ssd i have Win10, Ubuntu 19.04( i was using before change to Mint) and Mint 19.2.

Today i was working and suddenly my wifi connection was gone.

the wifi section (in red) completely disapeared:
Image

and the "Wi-Fi" option on network settings also!

it was 17:00 and i had some importants commit to do, then i boot into my Ubuntu and... surprise, the same happened there, no wifi at all, then i boot into windows just to test and wifi worked fine.

i started to search like a crazy in forums, i saw people on similar topics asking to run

Code: Select all

rfkill list
and my output only has the bluetooth:
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

then i had the idea to make a live-usb stick with mint, then boot without install... wifi was there! i connected, installed git made my pushs to repo, then i removed the usb stick and get back to my installed Mint... and MAGIC, wifi was working again!

the problem is already "solved" but i decided to post it for people having this trouble in future: try to boot in a live-USB mint and get back to installed Mint after.

deepakdeshp
Level 15
Level 15
Posts: 5847
Joined: Sun Aug 09, 2015 10:00 am

Re: [SOLVED] Wifi disappeared

Post by deepakdeshp » Sat Sep 28, 2019 9:28 pm

Good to know that you listed the problem and the solution.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

igor_cdm
Level 1
Level 1
Posts: 2
Joined: Fri Sep 27, 2019 5:09 pm

Re: [SOLVED] Wifi disappeared

Post by igor_cdm » Fri Oct 11, 2019 1:14 pm

UPDATE:
I'm back, the problem happened again.

suddenly wifi has gone, so I decided to do the same thing that solved the problem last time (boot into a live-USB Mint) but turns out that this was not the problem solver action:
When I booted into live USB there was no wifi also, like the installed Mint, so I decided to boot into windows, wifi worked fine, and when I back to Mint Wifi was Working again!

So, the real problem solver action for me was:
Boot into windows, connected into wifi (not sure if is really needed to connect) and then get back to Mint

there is anything I can do next time it happens to help identify the problem?

Post Reply

Return to “Wireless”