App on Cinnamon won't stay fully maximized

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

App on Cinnamon won't stay fully maximized

Post by blueocean » Thu Oct 10, 2019 8:42 pm

Two apps that won't stay maximized have been an ongoing puzzle. Kpat and Xreader insist on not quite fully maximized. I can tick the button to maximize and it stays for a while then upon launch it drops in size a bit. I've tried deleting .config/kpat and set the interface up many times. I've tried different themes, window borders, and controls including defaults I have confirmed this behavior in 19, 19.1, and 19.2 all clean installs on 3 different PCs. Just wondering if others had noticed this type of behavior? A cure would be good. I'm guessing it's a bug.
Last edited by blueocean on Wed Oct 16, 2019 3:24 pm, edited 1 time in total.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

rene
Level 12
Level 12
Posts: 4171
Joined: Sun Mar 27, 2016 6:58 pm

Re: Windows won't stay fully maximized

Post by rene » Fri Oct 11, 2019 3:25 am

Does not reproduce for either kpat (the KDE solitaire game(s), right?) or xreader on 19.2 Cinnamon with anything graphic that I'm aware of at defaults, on a 1920x1080 screen.

The issue sounds like a rounding issue/error and I'll believe you may as such need to specify your edition (i.e., window manager) and screen resolution -- although latter is perhaps less important if this happens on 3 systems, not all of which supposedly have some strange resolution.

User avatar
smurphos
Level 12
Level 12
Posts: 4355
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: Windows won't stay fully maximized

Post by smurphos » Fri Oct 11, 2019 3:49 am

Try running

Code: Select all

sudo chown -Rc $USER:$USER $HOME
in a terminal.

I'm not near my Mint machine at the moment to check behaviour or where these applications store their last run geometry, but I suspect a file ownership issue is preventing the last run geometry being written.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

Re: Windows won't stay fully maximized

Post by blueocean » Fri Oct 11, 2019 11:55 am

rene wrote:
Fri Oct 11, 2019 3:25 am
Does not reproduce for either kpat (the KDE solitaire game(s), right?) or xreader on 19.2 Cinnamon with anything graphic that I'm aware of at defaults, on a 1920x1080 screen.

The issue sounds like a rounding issue/error and I'll believe you may as such need to specify your edition (i.e., window manager) and screen resolution -- although latter is perhaps less important if this happens on 3 systems, not all of which supposedly have some strange resolution.
Laptop is different resolution but desktops are the same at 1920x1080. Sometimes it stays maximized all day but usually after a restart it drops. I have to close kpat or xreader and reopen to get it to do this. It did not do this on 18x
Attachments
kpat.jpg
kpat.jpg (23.56 KiB) Viewed 288 times
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

Re: Windows won't stay fully maximized

Post by blueocean » Fri Oct 11, 2019 12:01 pm

smurphos wrote:
Fri Oct 11, 2019 3:49 am
Try running

Code: Select all

sudo chown -Rc $USER:$USER $HOME
in a terminal.

I'm not near my Mint machine at the moment to check behaviour or where these applications store their last run geometry, but I suspect a file ownership issue is preventing the last run geometry being written.
Thanks.
3 questions:
should i reset kpat by deleting .config/kpatrc before

Code: Select all

sudo chown -Rc $USER:$USER $HOME
?
and
what are the overall consequences of

Code: Select all

sudo chown -Rc $USER:$USER $HOME
?
Not many google hits on that exact command that I can consult :shock:
once done is there a way to undo

Code: Select all

sudo chown -Rc $USER:$USER $HOME
and put it back like it was?
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

rene
Level 12
Level 12
Posts: 4171
Joined: Sun Mar 27, 2016 6:58 pm

Re: Windows won't stay fully maximized

Post by rene » Fri Oct 11, 2019 1:04 pm

You don't need to "reset" kpat and can run that command safely. All it does is make you the owner of every file under your home directory. Assuming that you don't have other file systems mounted under your home directory that's always a good idea, and even if you were to have such it usually is. Basically, nothing in your home directory has any business being owned by anyone other than you in the first place.

smurphos suggested it due to a notion that some file and/or directory in your home directory having become root-owned --- as can happen for example by inadvertently launching graphical programs with sudo --- could be keeping a program such as kpat, a program running as you when launched by you, from automatically saving its settings.

I dunno... but you may as well just try; it's a fine bit of maintenance regardless,

User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

Re: Windows won't stay fully maximized

Post by blueocean » Fri Oct 11, 2019 1:11 pm

rene wrote:
Fri Oct 11, 2019 1:04 pm
You don't need to "reset" kpat and can run that command safely. All it does is make you the owner of every file under your home directory. Assuming that you don't have other file systems mounted under your home directory that's always a good idea, and even if you were to have such it usually is. Basically, nothing in your home directory has any business being owned by anyone other than you in the first place.

smurphos suggested it due to a notion that some file and/or directory in your home directory having become root-owned --- as can happen for example by inadvertently launching graphical programs with sudo --- could be keeping a program such as kpat, a program running as you when launched by you, from automatically saving its settings.

I dunno... but you may as well just try; it's a fine bit of maintenance regardless,
Ok, thanks! I did it and even reset kpat before reading your post. Will report back after keeping both :shock: eyes on it.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

rene
Level 12
Level 12
Posts: 4171
Joined: Sun Mar 27, 2016 6:58 pm

Re: Windows won't stay fully maximized

Post by rene » Fri Oct 11, 2019 1:12 pm

You by the way did not yet report your Mint edition. That information would be vital to anyone trying to reproduce.

User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

Re: Windows won't stay fully maximized

Post by blueocean » Fri Oct 11, 2019 1:51 pm

rene wrote:
Fri Oct 11, 2019 1:12 pm
You by the way did not yet report your Mint edition. That information would be vital to anyone trying to reproduce.
Oh ok. this is 19.2 but as I said in my post behavior has been in 19, 19.1, and 19.2.
Additionally, not in 18x
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

rene
Level 12
Level 12
Posts: 4171
Joined: Sun Mar 27, 2016 6:58 pm

Re: Windows won't stay fully maximized

Post by rene » Fri Oct 11, 2019 3:46 pm

Edition as in Cinnamon, MATE or Xfce.

User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

Re: Windows won't stay fully maximized

Post by blueocean » Fri Oct 11, 2019 4:18 pm

rene wrote:
Fri Oct 11, 2019 3:46 pm
Edition as in Cinnamon, MATE or Xfce.
Sorry, Cinnamon. Also Xfce doesn't have this problem for me, although I don't use it too much. I'm entrenched with Cinnamon - like it the best.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

Re: Windows won't stay fully maximized

Post by blueocean » Fri Oct 11, 2019 8:32 pm

Unfortunately

Code: Select all

sudo chown -Rc $USER:$USER $HOME
did not help. Seems like if it's maximized and I click to full minimize (- sign) then click it on the panel to bring the window back up, then close kpat and reopen it, then it's resized.
Screenshots

Maximized
Maximized.jpg
Resized
Resized.jpg
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

rene
Level 12
Level 12
Posts: 4171
Joined: Sun Mar 27, 2016 6:58 pm

Re: Windows won't stay fully maximized

Post by rene » Sat Oct 12, 2019 6:43 am

blueocean wrote:
Fri Oct 11, 2019 8:32 pm
Seems like if it's maximized and I click to full minimize (- sign) then click it on the panel to bring the window back up, then close kpat and reopen it, then it's resized.
Definitely not here on 19.2 Cinnamon, 1920x180, so will have to bow out; can not reproduce.

User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

Re: Windows won't stay fully maximized

Post by blueocean » Sat Oct 12, 2019 12:09 pm

It's mysterious because I've tested it on bare installs with Btrfs, XFS (legacy mode), and Ext4 for /. Also on AMD and 4 different intel chipsets All with default Mint theme and settings. This one (with custom Mint theme) does the same every time when I open Kpat and maximize, then click the - to minimize to panel, then click panel and resume (at this point it's still maximized). Then I close Kpat and open it again (launching from a shortcut on the panel) and then it has been resized so a slight space around the window shows. I do use the clean green background and classic cards for appearance.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

User avatar
blueocean
Level 4
Level 4
Posts: 475
Joined: Sun Jul 08, 2018 11:50 pm

Re: Windows won't stay fully maximized

Post by blueocean » Wed Oct 16, 2019 4:47 pm

I tried it again on Mate 19.2 and Xfce 19.2. Mate does it, but not Xfce. I then tried setting the window border, theme, controls, all to default and deleted kpatrc from .config. So with everything at default on Cinnamon 9.2 it still does this. Now with any of the default window borders included in Cinnamon 19.2 it does this but is so subtle as to be difficult to notice. The way to tell is look down at the number of moves in the lower right. When maximized it's all the way to the right, but when resized, it moves a bit to the left. See screenshots.

Maximized
Maximized.jpg
Resized.jpg
Resized


Last bumped by blueocean on Wed Oct 16, 2019 4:47 pm.
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.

Post Reply

Return to “Cinnamon”