Wifi loses connection - another case

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
fbshilli
Level 1
Level 1
Posts: 2
Joined: Sun Dec 31, 2017 4:02 pm

Wifi loses connection - another case

Post by fbshilli » Sat Nov 09, 2019 8:24 pm

The wifi on my desktop slows and eventually loses its connection after a few minutes. Doesn't happen using windows.
I've tried a few things from other threads, but it still happens.
- power manager is off
- updated to kernel 5.3
- disabled hardware encryption for ath9k
- disable IPv6

Any suggestions would be appreciated. Thanks.

inxi -Fxz

Code: Select all

fbshilli@fbshilli-home ~ $ inxi -Fxz
System:    Host: fbshilli-home Kernel: 5.0.0-32-generic x86_64
           bits: 64 gcc: 7.4.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu4)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: Dell product: Inspiron 3847 serial: N/A
           Mobo: Dell model: 088DT1 v: A01 serial: N/A
           BIOS: Dell v: A08 date: 06/29/2015
CPU:       Quad core Intel Core i7-4790 (-MT-MCP-) 
           arch: Haswell rev.3 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 28735
           clock speeds: max: 4000 MHz 1: 1093 MHz 2: 1292 MHz 3: 1651 MHz
           4: 1524 MHz 5: 1394 MHz 6: 2223 MHz 7: 2233 MHz 8: 1600 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel Haswell Desktop
           version: 4.5 Mesa 19.0.8 Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k5.0.0-32-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 port: e000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
           Card-3: Atheros usb-ID: 003-006
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1739.7GB (18.0% used)
           ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
           ID-2: /dev/sdb model: SSD2SC240G1SA754 size: 240.1GB
           ID-3: USB /dev/sdc model: My_Book_1110 size: 499.4GB
Partition: ID-1: / size: 108G used: 39G (39%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 17.09GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 32.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 252 Uptime: 14 min Memory: 2362.9/15954.8MB
           Init: systemd runlevel: 5 Gcc sys: 7.4.0
           Client: Shell (bash 4.4.201) inxi: 2.3.56 
iwconfig

Code: Select all

wlp3s0    IEEE 802.11  ESSID:"ATT2jzq5JH"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: F8:2C:18:60:12:5D   
          Bit Rate=39 Mb/s   Tx-Power=18 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=45/70  Signal level=-65 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:714  Invalid misc:182   Missed beacon:0

lo        no wireless extensions.

enp2s0    no wireless extensions.
lsmod | grep ath

Code: Select all

ath3k                  24576  0
ath9k                 151552  0
ath9k_common           36864  1 ath9k
ath9k_hw              475136  2 ath9k_common,ath9k
ath                    32768  3 ath9k_common,ath9k,ath9k_hw
mac80211              819200  1 ath9k
bluetooth             557056  44 btrtl,btintel,btbcm,bnep,ath3k,btusb,rfcomm
cfg80211              679936  4 ath9k_common,ath9k,ath,mac80211

sleeper12
Level 6
Level 6
Posts: 1209
Joined: Thu May 25, 2017 3:22 pm

Re: Wifi loses connection - another case

Post by sleeper12 » Sat Nov 09, 2019 11:18 pm

This is an old thread, but maybe something here might help?:
viewtopic.php?t=171819

Post Reply

Return to “Wireless”