Slow and intermittent wifi issues with usb adapter

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help
Post Reply
wamosjk
Level 1
Level 1
Posts: 4
Joined: Sat Nov 09, 2019 11:54 pm

Slow and intermittent wifi issues with usb adapter

Post by wamosjk » Sun Nov 10, 2019 12:06 am

I know there have been many posts about slow wifi but none of the answers seem to work. I am only getting about 1mb/s download speed and then I am constantly getting
activation of network connection failed
messages and getting kicked off the network. I am dual booting with windows and everything works fine in windows it's only happening in linux mint. I am using the 19.2 and I have tried updating the kernel. I checked if power management is on and it is turned off. I tried this terrible video https://www.youtube.com/watch?v=p19b5EbfQlk. Secure boot is turned off in the bios. I even turned off fast startup in windows. Nothing seems to work. I am getting pretty frustrated and this is my hail mary attempt to fix it before I just scrap this distro. This seems to be a pretty common problem and there doesn't seem to be any real clear answers as to why this is happening. Any help would be appreciated.

Thanks

sleeper12
Level 6
Level 6
Posts: 1209
Joined: Thu May 25, 2017 3:22 pm

Re: Slow and intermittent wifi issues with usb adapter

Post by sleeper12 » Sun Nov 10, 2019 1:10 am

It would help to see your results of:

Code: Select all

 inxi -Fxz 

wamosjk
Level 1
Level 1
Posts: 4
Joined: Sat Nov 09, 2019 11:54 pm

Re: Slow and intermittent wifi issues with usb adapter

Post by wamosjk » Sun Nov 10, 2019 10:55 am

Here is the result of the command you requested

System:
Host: wamo-HP-Compaq-Elite-8300-CMT Kernel: 5.3.0-19-generic x86_64
bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.2.4
Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic
Machine:
Type: Desktop System: Hewlett-Packard product: HP Compaq Elite 8300 CMT
v: N/A serial: <filter>
Mobo: Hewlett-Packard model: 3396 serial: <filter> UEFI: Hewlett-Packard
v: K01 v02.90 date: 07/16/2013
Battery:
Device-1: hidpp_battery_0 model: Logitech K350 charge: 70%
status: Discharging
CPU:
Topology: Quad Core model: Intel Core i7-3770 bits: 64 type: MT MCP
arch: Ivy Bridge rev: 9 L2 cache: 8192 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54276
Speed: 1597 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1596 2: 1596
3: 1596 4: 1596 5: 1597 6: 1596 7: 1596 8: 1597
Graphics:
Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: Micro-Star MSI
driver: nvidia v: 435.21 bus ID: 01:00.0
Display: x11 server: X.Org 1.19.6 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GTX 750 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21
direct render: Yes
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Device-2: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus ID: 01:00.1
Sound Server: ALSA v: k5.3.0-19-generic
Network:
Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:19.0
IF: eno1 state: down mac: <filter>
Device-2: Realtek RTL8188CUS 802.11n WLAN Adapter type: USB
driver: rtl8192cu bus ID: 3-1:2
IF: wlx081076c0e877 state: down mac: <filter>
Drives:
Local Storage: total: 3.77 TiB used: 1.21 TiB (32.1%)
ID-1: /dev/sda vendor: Samsung model: SSD PM830 2.5 7mm 128GB
size: 119.24 GiB
ID-2: /dev/sdb model: MB4000GDMTH size: 3.64 TiB
ID-3: /dev/sdc type: USB vendor: SanDisk model: Cruzer Blade
size: 14.91 GiB
Partition:
ID-1: / size: 45.87 GiB used: 18.33 GiB (40.0%) fs: ext4 dev: /dev/sda5
Sensors:
System Temperatures: cpu: 31.0 C mobo: N/A gpu: nvidia temp: 26 C
Fan Speeds (RPM): N/A
Info:
Processes: 257 Uptime: 1m Memory: 15.58 GiB used: 746.0 MiB (4.7%)
Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
inxi: 3.0.32

sleeper12
Level 6
Level 6
Posts: 1209
Joined: Thu May 25, 2017 3:22 pm

Re: Slow and intermittent wifi issues with usb adapter

Post by sleeper12 » Sun Nov 10, 2019 1:48 pm

See if this does anything:

Code: Select all

 sudo modprobe rtl8192cu 
Reboot

wamosjk
Level 1
Level 1
Posts: 4
Joined: Sat Nov 09, 2019 11:54 pm

Re: Slow and intermittent wifi issues with usb adapter

Post by wamosjk » Sun Nov 10, 2019 8:34 pm

No that didn't do anything unfortunately.

sleeper12
Level 6
Level 6
Posts: 1209
Joined: Thu May 25, 2017 3:22 pm

Re: Slow and intermittent wifi issues with usb adapter

Post by sleeper12 » Sun Nov 10, 2019 10:20 pm

All I can suggest is maybe try something here:
https://easylinuxtipsproject.blogspot.c ... s.html#ID2

JeremyB
Level 20
Level 20
Posts: 11018
Joined: Fri Feb 21, 2014 8:17 am

Re: Slow and intermittent wifi issues with usb adapter

Post by JeremyB » Mon Nov 11, 2019 7:27 am

You may have 2 drivers loaded for that wifi, do

Code: Select all

echo "blacklist rtl8192cu" | sudo tee /etc/modprobe.d/rtl8192cu.conf
Reboot

That youtube video is really bad, it needs to be deleted

wamosjk
Level 1
Level 1
Posts: 4
Joined: Sat Nov 09, 2019 11:54 pm

Re: Slow and intermittent wifi issues with usb adapter

Post by wamosjk » Mon Nov 11, 2019 6:54 pm

Code: Select all

echo "blacklist rtl8192cu" | sudo tee /etc/modprobe.d/rtl8192cu.conf
Thanks JeremyB

This seems to fix the problem!!! Thank you very much. I had spent nearly two days trying to figure this out. Your a lifesaver.

Post Reply

Return to “Hardware Support”