Headphones not detecting through laptop audio jack

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
Colander
Level 1
Level 1
Posts: 2
Joined: Tue Aug 06, 2019 6:57 am

Headphones not detecting through laptop audio jack

Post by Colander » Sun Nov 10, 2019 5:46 pm

Hi, I've searched everywhere and no procedure seems to fix this issue.
I've got an problem with my headphones not getting detected when connected to the 3.5 mm jack on my laptop (ThinkPad E480).
When I connect the headphones, nothing changes, the audio still goes through the integrated speakers.
The only way I could get external audio is through an HDMI monitor (after manually switching the output), that works without issue.
On Windows it works just fine, so I think the hardware is ok.
Also tried a bios update, no luck.

inxi -Fxz:

Code: Select all

System:    Host: bouca-e480 Kernel: 5.0.0-32-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.2.4 
           Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: LENOVO product: 20KN0065MC v: ThinkPad E480 serial: <filter> 
           Mobo: LENOVO model: 20KN0065MC v: SDK0J40697 WIN serial: <filter> UEFI: LENOVO v: R0PET58W (1.35 ) date: 07/02/2019 
Battery:   ID-1: BAT0 charge: 36.2 Wh condition: 36.2/45.0 Wh (81%) model: LGC 01AV445 status: Unknown 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800 
           Speed: 700 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 5: 700 6: 700 7: 700 8: 700 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 2560x1440~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.8 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.0.0-32-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: d000 
           bus ID: 03:00.0 
           IF: enp3s0 state: down mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi v: kernel port: d000 bus ID: 05:00.0 
           IF: wlp5s0 state: up mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 89.83 GiB (37.7%) 
           ID-1: /dev/nvme0n1 model: LENSE20256GMSP34MEAT2TA size: 238.47 GiB 
Partition: ID-1: / size: 114.51 GiB used: 89.80 GiB (78.4%) fs: ext4 dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 43.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 266 Uptime: 36m Memory: 15.43 GiB used: 2.22 GiB (14.4%) Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 
           clang: 6.0.0-1ubuntu2 Shell: bash v: 4.4.20 inxi: 3.0.32 
Thanks for any help!

User avatar
MrEen
Level 14
Level 14
Posts: 5421
Joined: Mon Jun 12, 2017 8:39 pm

Re: Headphones not detecting through laptop audio jack

Post by MrEen » Sun Nov 10, 2019 5:57 pm

Hi Colander.

Let's see the outputs of aplay -l and dmesg | grep snd please.

Post Reply

Return to “Sound, Multimedia, & Codecs”