[SOLVED] Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help
Post Reply
waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

[SOLVED] Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Sat Nov 30, 2019 5:44 am

Hello all,

Just letting people know that after using Reaper and Linux Mint successfully for some weeks, I suddenly had a problem where Reaper would not load project, nor save projects to a secondary internal drive.

The problem became apparent after i had edited the Hard Drive's mount options to have it automatically mount on start up.

I tried turning off the option by switching back 'User Session Defaults", but the problem persisted.

After using Timeshift to go back to an older configuration of my OS, it worked just as it did, luckily.

Just making a note of it here for anyone who encounters a similar problem.

(Am assuming the problem was auto mount and not some other script or package that came through an update.}
Last edited by waywayka on Sat Dec 07, 2019 5:14 am, edited 1 time in total.
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

gm10
Level 20
Level 20
Posts: 10274
Joined: Thu Jun 21, 2018 5:11 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by gm10 » Sat Nov 30, 2019 5:53 am

Assuming this is not a partition formatted with a Linux filesystem, for that is what this sounds like, see my post here on how to mount it at startup for your user:
viewtopic.php?p=1566922#p1566922

Otherwise we'd need some system details.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Mon Dec 02, 2019 6:07 am

Hi gm10,

Many thanks for your interest.

I believe this HD is formatted Ext4, which is Linux.

What is the best way to provide you with system details?
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

gm10
Level 20
Level 20
Posts: 10274
Joined: Thu Jun 21, 2018 5:11 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by gm10 » Mon Dec 02, 2019 6:15 am

With the HDD in question mounted, run this command in a terminal window and copy & paste the output in your next post (in code tags please, </> button):

Code: Select all

inxi -Fxz
(as explained in the "how to get help" link in the red banner above your post ;))
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Wed Dec 04, 2019 6:27 am

Code: Select all

System:
  Host: d******-XPS-15-9530 Kernel: 4.15.0-70-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: MATE 1.22.0 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Portable System: Dell product: XPS 15 9530 v: A11 serial: <filter> 
  Mobo: Dell model: XPS 15 9530 v: A11 serial: <filter> BIOS: Dell v: A11 
  date: 05/25/2018 
Battery:
  ID-1: BAT1 charge: 32.1 Wh condition: 43.0/61.0 Wh (70%) 
  model: Simplo PABAS0241231 status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i5-4200H bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 22348 
  Speed: 2794 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 2794 2: 2794 
  3: 2794 4: 2784 
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Dell 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1368x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-70-generic 
Network:
  Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel port: f040 
  bus ID: 06:00.0 
  IF: wlp6s0 state: up mac: <filter> 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 1.36 TiB used: 660.36 GiB (47.3%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB 
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO mSATA 500GB 
  size: 465.76 GiB 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 bus ID: 00:1f.2 
Partition:
  ID-1: / size: 456.50 GiB used: 148.17 GiB (32.5%) fs: ext4 dev: /dev/dm-0 
  ID-2: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:
  System Temperatures: cpu: 57.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 203 Uptime: 35m Memory: 7.70 GiB used: 1.29 GiB (16.8%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 
Thanks again for taking an interest. Another interesting thing has popped up (literally):
Randomly, the HDD icon will appear by itself on the desktop, looks like it's mounted, but when double clicked, an error message pops up and in inaccessable - I will try and reproduce the problem and get the exact error message. Might be related?
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

gm10
Level 20
Level 20
Posts: 10274
Joined: Thu Jun 21, 2018 5:11 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by gm10 » Wed Dec 04, 2019 6:43 am

waywayka wrote:
Wed Dec 04, 2019 6:27 am

Code: Select all

Partition:
  ID-1: / size: 456.50 GiB used: 148.17 GiB (32.5%) fs: ext4 dev: /dev/dm-0 
  ID-2: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
You do not appear to have your external drive mounted. I wanted to see the information with it mounted. :)
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Thu Dec 05, 2019 7:08 am

The drive is actually mounted. I've provided an attachment showing you the terminal readout that matches the one above, but you can also see that the drive is mounted as far as the file manager is concerned.

Perhaps I have formatted drive incorrectly at inception?
Last edited by waywayka on Thu Dec 05, 2019 4:22 pm, edited 1 time in total.
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

gm10
Level 20
Level 20
Posts: 10274
Joined: Thu Jun 21, 2018 5:11 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by gm10 » Thu Dec 05, 2019 9:00 am

Hmm, might be a bug with inxi. Let's see

Code: Select all

lsblk -f
and for good measure throw in a

Code: Select all

sudo blkid
and a

Code: Select all

mount|grep /media
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Thu Dec 05, 2019 4:16 pm

gm10 wrote:
Thu Dec 05, 2019 9:00 am
Hmm, might be a bug with inxi. Let's see

Code: Select all

NAME             FSTYPE LABEL  UUID                                   MOUNTPOINT
sda                                                                   
└─sda1           ext4   1.0 TB d4c062d7-b16c-4420-a8ba-6f323349584e   /media/ddu
sdb                                                                   
└─sdb1           LVM2_m        uKJYsN-x6yN-PztI-5le5-mLTS-7zwc-GmcwBu 
  ├─mint--vg-root
  │              ext4          16d1db7b-a2b0-4eb0-8ceb-c50e307f1742   /
  └─mint--vg-swap_1
                 swap          e6b2e145-912c-41d7-9876-953335abe1c9   [SWAP]
                 
and for good measure throw in a

Code: Select all

/dev/sda1: LABEL="1.0 TB" UUID="d4c062d7-b16c-4420-a8ba-6f323349584e" TYPE="ext4" PARTUUID="380e4215-01"
/dev/sdb1: UUID="uKJYsN-x6yN-PztI-5le5-mLTS-7zwc-GmcwBu" TYPE="LVM2_member" PARTUUID="e1dc306b-01"
/dev/mapper/mint--vg-root: UUID="16d1db7b-a2b0-4eb0-8ceb-c50e307f1742" TYPE="ext4"
/dev/mapper/mint--vg-swap_1: UUID="e6b2e145-912c-41d7-9876-953335abe1c9" TYPE="swap"
and a

Code: Select all

/dev/sda1 on /media/d******/1.0 TB type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
Last edited by waywayka on Thu Dec 05, 2019 4:23 pm, edited 1 time in total.
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Thu Dec 05, 2019 4:20 pm

Also, here is that error message that pops up when I try to open the HD after it randomly appears on the desktop:

In order to unount, I have put in suoeruser password - says its being used by another user.
Attachments
errot.png
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

gm10
Level 20
Level 20
Posts: 10274
Joined: Thu Jun 21, 2018 5:11 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by gm10 » Fri Dec 06, 2019 4:47 am

waywayka wrote:
Thu Dec 05, 2019 4:16 pm

Code: Select all

/dev/sda1 on /media/d******/1.0 TB type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
Ok, so there it is, and using ext4 indeed. It's weird that inxi would not pick up on it when all the other commands did - maybe you could run an inxi -p again just to see if it still does not get listed (I don't need to see the output - I'm just wondering if it's really a bug in inxi or if the connection to the device is unstable, because I'm leaning more towards the latter).

Also you said you were mounting it on startup, but the above shows that it has been mounted on demand and not on system startup. You can configure a partition to be mounted at startup by using the Disks tool, selecting the partition, clicking the cogs icon and seleting Edit Mount Options..., then make it look exactly like this, except your own UUID will be pre-selected, so leave that alone, and you have to choose your own mount point where I marked it in red:

Image

The recommended location to mount it would be in /mnt, so something like /mnt/custom_name. The /media location is meant for removable devices, i.e. the way it is currently configured for you. It's cleaner to keep the two apart.

Note that you can mount it anywhere you want. Depending on the location you choose, if you're using Timeshift for system snapshots you may have to manually add the mount point to the excluded paths. Locations like /media, /mnt and your user's home directory are excluded by default though.

Then reboot to make sure it works. For good measure maybe post the output of this:

Code: Select all

cat /etc/fstab
Now adjust the configuration of your software to point to the new mount point. Since this is an ext4 filesystem, for you and software running under your user account to access it, you must have the proper permissions to the files and folders you want to access. As this worked for you in the past, this should already be the case, otherwise you'll have to adjust it. To give your user ownership of everything on that partition you would run:
sudo chown -R $USER:$USER /mnt/custom_name/*
(obviously using the actual mount point you chose previously)
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Fri Dec 06, 2019 5:40 am

[/quote]

The recommended location to mount it would be in /mnt, so something like /mnt/custom_name. The /media location is meant for removable devices, i.e. the way it is currently configured for you. It's cleaner to keep the two apart.

[/quote]

Err.. it seems that the mount point isn't /media at all, but /mnt as you suggest. Thoughts?
Attachments
Mount Options.png
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

gm10
Level 20
Level 20
Posts: 10274
Joined: Thu Jun 21, 2018 5:11 pm

Re: Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by gm10 » Fri Dec 06, 2019 6:08 am

No, that is misleading, that is just a proposed mount point in case you were to uncheck the "User Session Defaults" box, but it is not what is currently being used (as they try to indicate by greying it all out).

As I said, make it all look exactly as in my screenshot except with your own mount point (and selecting the UUID from the dropdown it will show yours, not mine, of course).
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

Re: [SOLVED] Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Sat Dec 07, 2019 5:32 am

gm10, I cannot thank you enough.

By steering me through the Auto Mount options, you helped me to locate the cause of random appearances of the 2nd HD, and prompt me to understand why Reaper wasn't able to access HD.

1. Random and inaccessible mounting of HD were caused by a folder in mnt/ titled with UUID number. (I had previously been messing around with a different way of automounting and had forgotten to go back and delete my steps). At least that;s what I think caused that problem.

2. Mounting the HD from media/ was the newbie mistake here, and by changing it to mnt/ and filling the fields correctly has made everything work perfectly.

3. And of course, going through process made me realise that Reaper couldn't access its files because the path had changed. It wasn't obvious to me at the time, but is as plain as can be now.

Again, thanks so much for your help.
Last edited by waywayka on Sat Dec 07, 2019 5:40 am, edited 1 time in total.
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

gm10
Level 20
Level 20
Posts: 10274
Joined: Thu Jun 21, 2018 5:11 pm

Re: [SOLVED] Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by gm10 » Sat Dec 07, 2019 5:37 am

You are quite welcome.

And to clarify the issue you had: You were not automatically mounting the drive at startup, you were mounting it on-demand to an automatically generated mount point - and as you found, that one can change if the folder from the previous on-demand mount stayed behind for some reason.

So the fix was just to configure a permanent (= mount at system startup) mount point like you had originally intended, anyway.

Have a nice weekend! :)
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

waywayka
Level 1
Level 1
Posts: 30
Joined: Sun Mar 03, 2019 9:06 pm

Re: [SOLVED] Reaper cannot load from or save to Hard Drive when Auto Mount is turned on

Post by waywayka » Sat Dec 07, 2019 5:43 am

Thanks for that clarification. A great weekend to you too! 8)
Dell XPS 15 9530
i5 4200H 2.9 GHz
Linux Mint Tara 19.2 (MATE)

Post Reply

Return to “Sound, Multimedia, & Codecs”