[SOLVED] Nvidia Quadro no acceleration

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

[SOLVED] Nvidia Quadro no acceleration

Post by gbone » Sun Dec 01, 2019 9:35 pm

Lenovo W530 with new install of LM 19.2 and I have sluggish mouse and graphics. On reboot I get this message:
"Your system is currently running without video hardware acceleration"

Here is more info on my machine:
$ inxi -Gxx
Graphics: Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: N/A bus ID: 00:02.0 chip ID: 8086:0166
Device-2: NVIDIA GK107GLM [Quadro K1000M] vendor: Lenovo driver: nvidia v: 430.50 bus ID: 01:00.0
chip ID: 10de:0ffc
Display: x11 server: X.Org 1.19.6 driver: fbdev,nouveau,nvidia unloaded: modesetting,vesa resolution: 1600x900~77Hz
OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.8 compat-v: 3.1 direct render: Yes




System Info

System: Host: douglas-ThinkPad-W530 Kernel: 4.15.0-54-generic x86_64 bits: 64 compiler: gcc
v: 7.4.0 Desktop: Cinnamon 4.2.3 wm: muffin dm: LightDM Distro: Linux Mint 19.2 Tina
base: Ubuntu 18.04 bionic
Machine: Type: Laptop System: LENOVO product: 2436CTO v: ThinkPad W530 serial: <filter> Chassis:
type: 10 serial: <filter>
Mobo: LENOVO model: 2436CTO serial: <filter> UEFI [Legacy]: LENOVO v: G5ETA5WW (2.65 )
date: 03/04/2016
Battery: ID-1: BAT0 charge: 49.0 Wh condition: 49.0/56.2 Wh (87%) volts: 12.4/10.8
model: SANYO 45N1001 serial: <filter> status: Full
CPU: Topology: Quad Core model: Intel Core i7-3720QM bits: 64 type: MT MCP arch: Ivy Bridge
rev: 9 L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41503
Speed: 1264 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 1389 2: 1202 3: 1695
4: 1383 5: 1393 6: 1443 7: 1396 8: 1449
Graphics: Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: N/A
bus ID: 00:02.0 chip ID: 8086:0166
Device-2: NVIDIA GK107GLM [Quadro K1000M] vendor: Lenovo driver: nvidia v: 415.27
bus ID: 01:00.0 chip ID: 10de:0ffc
Display: x11 server: X.Org 1.19.6 driver: fbdev,nouveau,nvidia
unloaded: modesetting,vesa resolution: 1600x900~77Hz
OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.8 compat-v: 3.1
direct render: Yes
Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20
Sound Server: ALSA v: k4.15.0-54-generic
Network: Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e v: 3.2.6-k
port: 7080 bus ID: 00:19.0 chip ID: 8086:1502
IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter>
Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel port: 6000
bus ID: 03:00.0 chip ID: 8086:4238
IF: wlp3s0 state: down mac: <filter>
Drives: Local Storage: total: 696.79 GiB used: 7.11 GiB (1.0%)
ID-1: /dev/sda vendor: OCZ model: VERTEX3 size: 111.79 GiB speed: 6.0 Gb/s
serial: <filter>
ID-2: /dev/sdb vendor: Hitachi model: HTS545050A7E380 size: 465.76 GiB speed: 3.0 Gb/s
serial: <filter>
ID-3: /dev/sdc vendor: Plextor model: PX-128M5M size: 119.24 GiB speed: 3.0 Gb/s
serial: <filter>
Partition: ID-1: / size: 226.49 GiB used: 7.11 GiB (3.1%) fs: ext4 dev: /dev/sdb1
ID-2: swap-1 size: 8.88 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb5
Sensors: System Temperatures: cpu: 51.0 C mobo: N/A
Fan Speeds (RPM): cpu: 2692
Repos: No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-bionic.list
1: deb http: //ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http: //packages.linuxmint.com tina main upstream import backport #id:linuxmint_main
2: deb http: //archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
3: deb http: //archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
4: deb http: //archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
5: deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
6: deb http: //archive.canonical.com/ubuntu/ bionic partner
Info: Processes: 221 Uptime: 18m Memory: 30.98 GiB used: 1.12 GiB (3.6%) Init: systemd v: 237
runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Client: Unknown python3.6 client inxi: 3.0.32
I'm looking for some guidance on how to activate hardware acceleration on this nvidia driver.
Thanks
Last edited by gbone on Sat Dec 07, 2019 7:05 pm, edited 1 time in total.

User avatar
trytip
Level 12
Level 12
Posts: 4019
Joined: Tue Jul 05, 2016 1:20 pm

Re: Nvidia Quadro no acceleration

Post by trytip » Sun Dec 01, 2019 10:16 pm

how many nvidia do you have

Code: Select all

dpkg -l nvidia*
Image

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Mon Dec 02, 2019 7:58 am

I have tried the nvidia-390 and the nvidia-418 but I do not recall trying nvidia-430.
$ dpkg -l nvidia*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===========================================-==========================-==========================-============================================================================================
un nvidia-304 <none> <none> (no description available)
un nvidia-340 <none> <none> (no description available)
un nvidia-384 <none> <none> (no description available)
un nvidia-390 <none> <none> (no description available)
un nvidia-common <none> <none> (no description available)
ii nvidia-compute-utils-430 430.50-0ubuntu0.18.04.2 amd64 NVIDIA compute utilities
ii nvidia-dkms-430 430.50-0ubuntu0.18.04.2 amd64 NVIDIA DKMS package
un nvidia-dkms-kernel <none> <none> (no description available)
hi nvidia-driver-418 430.50-0ubuntu0.18.04.2 amd64 Transitional package for nvidia-driver-430
ii nvidia-driver-430 430.50-0ubuntu0.18.04.2 amd64 NVIDIA driver metapackage
un nvidia-driver-binary <none> <none> (no description available)
un nvidia-kernel-common <none> <none> (no description available)
ii nvidia-kernel-common-430 430.50-0ubuntu0.18.04.2 amd64 Shared files used with the kernel module
un nvidia-kernel-source <none> <none> (no description available)
ii nvidia-kernel-source-430 430.50-0ubuntu0.18.04.2 amd64 NVIDIA kernel source package
un nvidia-opencl-icd <none> <none> (no description available)
un nvidia-persistenced <none> <none> (no description available)
un nvidia-prime <none> <none> (no description available)
un nvidia-settings <none> <none> (no description available)
un nvidia-smi <none> <none> (no description available)
un nvidia-utils <none> <none> (no description available)
ii nvidia-utils-430 430.50-0ubuntu0.18.04.2 amd64 NVIDIA driver support binaries

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Tue Dec 03, 2019 8:55 pm

I have seen a suggestion to simply upgrade the kernel. Anyone else heard of this approach?

Hoser Rob
Level 15
Level 15
Posts: 5682
Joined: Sat Dec 15, 2012 8:57 am

Re: Nvidia Quadro no acceleration

Post by Hoser Rob » Wed Dec 04, 2019 8:28 am

gbone wrote:
Tue Dec 03, 2019 8:55 pm
I have seen a suggestion to simply upgrade the kernel. Anyone else heard of this approach?
Yes, but on a 2016 machine a 4.15 kernel should work IMO.

Did you instrall those drivers from the nvidia site? That's not such a good idea in Linux. What happens when you run Driver Manager?

User avatar
trytip
Level 12
Level 12
Posts: 4019
Joined: Tue Jul 05, 2016 1:20 pm

Re: Nvidia Quadro no acceleration

Post by trytip » Wed Dec 04, 2019 10:07 am

I have tried the nvidia-390 and the nvidia-418 but I do not recall trying nvidia-430
you have nvidia-430 installed why? you need to purge nvidia reboot and then use driver manager to install nvidia-340 or nvidia-390 whichever is lowest option provided for you in driver manager
Image

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Thu Dec 05, 2019 4:16 pm

trytip wrote:
Wed Dec 04, 2019 10:07 am
I have tried the nvidia-390 and the nvidia-418 but I do not recall trying nvidia-430
you have nvidia-430 installed why? you need to purge nvidia reboot and then use driver manager to install nvidia-340 or nvidia-390 whichever is lowest option provided for you in driver manager
I have purged and then loaded

Code: Select all

$ sudo apt-get purge nvidia*
$ sudo apt-get install nvidia-340
Result: Cinnamon crashes into Fallback Mode

Then I tried

Code: Select all

$ sudo apt-get purge nvidia*
$ sudo apt-get install nvidia-driver-390
Result: No crash and no acceleration

I have also tried

Code: Select all

$ sudo apt-get purge nvidia*
$ sudo apt-get install nvidia-driver-418
Result: No crash, no acceleration. It was this driver that gave the indication of nvidia-430 being used.
According to Nvidia website, the latest driver to support Quadro K1000M is nvidia-driver-418

I have tried the Quadro Optimus setting in the Bios as well as the Quadro Discrete mode but seems to make no difference.

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Thu Dec 05, 2019 4:20 pm

Hoser Rob wrote:
Wed Dec 04, 2019 8:28 am
gbone wrote:
Tue Dec 03, 2019 8:55 pm
I have seen a suggestion to simply upgrade the kernel. Anyone else heard of this approach?
Yes, but on a 2016 machine a 4.15 kernel should work IMO.

Did you instrall those drivers from the nvidia site? That's not such a good idea in Linux. What happens when you run Driver Manager?
I have tried the Nvidia site but also went to ppa. When Driver Manager is run, it provides suggestions for nvidia-340 or nvidia-390, but neither one works for me.

User avatar
roblm
Level 11
Level 11
Posts: 3679
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Quadro no acceleration

Post by roblm » Thu Dec 05, 2019 5:57 pm

When the apt purge command was used, this also removed nvidia-prime, which is needed to switch to the Nvidia GPU, and nvidia-settings and the nvidia-prime applet. Use this command to re-install them:
apt install nvidia-prime nvidia-settings nvidia-prime-applet

Reboot and use these commands and post the output:

Code: Select all

1. lspci -nnk | egrep -A3 -i "3D|VGA"
2. ls /lib/modprobe.d				
3. dpkg -l | grep -i nvidia
4. mokutil --sb-state
5. prime-select query

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Thu Dec 05, 2019 6:29 pm

Looks like I'm missing something

Code: Select all

$ lspci -nnk | egrep -A3 -i "3D|VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
	Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f5]
	Kernel modules: i915
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GLM [Quadro K1000M] [10de:0ffc] (rev a1)
	Subsystem: Lenovo GK107GLM [Quadro K1000M] [17aa:21f5]
	Kernel modules: nvidiafb, nouveau
01:00.1 Audio device [0403]: NVIDIA Corporation GK107 HDMI Audio Controller [10de:0e1b] (rev a1)


ls /lib/modprobe.d/
aliases.conf                            blacklist_linux_4.15.0-72-generic.conf  nvidia-graphics-drivers.conf
blacklist_linux_4.15.0-54-generic.conf  fbdev-blacklist.conf                    systemd.conf


$ dpkg -l | grep -i nvidia
iU  libnvidia-cfg1-390:amd64                   390.116-0ubuntu0.18.04.1                        amd64        NVIDIA binary OpenGL/GLX configuration library
iU  libnvidia-common-390                       390.116-0ubuntu0.18.04.1                        all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-415                       415.27-0ubuntu0~gpu18.04.2                      all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-430                       430.50-0ubuntu0.18.04.2                         all          Shared files used by the NVIDIA libraries
iU  libnvidia-compute-390:amd64                390.116-0ubuntu0.18.04.1                        amd64        NVIDIA libcompute package
rc  libnvidia-compute-415:amd64                415.27-0ubuntu0~gpu18.04.2                      amd64        NVIDIA libcompute package
rc  libnvidia-compute-430:amd64                430.50-0ubuntu0.18.04.2                         amd64        NVIDIA libcompute package
iU  libnvidia-decode-390:amd64                 390.116-0ubuntu0.18.04.1                        amd64        NVIDIA Video Decoding runtime libraries
iU  libnvidia-encode-390:amd64                 390.116-0ubuntu0.18.04.1                        amd64        NVENC Video Encoding runtime library
iU  libnvidia-fbc1-390:amd64                   390.116-0ubuntu0.18.04.1                        amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
iU  libnvidia-ifr1-390:amd64                   390.116-0ubuntu0.18.04.1                        amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
iU  nvidia-compute-utils-390                   390.116-0ubuntu0.18.04.1                        amd64        NVIDIA compute utilities
iU  nvidia-dkms-390                            390.116-0ubuntu0.18.04.1                        amd64        NVIDIA DKMS package
iU  nvidia-driver-390                          390.116-0ubuntu0.18.04.1                        amd64        NVIDIA driver metapackage
iU  nvidia-kernel-common-390                   390.116-0ubuntu0.18.04.1                        amd64        Shared files used with the kernel module
iU  nvidia-kernel-source-390                   390.116-0ubuntu0.18.04.1                        amd64        NVIDIA kernel source package
iU  nvidia-utils-390                           390.116-0ubuntu0.18.04.1                        amd64        NVIDIA driver support binaries
iU  xserver-xorg-video-nvidia-390              390.116-0ubuntu0.18.04.1                        amd64        NVIDIA binary Xorg driver

$ sudo apt install mokutil
[sudo] password for douglas:        
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libnvidia-ifr1-390 : Depends: libnvidia-gl-390 but it is not going to be installed
 nvidia-driver-390 : Depends: libnvidia-gl-390 (= 390.116-0ubuntu0.18.04.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


$ prime-select query

Command 'prime-select' not found, but can be installed with:

sudo apt install nvidia-prime

$ sudo apt install nvidia-prime
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libnvidia-ifr1-390 : Depends: libnvidia-gl-390 but it is not going to be installed
 nvidia-driver-390 : Depends: libnvidia-gl-390 (= 390.116-0ubuntu0.18.04.1) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


User avatar
roblm
Level 11
Level 11
Posts: 3679
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Quadro no acceleration

Post by roblm » Thu Dec 05, 2019 8:06 pm

You used the command sudo apt install mokutil. It should have been mokutil --sb-state

The last Nvidia driver installation failed. No Nvidia kernel modules were built. Use this command to remove that driver:
apt remove nvidia-driver-390; apt autoremove

Reboot and install the recommended driver in Driver Manager; probably nvidia-driver-418

After rebooting, try to install nvidia-prime again: apt install nvidia-prime nvidia-settings nvidia-prime-applet

Reboot and use these commands and post the output.

Code: Select all

1. lspci -nnk | egrep -A3 -i "3D|VGA"
2. ls /lib/modprobe.d				
3. dpkg -l | grep -i nvidia
4. mokutil --sb-state
5. prime-select query
6. ls /etc/modprobe.d

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Thu Dec 05, 2019 9:04 pm

It seems that I cannot get mokutil installed

Image

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Fri Dec 06, 2019 1:43 am

After a system update I was able to perform the above commands"

Code: Select all

$ lspci -nnk | egrep -A3 -i "3D|VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
	Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f5]
	Kernel modules: i915
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GLM [Quadro K1000M] [10de:0ffc] (rev a1)
	Subsystem: Lenovo GK107GLM [Quadro K1000M] [17aa:21f5]
	Kernel modules: nvidiafb, nouveau
01:00.1 Audio device [0403]: NVIDIA Corporation GK107 HDMI Audio Controller [10de:0e1b] (rev a1)


$ ls /lib/modprobe.d/
aliases.conf                            blacklist_linux_4.15.0-72-generic.conf  nvidia-graphics-drivers.conf
blacklist_linux_4.15.0-54-generic.conf  fbdev-blacklist.conf                    systemd.conf



$ dpkg -l | grep -i nvidia
ii  libnvidia-common-390                       390.129-0ubuntu0~gpu18.04.1                     all          Shared files used by the NVIDIA libraries
rc  libnvidia-compute-390:amd64                390.129-0ubuntu0~gpu18.04.1                     amd64        NVIDIA libcompute package
rc  libnvidia-compute-415:amd64                415.27-0ubuntu0~gpu18.04.2                      amd64        NVIDIA libcompute package
rc  libnvidia-compute-430:amd64                430.50-0ubuntu0.18.04.2                         amd64        NVIDIA libcompute package
rc  nvidia-compute-utils-390                   390.129-0ubuntu0~gpu18.04.1                     amd64        NVIDIA compute utilities
rc  nvidia-dkms-390                            390.129-0ubuntu0~gpu18.04.1                     amd64        NVIDIA DKMS package
ii  nvidia-kernel-common-390                   390.129-0ubuntu0~gpu18.04.1                     amd64        Shared files used with the kernel module
ii  nvidia-prime                               0.8.8.2                                         all          Tools to enable NVIDIA's Prime
ii  nvidia-prime-applet                        1.0.7                                           all          An applet for NVIDIA Prime
ii  nvidia-settings                            418.56-0ubuntu0~gpu18.04.1                      amd64        Tool for configuring the NVIDIA graphics driver



$ mokutil --sb-state
EFI variables are not supported on this system



$ prime-select query
nvidia



$ ls /etc/modprobe.d
alsa-base.conf                  blacklist.conf              blacklist-modem.conf         dkms.conf
amd64-microcode-blacklist.conf  blacklist-firewire.conf     blacklist-oss.conf           intel-microcode-blacklist.conf
blacklist-ath_pci.conf          blacklist-framebuffer.conf  blacklist-rare-network.conf  iwlwifi.conf

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Fri Dec 06, 2019 1:57 am

I now opened Driver Manager and there was no recommended driver to install. The choices were Nvidia 304,340, 390, 410,and 415. I chose 415 and got a bunch of errors here:

Code: Select all

Unpacking nvidia-driver-415 (415.27-0ubuntu0~gpu18.04.2) ...
Errors were encountered while processing:
 /tmp/apt-dpkg-install-qYypNZ/46-libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_amd64.deb
 /tmp/apt-dpkg-install-qYypNZ/47-libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_i386.deb
Setting up libedit2:i386 (3.1-20170329-1) ...
Setting up libatomic1:i386 (8.3.0-6ubuntu1~18.04.1) ...
Setting up libglvnd0:i386 (1.0.0-2ubuntu2.3) ...
Setting up libexpat1:i386 (2.2.5-3ubuntu0.2) ...
Setting up libnvidia-common-415 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libelf1:i386 (0.170-0.4ubuntu0.1) ...
Setting up libxshmfence1:i386 (1.3-1) ...
Setting up libglapi-mesa:i386 (19.0.8-0ubuntu0~18.04.3) ...
Setting up libbsd0:i386 (0.8.7-1) ...
Setting up libnvidia-fbc1-415:amd64 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libdrm2:i386 (2.4.97-1ubuntu1~18.04.1) ...
Setting up libnvidia-cfg1-415:amd64 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libx11-xcb1:i386 (2:1.6.4-3ubuntu0.2) ...
dpkg: dependency problems prevent configuration of nvidia-driver-415:
 nvidia-driver-415 depends on libnvidia-gl-415 (= 415.27-0ubuntu0~gpu18.04.2); however:
  Package libnvidia-gl-415:amd64 is not installed.

dpkg: error processing package nvidia-driver-415 (--configure):
 dependency problems - leaving unconfigured
Setting up libpciaccess0:i386 (0.14-1) ...
Setting up libnvidia-compute-415:amd64 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libnvidia-compute-415:i386 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libsensors4:i386 (1:3.4.0-4) ...
dpkg: dependency problems prevent configuration of libnvidia-ifr1-415:amd64:
 libnvidia-ifr1-415:amd64 depends on libnvidia-gl-415; however:
  Package libnvidia-gl-415:amd64 is not installed.

dpkg: error processing package libnvidia-ifr1-415:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnvidia-ifr1-415:i386:
 libnvidia-ifr1-415:i386 depends on libnvidia-gl-415; however:
  Package libnvidia-gl-415:i386 is not installed.

dpkg: error processing package libnvidia-ifr1-415:i386 (--configure):
 dependency problems - leaving unconfigured
Setting up libstdc++6:i386 (8.3.0-6ubuntu1~18.04.1) ...
Setting up libffi6:i386 (3.2.1-8) ...
Setting up libdrm-radeon1:i386 (2.4.97-1ubuntu1~18.04.1) ...
Setting up libxdmcp6:i386 (1:1.1.2-3) ...
Setting up libdrm-nouveau2:i386 (2.4.97-1ubuntu1~18.04.1) ...
Setting up nvidia-utils-415 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up nvidia-kernel-common-415 (415.27-0ubuntu0~gpu18.04.2) ...
update-initramfs: deferring update (trigger activated)
Setting up libxau6:i386 (1:1.0.8-1) ...
Setting up nvidia-kernel-source-415 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libllvm8:i386 (1:8-3~ubuntu18.04.1) ...
Setting up nvidia-compute-utils-415 (415.27-0ubuntu0~gpu18.04.2) ...
Warning: The home directory /nonexistent you specified can not be accessed: No such file or directory
Adding system user `nvidia-persistenced' (UID 122) ...
Adding new group `nvidia-persistenced' (GID 129) ...
Adding new user `nvidia-persistenced' (UID 122) with group `nvidia-persistenced' ...
Not creating home directory `/nonexistent'.
Setting up libdrm-amdgpu1:i386 (2.4.97-1ubuntu1~18.04.1) ...
Setting up xserver-xorg-video-nvidia-415 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libnvidia-decode-415:amd64 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libnvidia-encode-415:amd64 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libdrm-intel1:i386 (2.4.97-1ubuntu1~18.04.1) ...
Setting up libxcb1:i386 (1.13-2~ubuntu18.04) ...
Setting up nvidia-dkms-415 (415.27-0ubuntu0~gpu18.04.2) ...
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
Loading new nvidia-415.27 DKMS files...
Building for 4.15.0-72-generic
Building for architecture x86_64
Building initial module for 4.15.0-72-generic
Done.

nvidia:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-72-generic/kernel/drivers/char/drm/

nvidia-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-72-generic/kernel/drivers/char/drm/

nvidia-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-72-generic/kernel/drivers/char/drm/

nvidia-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.15.0-72-generic/kernel/drivers/char/drm/

depmod........

DKMS: install completed.
Setting up libxcb-present0:i386 (1.13-2~ubuntu18.04) ...
Setting up libxcb-dri2-0:i386 (1.13-2~ubuntu18.04) ...
Setting up libxcb-dri3-0:i386 (1.13-2~ubuntu18.04) ...
Setting up libxcb-glx0:i386 (1.13-2~ubuntu18.04) ...
Setting up libx11-6:i386 (2:1.6.4-3ubuntu0.2) ...
Setting up libgl1-mesa-dri:i386 (19.0.8-0ubuntu0~18.04.3) ...
Setting up libxcb-sync1:i386 (1.13-2~ubuntu18.04) ...
Setting up libxdamage1:i386 (1:1.1.4-3) ...
Setting up libxext6:i386 (2:1.3.3-1) ...
Setting up libxfixes3:i386 (1:5.0.3-1) ...
Setting up libnvidia-decode-415:i386 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libnvidia-encode-415:i386 (415.27-0ubuntu0~gpu18.04.2) ...
Setting up libxxf86vm1:i386 (1:1.1.4-1) ...
Setting up libglx-mesa0:i386 (19.0.8-0ubuntu0~18.04.3) ...
Setting up libglx0:i386 (1.0.0-2ubuntu2.3) ...
Setting up libgl1:i386 (1.0.0-2ubuntu2.3) ...
Setting up libnvidia-fbc1-415:i386 (415.27-0ubuntu0~gpu18.04.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for initramfs-tools (0.130ubuntu3.9) ...
update-initramfs: Generating /boot/initrd.img-4.15.0-72-generic
I: The initramfs will attempt to resume from /dev/sdb5
I: (UUID=5ddd99d5-d6c2-48c2-a1a3-e0c1e5d33110)
I: Set the RESUME variable to override this.
Processing triggers for libc-bin (2.27-3ubuntu1) ...

User avatar
roblm
Level 11
Level 11
Posts: 3679
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Quadro no acceleration

Post by roblm » Fri Dec 06, 2019 9:55 am

Try re-installing nvidia-driver-415 again in the Terminal: apt install --reinstall nvidia-driver-415

Reboot and use this command again: lspci -nnk | egrep -A3 -i "3D|VGA"

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Fri Dec 06, 2019 10:08 am

roblm wrote:
Fri Dec 06, 2019 9:55 am
Try re-installing nvidia-driver-415 again in the Terminal: apt install --reinstall nvidia-driver-415

Reboot and use this command again: lspci -nnk | egrep -A3 -i "3D|VGA"

Code: Select all

$  apt install --reinstall nvidia-driver-415
[sudo] password for douglas:        
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libnvidia-ifr1-415 : Depends: libnvidia-gl-415 but it is not going to be installed
 libnvidia-ifr1-415:i386 : Depends: libnvidia-gl-415:i386 but it is not going to be installed
 nvidia-driver-415 : Depends: libnvidia-gl-415 (= 415.27-0ubuntu0~gpu18.04.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
douglas@douglas-ThinkPad-W530:~$ apt --fix-broken install
apt
Usage: apt command [options]
       apt help command [options]
Any sense in trying nvidia-driver-418?

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Fri Dec 06, 2019 10:22 am

Code: Select all

$ lspci -nnk | egrep -A3 -i "3D|VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
	Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f5]
	Kernel modules: i915
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GLM [Quadro K1000M] [10de:0ffc] (rev a1)
	Subsystem: Lenovo GK107GLM [Quadro K1000M] [17aa:21f5]
	Kernel driver in use: nvidia
	Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

User avatar
roblm
Level 11
Level 11
Posts: 3679
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Quadro no acceleration

Post by roblm » Fri Dec 06, 2019 10:40 am

gbone post wrote:

Code: Select all

$  apt install --reinstall nvidia-driver-415
The following packages have unmet dependencies:
 libnvidia-ifr1-415 : Depends: libnvidia-gl-415 but it is not going to be installed
 libnvidia-ifr1-415:i386 : Depends: libnvidia-gl-415:i386 but it is not going to be installed
 nvidia-driver-415 : Depends: libnvidia-gl-415 (= 415.27-0ubuntu0~gpu18.04.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Try using this command to fix the broken packages: sudo apt-get --fix-broken install

gbone
Level 2
Level 2
Posts: 99
Joined: Wed Aug 20, 2014 7:55 am

Re: Nvidia Quadro no acceleration

Post by gbone » Fri Dec 06, 2019 11:42 am

Code: Select all

$ sudo apt-get --fix-broken install
[sudo] password for douglas:        
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libnvidia-gl-415 libnvidia-gl-415:i386
The following NEW packages will be installed:
  libnvidia-gl-415 libnvidia-gl-415:i386
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0 B/48.7 MB of archives.
After this operation, 218 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 292881 files and directories currently installed.)
Preparing to unpack .../libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_i386.deb ...
dpkg-query: no packages found matching libnvidia-gl-410
diversion of /usr/lib/i386-linux-gnu/libGL.so.1 to /usr/lib/i386-linux-gnu/libGL.so.1.distrib by nvidia-340
dpkg-divert: error: mismatch on package
  when removing 'diversion of /usr/lib/i386-linux-gnu/libGL.so.1 by libnvidia-gl-415'
  found 'diversion of /usr/lib/i386-linux-gnu/libGL.so.1 to /usr/lib/i386-linux-gnu/libGL.so.1.distrib by nvidia-340'
dpkg: error processing archive /var/cache/apt/archives/libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_i386.deb (--unpack):
 new libnvidia-gl-415:i386 package pre-installation script subprocess returned error exit status 2
Preparing to unpack .../libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_amd64.deb ...
dpkg-query: no packages found matching libnvidia-gl-410
diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 to /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib by nvidia-340
dpkg-divert: error: mismatch on package
  when removing 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 by libnvidia-gl-415'
  found 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 to /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib by nvidia-340'
dpkg: error processing archive /var/cache/apt/archives/libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_amd64.deb (--unpack):
 new libnvidia-gl-415:amd64 package pre-installation script subprocess returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_i386.deb
 /var/cache/apt/archives/libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Is the support for this video card as bad as it seems, or do I need to re-install LM 19.2?
Is BIOS boot instead of UEFI creating a problem here?
Maybe LM 18.3 would work better?

User avatar
roblm
Level 11
Level 11
Posts: 3679
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Quadro no acceleration

Post by roblm » Fri Dec 06, 2019 12:02 pm

gbone wrote:

Code: Select all

diversion of /usr/lib/i386-linux-gnu/libGL.so.1 to /usr/lib/i386-linux-gnu/libGL.so.1.distrib by nvidia-340
dpkg-divert: error: mismatch on package
  when removing 'diversion of /usr/lib/i386-linux-gnu/libGL.so.1 by libnvidia-gl-415'
  found 'diversion of /usr/lib/i386-linux-gnu/libGL.so.1 to /usr/lib/i386-linux-gnu/libGL.so.1.distrib by nvidia-340'
dpkg: error processing archive /var/cache/apt/archives/libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_i386.deb (--unpack):
 new libnvidia-gl-415:i386 package pre-installation script subprocess returned error exit status 2
Preparing to unpack .../libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_amd64.deb ...
dpkg-query: no packages found matching libnvidia-gl-410
diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 to /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib by nvidia-340
dpkg-divert: error: mismatch on package
  when removing 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 by libnvidia-gl-415'
  found 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 to /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib by nvidia-340'
dpkg: error processing archive /var/cache/apt/archives/libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_amd64.deb (--unpack):
 new libnvidia-gl-415:amd64 package pre-installation script subprocess returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_i386.deb
 /var/cache/apt/archives/libnvidia-gl-415_415.27-0ubuntu0~gpu18.04.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Those dpkg-divert diversion error messages are sometimes seen when the nvidia-340 driver was initially installed and removed and then a newer driver is intalled. Use this command to remove it:

Code: Select all

for FILE in $(dpkg-divert --list | grep nvidia-340 | awk '{print $3}'); do sudo dpkg-divert --remove $FILE; done
Then try this command again: sudo apt-get --fix-broken install
Last edited by roblm on Fri Dec 06, 2019 12:50 pm, edited 1 time in total.

Post Reply

Return to “Graphics Cards & Monitors”