[SOLVED] No audio in VLC analog capture

Questions about applications and software
Forum rules
Before you post please read how to get help
Locked
milon
Level 2
Level 2
Posts: 59
Joined: Thu Jan 10, 2019 3:20 pm

[SOLVED] No audio in VLC analog capture

Post by milon »

This is mostly a continuation of my previous thread (viewtopic.php?f=49&t=304761) but it's now a software issue, not a hardware one.

I'm trying to digitize my old VHS collection. I purchased the composite-to-USB adapter linked my MrEen in the other thread. I'm trying to use VLC to capture the analog input from the VHS player. (Yes, it works fine - still!) I'm not getting any audio in VLC, but I do get an error message telling me to check the log for more details. I cannot find the log file for the life of me! The VLC wiki doesn't tell me where to find it either, unless I'm really blind today.
MrEen wrote:
Mon Nov 04, 2019 6:29 pm
When you go to use [the adapter], set it as the default input device on pavucontrol's Input Devices tab (by clicking the the check mark next to it) and it will probably work without issue.
If it matters, I don't have checkboxes in my Input tab (I *think* I'm using pavucontrol). It shows the devices side-by-side with text & icons. I can choose analog or multi-channel digital. I think I want analog, but I've tried both options.

Anyway, TLDR = I get no audio in VLC, and VLC throws an error that I can't look into with the log file.

Help?

EDIT - I forgot to say that when I go to capture in VLC, I'm choosing the "TV - analog" option. The device name is "/dev/video0" (the only option). For "Audio device name", the options I have are "hw:1,0" or "hw:1,2" or "hw:4,0". I have no idea what any of those mean, but none of them work and all of them throw the above-mentioned error. Thanks in advance!
Last edited by milon on Mon Dec 23, 2019 10:21 am, edited 1 time in total.
User avatar
MrEen
Level 23
Level 23
Posts: 18140
Joined: Mon Jun 12, 2017 8:39 pm

Re: No audio in VLC analog capture

Post by MrEen »

Hi milon. :D

In the terminal type pavucontrol. If it's not installed, it should tell you, otherwise it will open PulseAudio Volume Control. There, you'll see on the Input Devices tab the check marks for setting a device as the Fallback (default) device. Click on the one for your USB device, then see if that made any difference for VLC. You might need to delete the files in /home/YourUserName/.config/pulse, run pulseaudio -k in the terminal, then verify pavucontrol still has the same device set as the fallback.

Running arecord -l in the terminal will show you the card number/device number of the various sound cards, that can be matched with what VLC offered as "hw:1,0" or "hw:1,2" or "hw:4,0". I'm almost certain your USB device will be hw:4,0.

Actually, you may need to go to the Configuration tab of pavucontrol to make sure the USB device is set with an Input Profile first. Running pacmd list-cards will show us what options are available.
milon
Level 2
Level 2
Posts: 59
Joined: Thu Jan 10, 2019 3:20 pm

Re: No audio in VLC analog capture

Post by milon »

Thanks again, MrEen!!

Turns out I didn't have pavucontrol installed, so I installed it. The device, USBTV007 Video Grabber [EasyCAP] Stereo, was already set as fallback.

I checked the Configuration tab, and its profile had been set to Off. I set it to Stereo Input. Still no success in capturing audio. But (I think!) I got VLC to output some logs now, and it's complaining that the selected audio device doesn't exist ("No such file or directory").

Here's the output of the two other commands:

Code: Select all

tim@TheDesktop:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 2: ALC892 Alt Analog [ALC892 Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 4: usbtv [usbtv], device 0: USBTV Audio [USBTV Audio Input]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Code: Select all

tim@TheDesktop:~$ pacmd list-cards
5 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_01_00.1>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "2"
		alsa.card_name = "HDA NVidia"
		alsa.long_card_name = "HDA NVidia at 0xf7080000 irq 17"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:01:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2"
		device.bus = "pci"
		device.vendor.id = "10de"
		device.vendor.name = "NVIDIA Corporation"
		device.product.id = "0e0f"
		device.product.name = "GK208 HDMI/DP Audio Controller"
		device.string = "2"
		device.description = "GK208 HDMI/DP Audio Controller"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400, available: no)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 300, available: no)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 300, available: no)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5200, available: no)
		output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 100, available: no)
		output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 100, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <off>
	ports:
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
    index: 1
	name: <alsa_card.pci-0000_00_03.0>
	driver: <module-alsa-card.c>
	owner module: 8
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel HDMI"
		alsa.long_card_name = "HDA Intel HDMI at 0x61fc04000 irq 29"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:03.0"
		sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "0c0c"
		device.product.name = "Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Built-in Audio"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400, available: no)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 300, available: no)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 300, available: no)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5200, available: no)
		output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 100, available: no)
		output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 100, available: no)
		output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5200, available: no)
		output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 100, available: no)
		output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 100, available: no)
		output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5200, available: no)
		output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 100, available: no)
		output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 100, available: no)
		output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5200, available: no)
		output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 100, available: no)
		output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 100, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <off>
	ports:
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
    index: 2
	name: <alsa_card.usb-Logitech__Inc._Logitech_Speaker_Lapdesk_N550-00>
	driver: <module-alsa-card.c>
	owner module: 9
	properties:
		alsa.card = "3"
		alsa.card_name = "Logitech Speaker Lapdesk N550"
		alsa.long_card_name = "Logitech, Inc. Logitech Speaker Lapdesk N550 at usb-0000:00:14.0-1.2, full spee"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:14.0-usb-0:1.2:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1.2/3-1.2:1.0/sound/card3"
		udev.id = "usb-Logitech__Inc._Logitech_Speaker_Lapdesk_N550-00"
		device.bus = "usb"
		device.vendor.id = "046d"
		device.vendor.name = "Logitech, Inc."
		device.product.id = "0a24"
		device.product.name = "Logitech Speaker Lapdesk N550"
		device.serial = "Logitech__Inc._Logitech_Speaker_Lapdesk_N550"
		device.form_factor = "speaker"
		device.string = "3"
		device.description = "Logitech Speaker Lapdesk N550"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-speakers-usb"
	profiles:
		output:analog-stereo: Analog Stereo Output (priority 6000, available: unknown)
		output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo>
	sinks:
		alsa_output.usb-Logitech__Inc._Logitech_Speaker_Lapdesk_N550-00.analog-stereo/#4: Logitech Speaker Lapdesk N550 Analog Stereo
	sources:
		alsa_output.usb-Logitech__Inc._Logitech_Speaker_Lapdesk_N550-00.analog-stereo.monitor/#10: Monitor of Logitech Speaker Lapdesk N550 Analog Stereo
	ports:
		analog-output: Analog Output (priority 9900, latency offset 0 usec, available: unknown)
			properties:
				
		iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
    index: 3
	name: <alsa_card.pci-0000_00_14.0-usb-0_7>
	driver: <module-alsa-card.c>
	owner module: 10
	properties:
		alsa.card = "4"
		alsa.card_name = "usbtv"
		alsa.long_card_name = "USBTV Audio at bus 3 device 5"
		device.bus_path = "pci-0000:00:14.0-usb-0:7"
		sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb3/3-7/sound/card4"
		device.vendor.name = "Fushicai"
		device.product.name = "USBTV007 Video Grabber [EasyCAP]"
		device.string = "4"
		device.description = "USBTV007 Video Grabber [EasyCAP]"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card"
	profiles:
		input:stereo-fallback: Stereo Input (priority 51, available: unknown)
		input:multichannel-input: Multichannel Input (priority 1, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <input:stereo-fallback>
	sources:
		alsa_input.pci-0000_00_14.0-usb-0_7.stereo-fallback/#13: USBTV007 Video Grabber [EasyCAP] Stereo
	ports:
		analog-input: Analog Input (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				
		multichannel-input: Multichannel Input (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
    index: 4
	name: <alsa_card.pci-0000_00_1b.0>
	driver: <module-alsa-card.c>
	owner module: 11
	properties:
		alsa.card = "1"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0x61fc00000 irq 30"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "8c20"
		device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "1"
		device.description = "Built-in Audio"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Analog Stereo Input (priority 60, available: no)
		output:analog-stereo: Analog Stereo Output (priority 6000, available: no)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060, available: no)
		output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
		output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (priority 5560, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <output:iec958-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1b.0.iec958-stereo/#1: Built-in Audio Digital Stereo (IEC958)
	sources:
		alsa_output.pci-0000_00_1b.0.iec958-stereo.monitor/#2: Monitor of Built-in Audio Digital Stereo (IEC958)
		alsa_input.pci-0000_00_1b.0.analog-stereo/#3: Built-in Audio Analog Stereo
	ports:
		analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
			properties:
				
		analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: no)
			properties:
				
		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
		iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
			properties:
User avatar
MrEen
Level 23
Level 23
Posts: 18140
Joined: Mon Jun 12, 2017 8:39 pm

Re: No audio in VLC analog capture

Post by MrEen »

I don't use VLC and haven't tried doing what you're attempting, so I'm struggling to find suggestions. Certainly try the Multichannel Input on pavucontrol's Configuration tab as a test, but I'm doubting that'll fix it. Change it back when it doesn't work.

Also, delete the files in /home/YourUserName/.config/pulse then run pulseaudio -k in the terminal in case pulse's input stream config is messed up.

You might also want to try different software. I've seen things like SimpleScreenRecorder recommended for jobs similar to this. Strangely, I'm not finding it available on my 18.3 system, but there are instructions for adding a PPA in that link if you also don't have it available.
Hoser Rob
Level 17
Level 17
Posts: 7272
Joined: Sat Dec 15, 2012 8:57 am

Re: No audio in VLC analog capture

Post by Hoser Rob »

milon wrote:
Thu Dec 19, 2019 5:25 pm
... The VLC wiki doesn't tell me where to find it either...
Have you actually tried searching "linuix vlc location of log files"?
rickNS
Level 6
Level 6
Posts: 1099
Joined: Tue Jan 25, 2011 11:59 pm

Re: No audio in VLC analog capture

Post by rickNS »

Add sound to a vlc capture...
*disclaimer, have not tried with tv input, just screen capture, and that does work as of right now.
picture worth a lot of words, see pic.

VLC log file. does not exist till you tell vlc where to put one (strange behavior ? maybe)

Add log file location;
VLC > Tools > Preferences, at the bottom click the "All" radio button, click "Logger" near top of list, then on the right Browse to location / file name. Example; /home/user/vlc_log.
Then next time you get error / need log file it will be there.

here is screen shot.
Attachments
ksnip_vlc-capture+audio.png
Mint 19.0 mate on 2 identical Thinkpad T420's
milon
Level 2
Level 2
Posts: 59
Joined: Thu Jan 10, 2019 3:20 pm

[SOLVED] Re: No audio in VLC analog capture

Post by milon »

@MrEen, no dice, but good idea. I didn't try the screen recording software since rickNS's solution worked and I prefer to stick to whatever I already have, when possible.

@Hoser Rob, yes, the first thing I tried was an online search. I didn't explicitly state that, however, so you couldn't have known.

@rickNS, Thank you! Setting the Extra Media to alsa:// did the trick - although I had to set my Capture Mode to TV - Analog, rather than Desktop. I'm capturing sound & video both!!

PS - I had already figured out logging (see my previous post), but it didn't create any logs until I had attempted a couple more times (weird). Now it creates logs! And now it's working, I'll probably turn that off again. :lol:
User avatar
MrEen
Level 23
Level 23
Posts: 18140
Joined: Mon Jun 12, 2017 8:39 pm

Re: No audio in VLC analog capture

Post by MrEen »

That's great! Glad you got it sorted out. :D

P.S. It helps tremendously when someone using the same software chimes in, don't it? :wink:
milon
Level 2
Level 2
Posts: 59
Joined: Thu Jan 10, 2019 3:20 pm

Re: [SOLVED] No audio in VLC analog capture

Post by milon »

Definitely! Now if I could just get "perfect" output from these poor old analog sources... :lol:
avantgarden
Level 1
Level 1
Posts: 1
Joined: Thu Apr 23, 2020 8:47 am

Re: [SOLVED] No audio in VLC analog capture

Post by avantgarden »

Great folks! this made my day after strugling for hours. For sound I need to replace 'alsa://' with 'pulse://' and it works like a charm.
Attachments
vlc.png
Locked