[SOLVED] Intel i915 - Disable Modesetting Drivers?

Forum rules
Before you post please read how to get help
Post Reply
nixnuc
Level 1
Level 1
Posts: 10
Joined: Sat Feb 09, 2019 5:26 pm

[SOLVED] Intel i915 - Disable Modesetting Drivers?

Post by nixnuc »

Hey everyone,

Linux noob here - can someone point me to a tutorial on how I disable modesetting and revert to intel propriety drivers for my intel i915 GPU?

Here is inxi -G results:

Graphics:
Device-1: Intel driver: i915 v: kernel
Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT3)
v: 4.5 Mesa 19.0.8

I've tried "nomodeset" in GRUB, and that loads fbdev but I can't change resolutions (it's stuck on some ridiculously high 3840 x res).

Reason I ask is that I'm experiencing some lag issues gaming in Wine when the mouse is moved, and another user reported this issue was fixed for him when loading the intel propriety drivers.

Thanks!
Last edited by nixnuc on Wed Jan 01, 2020 8:45 pm, edited 1 time in total.
rene
Level 20
Level 20
Posts: 10682
Joined: Sun Mar 27, 2016 6:58 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by rene »

It's not a proprietary driver, but in any case, installing it and rebooting should be all there's to it: sudo apt-get install xserver-xorg-video-intel.
nixnuc
Level 1
Level 1
Posts: 10
Joined: Sat Feb 09, 2019 5:26 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by nixnuc »

Hey Rene,

Thank you for replying.

Apparently I already had the drivers installed?

"sudo apt-get install xserver-xorg-video-intel
Reading package lists... Done
Building dependency tree
Reading state information... Done
xserver-xorg-video-intel is already the newest version (2:2.99.917+git20171229-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
"
Strange since I thought they'd show up in unloaded when I inxi - G
rene
Level 20
Level 20
Posts: 10682
Joined: Sun Mar 27, 2016 6:58 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by rene »

Mmm. What kernel version are you on? uname -r from a terminal tells. If upgrading to the current 5.0 or 5.3 kernel does not help as advise, we'll need some more information; in that case please post the output of inxi -Fxz. But first:

I'd try the latest 5.3. In Update Manager (the shield icon in your tray), use View -> Linux kernels, install the latest 5.3 (currently 5.3.0-24) and reboot. Does inxi -Gx now indicate the intel driver?

Also finding something about relatively recently still needing i915.alpha_support=1 as a kernel parameter on newish hardware that identifies same as yours; if above does not bring immediate success, try (additionally) nano /etc/default/grub and adding said parameter to the GRUB_CMDLINE_LINUX_DEFAULT="..." line, inside of the quotes, save the file, run sudo update-grub and reboot.

If still nothing, please the requested inxi -Fxz output, preferably inside of [code]...[/code] tags.
nixnuc
Level 1
Level 1
Posts: 10
Joined: Sat Feb 09, 2019 5:26 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by nixnuc »

I actually upgraded my Linux kernel last night:

uname - r shows 5.3.0-24-generic

I added i915.alpha_support=1 as kernel parameter per your recommendation and "sudu update-grub" and rebooted, but driver still shows as modesetting:

Code: Select all

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="i915.alpha_support=1"
Here is inxi - Fxz as requested:

Code: Select all

System:
  Host: NUC Kernel: 5.3.0-24-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Intel Client Systems product: NUC8i5BEK 
  v: J72742-303 serial: <filter> 
  Mobo: Intel model: NUC8BEB v: J72692-303 serial: <filter> UEFI: Intel 
  v: BECFL357.86A.0077.2019.1127.1452 date: 11/27/2019 
CPU:
  Topology: Quad Core model: Intel Core i5-8259U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36799 
  Speed: 700 MHz min/max: 400/3800 MHz Core speeds (MHz): 1: 722 2: 746 
  3: 742 4: 791 5: 797 6: 713 7: 792 8: 749 
Graphics:
  Device-1: Intel driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT3) 
  v: 4.5 Mesa 19.0.8 direct render: Yes 
Audio:
  Device-1: Intel driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Device-2: Licensed by Sony Entertainment America Rocksmith Guitar Adapter 
  type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-1:2 
  Sound Server: ALSA v: k5.3.0-24-generic 
Network:
  Device-1: Intel driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-2: Intel Ethernet I219-V driver: e1000e v: 3.2.6-k port: efa0 
  bus ID: 00:1f.6 
  IF: eno1 state: down mac: <filter> 
Drives:
  Local Storage: total: 476.77 GiB used: 298.09 GiB (62.5%) 
  ID-1: /dev/mmcblk0 model: SC256 size: 238.30 GiB 
  ID-2: /dev/sda vendor: SK Hynix model: SC311 SATA 256GB size: 238.47 GiB 
Partition:
  ID-1: / size: 233.24 GiB used: 193.97 GiB (83.2%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 41.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 250 Uptime: 8m Memory: 7.64 GiB used: 1.10 GiB (14.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.27 
rene
Level 20
Level 20
Posts: 10682
Joined: Sun Mar 27, 2016 6:58 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by rene »

I believe you need the HWE (hardware enablement) xserver: https://wiki.ubuntu.com/Kernel/LTSEnablementStack, the section for Ubuntu 18.04 (the base of Mint 19).

Was actually vaguely recalling that 19.3 [edit: n/m; see you're in fact on 19.1] had it by default but appears that may not be the case. The linux-generic-hwe-18.04 is actually the 5.0 kernel it seems, so skip that, but install xserver-xorg-hwe-18.04,

Code: Select all

sudo apt-get install --install-recommends xserver-xorg-hwe-18.04
and again reboot.
nixnuc
Level 1
Level 1
Posts: 10
Joined: Sat Feb 09, 2019 5:26 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by nixnuc »

Thank you again for all of your help Rene.

I installed xserver-xorg-hwe-18.04, rebooted but inxi -G still displays:

Code: Select all

Graphics:
  Device-1: Intel driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (Coffeelake 3x8 GT3) 
  v: 4.5 Mesa 19.0.8 
It's very puzzling!
rene
Level 20
Level 20
Posts: 10682
Joined: Sun Mar 27, 2016 6:58 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by rene »

Narf. This was supposed to be a one-reply+thank-you thread... :?

Well, yes, unfortunate; I expected that would've done it. I assume that you are still on 5.3.0-24 and with i915.alpha_support=1 (although I don't believe latter is in fact necessary on 5.3 for your hardware)? Really the only thing left I can suggest now is upgrading Mesa. Do note that we're getting ever deeper into the rabbit hole there, but if you still care to try:

Code: Select all

$ sudo add-apt-repository ppa:paulo-miguel-dias/pkppa
$ sudo apt-get update
There are instructions for reverting if not useful there as well, see https://launchpad.net/~paulo-miguel-dia ... ntu/pkppa/, but frankly, we're after that approaching a point were I'd personally start suggesting a reinstall as the most full-proof method to return to a pristine system.
User avatar
roblm
Level 15
Level 15
Posts: 5504
Joined: Sun Feb 24, 2013 2:41 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by roblm »

I don’t know if this will work in Mint 19.3, as in previous versions.
To switch to the intel driver, use this command to create an xorg.conf file:
sudo touch /etc/X11/xorg.conf

Open the file for editing: xed admin:///etc/X11/xorg.conf

Add these lines:

Code: Select all

Section "Device"
   Identifier "Device0"
   Driver "intel"
EndSection
Log out and back in.
nixnuc
Level 1
Level 1
Posts: 10
Joined: Sat Feb 09, 2019 5:26 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by nixnuc »

Believe me, I was hoping this would be a one-reply+thank-you thread too :lol:

I'll make a recent Timeshift backup and then continue on with the Mesa upgrades to see if this works.
nixnuc
Level 1
Level 1
Posts: 10
Joined: Sat Feb 09, 2019 5:26 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by nixnuc »

roblm wrote:
Wed Jan 01, 2020 8:27 pm
I don’t know if this will work in Mint 19.3, as in previous versions.
To switch to the intel driver, use this command to create an xorg.conf file:
sudo touch /etc/X11/xorg.conf

Open the file for editing: xed admin:///etc/X11/xorg.conf

Add these lines:

Code: Select all

Section "Device"
   Identifier "Device0"
   Driver "intel"
EndSection
Log out and back in.
That did the trick - thank you!

inxi -G now shows i915 running on intel drivers.

Will this be persistent with reboots, etc. until I remove the lines in the xorg.conf file?
User avatar
roblm
Level 15
Level 15
Posts: 5504
Joined: Sun Feb 24, 2013 2:41 pm

Re: Intel i915 - Disable Modesetting Drivers?

Post by roblm »

nixnuc wrote: Will this be persistent with reboots, etc. until I remove the lines in the xorg.conf file?
Yes.

The Intel drivers have three parts - the 2D or DDX driver, either xserver-xorg-video-intel or the modesetting driver, the Mesa driver for 3D acceleration and the kernel component, the i915 module.

The Intel DDX driver has slight speed advantages over the generic modesetting driver. If you get no performance boost, then try rene’s suggestion, which will update the Mesa driver.
rene
Level 20
Level 20
Posts: 10682
Joined: Sun Mar 27, 2016 6:58 pm

Re: [SOLVED] Intel i915 - Disable Modesetting Drivers?

Post by rene »

I see; didn't know you could force that; thought it was automatic or simply not. Hope the behaviour's better now...
nixnuc
Level 1
Level 1
Posts: 10
Joined: Sat Feb 09, 2019 5:26 pm

Re: [SOLVED] Intel i915 - Disable Modesetting Drivers?

Post by nixnuc »

Perfect, thank you to both for your help/patience in solving this!

The new Mesa driver rene recommended is running great and everything is smooth as silk now.
rene
Level 20
Level 20
Posts: 10682
Joined: Sun Mar 27, 2016 6:58 pm

Re: [SOLVED] Intel i915 - Disable Modesetting Drivers?

Post by rene »

Good to know. The end of support for Windows 7 will likely have more users used to being able to in fact game on computers show up in the coming weeks/months....
Post Reply

Return to “Graphics Cards & Monitors”