Disable boot from external usb drive

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
menhir
Level 2
Level 2
Posts: 52
Joined: Sat Mar 15, 2014 1:46 pm

Disable boot from external usb drive

Post by menhir »

On my recent installation of 19.3, I installed from a USB flash drive, the first time I've used one instead of a CD...
I went into the BIOS to get the computer to boot from the USB...Everything works fine.

Here's my problem:
I had a relatively new external disc drive that I'd like to keep plugged into my computer via USB. It works fine, too.
But if I restart my computer with the external drive plugged it, tries to boot from that drive: I get the message: BOOTMGR IS MISSING.
I have to unplug the external drive, restart the computer, and plug the drive in again.

I tried to change the BIOS, and here is what I'm getting:

Boot from -
CD-ROM
USB Drive
Hard Drive
IBA GE Slot 00C8V1324

I've tried CD-ROM and Hard Drive, but it still tries to boot from the external drive if it's plugged in.
I haven't tried the last option yet because I don't want to keep on fiddling around anymore until I know I'm doing. :roll:

Any help would be appreciated.

User avatar
Flemur
Level 17
Level 17
Posts: 7650
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Disable boot from external usb drive

Post by Flemur »

menhir wrote:
Thu Jan 16, 2020 12:40 pm
I tried to change the BIOS, and here is what I'm getting:

Boot from -
CD-ROM
USB Drive
Hard Drive
IBA GE Slot 00C8V1324
I'm not clear: can you set the first boot device to "Hard Drive"? And it still tries to boot from the USB?

FWIW, I can disable booting from USB by disabling USB 'Legacy' mode in BIOS, everything else still works OK.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

ventse
Level 1
Level 1
Posts: 3
Joined: Thu Jan 16, 2020 12:35 pm

Re: Disable boot from external usb drive

Post by ventse »

As @Flemur said you should try to put Hard Drive as the first boot device.
In some BIOS you are able to modify the order of the list with some F-keys.

It should look like this:
Hard Drive
CD-ROM
USB Drive
IBA GE Slot 00C8V1324

menhir
Level 2
Level 2
Posts: 52
Joined: Sat Mar 15, 2014 1:46 pm

Re: Disable boot from external usb drive

Post by menhir »

Flemur wrote:
Thu Jan 16, 2020 12:52 pm

I'm not clear: can you set the first boot device to "Hard Drive"? And it still tries to boot from the USB?

FWIW, I can disable booting from USB by disabling USB 'Legacy' mode in BIOS, everything else still works OK.
I set the com to boot from the USB flash drive to install Mint.
After I set everything up to my liking, I restarted the computer and found it was looking to boot from the external drive.
I'd unplug the external drive, restart again and everything would boot up normally.

I tried changing the BIOS to boot from the hard drive, but it would still try to boot from the external drive if it was plugged in at time.
I also tried changing it to boot from CD-ROM just to see what happens. Same result.

It's easy enough to unplug the external drive whenever I have to restart, but I'm still curious about finding a solution.

User avatar
Flemur
Level 17
Level 17
Posts: 7650
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Disable boot from external usb drive

Post by Flemur »

menhir wrote:
Thu Jan 16, 2020 2:47 pm
I tried changing the BIOS to boot from the hard drive, but it would still try to boot from the external drive if it was plugged in at time.
That doesn't sound right - what kind of computer is it?
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

menhir
Level 2
Level 2
Posts: 52
Joined: Sat Mar 15, 2014 1:46 pm

Re: Disable boot from external usb drive

Post by menhir »

Flemur wrote:
Thu Jan 16, 2020 2:53 pm
That doesn't sound right - what kind of computer is it?
Truth.

It's an older Compaq 6000 desktop. I've been running an older version of Linux on it for years at my business. Now it's home and I'm using it as the test dummy for the other Windows 7 computers at home that I'm converting to Linux.

Incidentally, just after my previous post I went into the BIOS again the changed the boot options to hard drive.
Restarted the computer again with the external drive plugged in and once again, it tried to boot from the external drive.

It seems like the computer can't discern it's own hard drive from the external one.
A hard drive is a hard drive is a hard drive as far is it's concerned, I guess. :wink:

Post Reply

Return to “Newbie Questions”