Mint Cinnamon freezes every ~20-30 seconds

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
Kramps
Level 1
Level 1
Posts: 1
Joined: Sat Feb 15, 2020 5:20 am

Mint Cinnamon freezes every ~20-30 seconds

Post by Kramps »

Hi!

I just installed Mint on my Acer Predator yesterday. I had the issue that the PC wouldn't find the mmx64.efi file, but after using the usb boot medium to copy and rename grubx64.efi (as was the solution here: viewtopic.php?t=308137) and everything seemed to work fine.
However, after maybe half an hour of installing apps and getting the whole thing up, the system started to freeze randomly every 20-30 seconds or so.
The freezes take about 10 seconds, and during that time the CPU usage of one or two cores seems to spike, as well as the Notebook coolers acting up.
And after a while it would just freeze completely, forcing me to use ALT+Prnt+R+E+I+S+U+B or holding down the power button for 5 seconds.
I tried using a different NVidia driver, and that didn't change anything.
I also tried disabling Dropbox synch (which is the only process running right now), but that also changed nothing.

Here's my

Code: Select all

inxi -Fxxxrz

Code: Select all

System:
  Host: krampus-Notebook Kernel: 4.15.0-76-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.8 wm: muffin 4.4.2 
  dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Acer product: Predator G9-592 v: V1.08 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Acer model: Mustang_SLS v: V1.08 serial: <filter> UEFI: Acer v: 1.08 
  date: 10/02/2018 
Battery:
  ID-1: BAT0 charge: 83.1 Wh condition: 86.2/90.0 Wh (96%) volts: 16.6/14.8 
  model: AS15B3N type: Li-ion serial: <filter> status: Unknown 
CPU:
  Topology: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP 
  arch: Skylake-S rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41472 
  Speed: 2748 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 3254 2: 3298 
  3: 3206 4: 3210 5: 3177 6: 3284 7: 3493 8: 3294 
Graphics:
  Device-1: Intel HD Graphics 530 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:191b 
  Device-2: NVIDIA GM204M [GeForce GTX 980M] vendor: Acer Incorporated ALI 
  driver: nvidia v: 430.50 bus ID: 01:00.0 chip ID: 10de:13d7 
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia 
  unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 980M/PCIe/SSE2 v: 4.6.0 NVIDIA 430.50 
  direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  vendor: Acer Incorporated ALI Sunrise Point-H driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
  Device-2: NVIDIA GM204 High Definition Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fbb 
  Sound Server: ALSA v: k4.15.0-76-generic 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks driver: ath10k_pci v: kernel port: a000 
  bus ID: 02:00.0 chip ID: 168c:003e 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: alx v: kernel port: 9000 
  bus ID: 03:00.0 chip ID: 1969:e0a1 
  IF: enp3s0 state: down mac: <filter> 
  Device-3: Atheros type: USB driver: btusb bus ID: 1-7:2 chip ID: 0cf3:e300 
Drives:
  Local Storage: total: 2.05 TiB used: 27.68 GiB (1.3%) 
  ID-1: /dev/sda vendor: LITE-ON model: CV1-8B256 size: 238.47 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 201 scheme: GPT 
  ID-2: /dev/sdb vendor: Seagate model: ST2000LM003 HN-M201RAD 
  size: 1.82 TiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 0001 scheme: GPT 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: b060 bus ID: 00:17.0 chip ID: 8086.282a rev: 31 
Partition:
  ID-1: / size: 233.23 GiB used: 27.67 GiB (11.9%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nvidia temp: 55 C 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
  1: deb [arch=amd64] https://repo.skype.com/deb stable main
Info:
  Processes: 257 Uptime: 5m Memory: 15.55 GiB used: 1.46 GiB (9.4%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Shell: bash 
  v: 4.4.20 running in: gnome-terminal inxi: 3.0.32

HAWR
Level 5
Level 5
Posts: 996
Joined: Thu Jun 06, 2019 1:15 pm

Re: Mint Cinnamon freezes every ~20-30 seconds

Post by HAWR »

Hello Kramps,

I remember that such freezes can have something to with the cpu power management settings in the BIOS. You could try, whether the following how-to can help you in solving it:

https://www.thomas-krenn.com/en/wiki/Di ... nt_in_BIOS

User avatar
MrEen
Level 16
Level 16
Posts: 6864
Joined: Mon Jun 12, 2017 8:39 pm

Re: Mint Cinnamon freezes every ~20-30 seconds

Post by MrEen »

Also, did you load any CPU/GPU monitoring applets? I know some people had audio skips every x seconds when these were loaded. It's likely HAWR's suggestion is more appropriate as I've never read of those freezing up the whole system, but just wanted to mention it.

Post Reply

Return to “Software & Applications”