Live boot with no csm

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read how to get help
Post Reply
Vollfeiw
Level 1
Level 1
Posts: 2
Joined: Sat Feb 15, 2020 6:17 am

Live boot with no csm

Post by Vollfeiw »

Hello,

I just got a laptop that need to get a linux on it, and here's the problem,

The key (seen in UEFI) can't boot, i don't even have access to the live boot, nor grub. It just instantly failed with no error.
It just send me back to boot selection or, if i launch withtout boot selector, just send me back to the current windows boot manager, wich is obviously hwat i'm trying to get rid off.

The main probleme is i used to boot with CSM support, but this bios doesn't have it, i have access to secure boot option, sata is set as ahci, fast boot obviously disabled, but no legacy / CSM, wich is kinda frustrating.

I tried to make an fresh new usb with FAT32 and GPT, just in case it was a problem, and then again, no boot.

Tried with balenaEtcher and rufus (iso and DD mode), and then the problem is still there. So i tired the same conf but with my debian iso, and boom, it works. The main thing is, I don't want to use debian.

Currently trying to install LM64 19.1 cinnamon

Is there a way to boot live usb without csm support ?
Seems to be the problem right now

asinoro
Level 4
Level 4
Posts: 384
Joined: Mon Feb 12, 2018 11:43 am

Re: Live boot with no csm

Post by asinoro »

Run this command and post it by copy and paste selecting the symbol </>

Code: Select all

inxi -Fxz

User avatar
LanceM
Level 7
Level 7
Posts: 1790
Joined: Sun Jul 08, 2018 11:50 pm

Re: Live boot with no csm

Post by LanceM »

asinoro wrote:
Sat Feb 15, 2020 11:44 am
Run this command and post it by copy and paste selecting the symbol </>

Code: Select all

inxi -Fxz
Unless I misunderstand the OP's question, how can he run that if it won't even live boot?
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php

asinoro
Level 4
Level 4
Posts: 384
Joined: Mon Feb 12, 2018 11:43 am

Re: Live boot with no csm

Post by asinoro »

LanceM wrote:
Sat Feb 15, 2020 12:14 pm
asinoro wrote:
Sat Feb 15, 2020 11:44 am
Run this command and post it by copy and paste selecting the symbol </>

Code: Select all

inxi -Fxz
Unless I misunderstand the OP's question, how can he run that if it won't even live boot?
So i tired the same conf but with my debian iso, and boom, it works. The main thing is, I don't want to use debian.

User avatar
pbear
Level 10
Level 10
Posts: 3225
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Live boot with no csm

Post by pbear »

Might have to install inxi, though. Not standard on Ubuntu. No idea about Debian.

ETA: As regards, "Is there a way to boot live usb without csm support?," yes, Mint boots fine in UEFI. Has for a long time. It even boots with secure boot enabled. So either you're burning the USB incorrectly or there's some peculiar quirk of your system. An inxi report will help with diagnosis.
Last edited by pbear on Sun Feb 16, 2020 12:00 am, edited 1 time in total.
Time flies like an arrow. Fruit flies like a banana.
If your problem has been solved, please edit the thread title.

User avatar
LanceM
Level 7
Level 7
Posts: 1790
Joined: Sun Jul 08, 2018 11:50 pm

Re: Live boot with no csm

Post by LanceM »

Try Universal USB Installer (UUI). Disable your antivirus while creating the live boot stick on Windows. Format the stick to FAT32 with an MBR. When you select the distribution in the UUI interface, choose Mint under the ----- in the dropdown. Do not use persistence setting (the slider at the bottom). UUI download: https://www.pendrivelinux.com/universal ... -as-1-2-3/
To mark this issue solved, go to your original 1st post and click the edit pencil and add [Solved] at the beginning of the title and click Submit.
Mint accepts donations: https://linuxmint.com/donors.php

Vollfeiw
Level 1
Level 1
Posts: 2
Joined: Sat Feb 15, 2020 6:17 am

Re: Live boot with no csm

Post by Vollfeiw »

Hi, thanks for your answers.

I don't think i burn it incorrectly, it worked multiple ways, and it works pretty well with debian, but for any reason, it just doesn't work here so i bet the "or there's some peculiar quirk of your system". I'll try with UUI and i'll also try with 19.3 as well. If it fails, i'll go for the inxi reports.

I'll keep you up about this tomorrow.

Post Reply

Return to “Installation & Boot”