Black screen after opening laptop lid (not waking up from being suspended)

Forum rules
Before you post please read how to get help
Post Reply
ZulfenFloof
Level 1
Level 1
Posts: 1
Joined: Mon Feb 24, 2020 2:17 pm

Black screen after opening laptop lid (not waking up from being suspended)

Post by ZulfenFloof »

Hello! As you can see in the title, I am having issues with the system not properly waking up while opening the laptop lid. It sometimes works fine, but almost all of the time this happens. Sorry if my description is a bit brief, not sure if I can explain it any other way. I am very new to GNU/Linux in general if i'm going to be honest.

I am running 64-bit 19.3 Tricia with the XFCE window manager (I do apologise if i have posted this in the wrong place by the way, thought this would be an appropriate place to post it).
Here are more detailed specs:

Code: Select all

System:
  Host: zulfenfloof-NF110-NF210-NF310 Kernel: 5.3.0-40-generic x86_64 
  bits: 64 compiler: gcc v: 7.4.0 Desktop: Xfce 4.14.1 tk: Gtk 3.22.30 
  info: xfce4-panel wm: xfwm4 dm: LightDM 1.26.0 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: SAMSUNG product: NF110/NF210/NF310 v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: SAMSUNG model: NF110/NF210/NF310 serial: <filter> BIOS: Phoenix 
  v: 04MY.M033.20110308.JIP date: 03/08/2011 
Battery:
  ID-1: BAT1 charge: 17.6 Wh condition: 45.1/48.8 Wh (92%) volts: 7.1/7.4 
  model: SAMSUNG Electronics type: Li-ion serial: N/A status: Discharging 
CPU:
  Topology: Dual Core model: Intel Atom N550 bits: 64 type: MT MCP 
  arch: Bonnell rev: A L2 cache: 512 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 11969 
  Speed: 998 MHz min/max: 1000/1500 MHz Core speeds (MHz): 1: 997 2: 997 
  3: 997 4: 997 
Graphics:
  Device-1: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics 
  vendor: Samsung Co driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:a011 
  Display: x11 server: X.Org 1.20.5 driver: intel 
  unloaded: fbdev,modesetting,vesa resolution: 1024x600~60Hz 
  OpenGL: renderer: Mesa DRI Intel Pineview M v: 1.4 Mesa 19.2.8 
  direct render: Yes 
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Samsung Co 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:27d8 
  Sound Server: ALSA v: k5.3.0-40-generic 
Network:
  Device-1: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network 
  Adapter 
  vendor: Wistron NeWeb driver: wl v: kernel port: 18a0 bus ID: 05:00.0 
  chip ID: 14e4:4727 
  IF: wlp5s0 state: up mac: <filter> 
  Device-2: Marvell 88E8040 PCI-E Fast Ethernet vendor: Samsung Co 
  driver: sky2 v: 1.30 port: 2000 bus ID: 09:00.0 chip ID: 11ab:4354 
  IF: enp9s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 232.89 GiB used: 9.50 GiB (4.1%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS543225A7A384 size: 232.89 GiB 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: A60W scheme: MBR 
Partition:
  ID-1: / size: 228.23 GiB used: 9.50 GiB (4.2%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 

Yeah, this is a pretty old netbook. I have looked around on Google of course for any solutions, but couldn't find any :/
I have toyed around with the power manager settings. This issue only occurs when the laptop is suspended.
Thanks for reading this far! Is there anything I can do to solve this :? ?
Last edited by WharfRat on Mon Feb 24, 2020 2:39 pm, edited 1 time in total.
Reason: Changed quote tag to code tag

Shidifen
Level 2
Level 2
Posts: 52
Joined: Thu Mar 09, 2017 1:10 am

Re: Black screen after opening laptop lid (not waking up from being suspended)

Post by Shidifen »

This used to happen intermittently on my Acer laptop as well, about a year ago. In frustration one day, instead of holding the power button down to switch off, I just typed my password into the blank screen and it worked. The problem fixed itself up soon after, maybe due to a kernel update. I really don't know what caused the problem or what solved it.

Scorp6
Level 1
Level 1
Posts: 19
Joined: Mon Oct 07, 2019 2:24 am

Re: Black screen after opening laptop lid (not waking up from being suspended)

Post by Scorp6 »

I have this same issue on my 19.3 xfce. I open the lid and the login screen comes up fine. As soon as I enter my password I get the black screen. I have noticed that the computer still operates though. I have found I'm able to CTRL+ALT+t to open a terminal and type reboot to at least safely shut it down.

One work-around that seems to work for me is to CTRL+ALT+l to lock the screen before shutting the lid. When doing this, I don't believe I've ever logged into a black screen. That being said, I'd love a fix as well.

berlin18
Level 1
Level 1
Posts: 1
Joined: Mon Mar 30, 2020 2:31 pm

Re: Black screen after opening laptop lid (not waking up from being suspended)

Post by berlin18 »

I do have the same problem,using Linux Mint 19.3 Xfce 32-bit. After the laptop has gone to standby, be it by closing the lid or after inactivity, I get a black screen after logging in. The white arrow (or hand) of the cursor is however active.
I am able to get the log-in screen again through ctrl+alt+del or ctro+alt+l as suggested Scorp6. But ctrl+alt+l before closing the lid did not solve the problem, unfortunately.

Does anybody else have any idea? I am very new to Linux.

Post Reply

Return to “Xfce”