How can i remove 'minecraft-installer' that causes dpkg errors?

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
TK66
Level 1
Level 1
Posts: 1
Joined: Sat Feb 02, 2019 12:47 pm
Location: Philippines

How can i remove 'minecraft-installer' that causes dpkg errors?

Post by TK66 »

Greenie here...
running Linux Mint 19.1 Cinnamon x64

Code: Select all

System:
  Host: TKLinux-PC Kernel: 4.15.0-20-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Cinnamon 4.0.8 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Sony product: VGN-NW238F v: C602N87J serial: <filter> 
  Mobo: Sony model: VAIO serial: <filter> BIOS: American Megatrends 
  v: R1120Y4 date: 08/20/2009 
Battery:
  ID-1: BAT0 charge: 13.2 Wh condition: 17.2/41.1 Wh (42%) model: Sony Corp. 
  status: Charging 
CPU:
  Topology: Dual Core model: Pentium T4300 bits: 64 type: MCP arch: Penryn 
  rev: A L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 8372 
  Speed: 1196 MHz min/max: 1200/2100 MHz Core speeds (MHz): 1: 1196 2: 1196 
Graphics:
  Device-1: Intel Mobile 4 Series Integrated Graphics vendor: Sony 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Mobile Intel GM45 Express v: 2.1 Mesa 18.0.5 
  direct render: Yes 
Audio:
  Device-1: Intel 82801I HD Audio vendor: Sony driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-20-generic 
Network:
  Device-1: Marvell 88E8057 PCI-E Gigabit Ethernet vendor: Sony driver: sky2 
  v: 1.30 port: d000 bus ID: 01:00.0 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter 
  vendor: Foxconn T77H126.00 802.11bgn driver: ath9k v: kernel port: d000 
  bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 64.60 GiB (13.9%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LM030-2E717D size: 465.76 GiB 
Partition:
  ID-1: / size: 457.45 GiB used: 64.60 GiB (14.1%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 58.0 C mobo: 58.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 200 Uptime: 43m Memory: 3.70 GiB used: 2.03 GiB (54.9%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27
PROBLEM:I can't remove the minecraft installer and it prevents me from installing other softwares...

I tried installing minecraft a long time ago but decided to abort it instead because of the reviews i've seen in the software manager. When the time came that i needed to install new software, iinux always aborts the process and returns 'error code (2)' from dpkg.

I already tried to sudo remove it, still returns the same error, also tried sudo apt purge minecraft-installer in root but it still returned the same errors

Code: Select all

root@TKLinux-PC:/home/tk66# sudo apt purge minecraft-installer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED
  minecraft-installer*
0 to upgrade, 0 to newly install, 1 to remove and 615 not to upgrade.
1 not fully installed or removed.
After this operation, 31.7 kB disk space will be freed.
Do you want to continue? [Y/n] y
dpkg: unrecoverable fatal error, aborting:
 reading files list for package 'grub-gfxpayload-lists': Input/output error
E: Sub-process /usr/bin/dpkg returned an error code (2)


Last bumped by TK66 on Thu Mar 26, 2020 9:56 pm.

Post Reply

Return to “Software & Applications”