(Solved) Stuck in 640 X 480 with no hardware acceleration.

Quick to answer questions about finding your way around Linux Mint as a new user.
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
SeanIE
Level 1
Level 1
Posts: 8
Joined: Thu Mar 26, 2020 1:31 pm

(Solved) Stuck in 640 X 480 with no hardware acceleration.

Post by SeanIE »

Hi all,

I'm a new Mint user, but at the moment I cannot use it. I'm having a problem in that my display resolution is stuck at 640*480 and with a warning at startup: "Currently running without video hardware acceleration". I'm using an nVidia GeForce 1050Ti. I'm currently using an HDMI cable to connect that card to my monitor, but am using a separate 3.5mm cable to handle audio. I have a number of hard drives, all exFAT except for the Linux boot drive (ext4 I think) and the Windows boot drive, NTFS. I'm trying to dual-boot, with a choice at startup between Mint 19.3 64 bit with Cinnamon display and Windows 10.

It's a bit messy because when I run Mint from a Live USB stick, it works fine and after I install Mint, it also works fine for the first few restarts. Then I get the above warning and am told to launch Driver Manager, at which point I can make it work again by switching (from the nVidia driver) to the X11 Noveau driver. But that fix only lasts a session or two, after which I get permanently stuck at 640*480 and when prompted to launch Driver Manager, the only enabled option is "Continue using a manually installed driver" (which I never installed, obviously) and the Revert and Apply Changes buttons are not enabled.

Unfortunately, I had re-installed Mint because the last installation failed in almost exactly the same way. My problem is somewhat similar to what this user had some years ago: viewtopic.php?t=185774

Except I'm using nVidia graphics instead of SiS, my hardware is considerably newer, my system does work for the first few sessions after installation, and I'm getting warning messages about video acceleration that this user might not have, so I'm not sure how much overlap there is. As far as fixes go I'm more or less stuck with the command prompt, because obviously at 640*480 the system is not usable. So I'm stuck using Windoze all the time for now. :cry:

In the hope it might help, I took some advice from that thread and did a dump from the inxi program,

Code: Select all

sean@sean-MS-7971:~$ inxi -Fx
System:
  Host: sean-MS-7971 Kernel: 5.0.0-32-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.4.5 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop Mobo: MSI model: Z170A PC MATE (MS-7971) v: 2.0 
  serial: <root required> UEFI [Legacy]: American Megatrends v: A.A0 
  date: 07/27/2016 
CPU:
  Topology: Quad Core model: Intel Core i5-6600 bits: 64 type: MCP 
  arch: Skylake-S rev: 3 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26496 
  Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1747 2: 1675 
  3: 1495 4: 2138 
Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: eVga.com. 
  driver: nvidia v: 435.21 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.4 driver: fbdev,modesetting,nouveau 
  unloaded: vesa resolution: 640x480~73Hz 
  OpenGL: renderer: llvmpipe (LLVM 9.0 256 bits) v: 3.3 Mesa 19.2.8 
  direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio 
  vendor: Micro-Star MSI Sunrise Point-H driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 
  Device-2: NVIDIA GP107GL High Definition Audio vendor: eVga.com. 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.0.0-32-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 
  bus ID: 07:00.0 
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: 4c:cc:6a:66:82:eb 
Drives:
  Local Storage: total: 12.13 TiB used: 3.53 TiB (29.1%) 
  ID-1: /dev/sda type: USB vendor: Seagate model: Expansion Desk 
  size: 3.64 TiB 
  ID-2: /dev/sdb vendor: Western Digital model: WD60EZRZ-00GZ5B1 
  size: 5.46 TiB 
  ID-3: /dev/sdc vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
  ID-4: /dev/sdd vendor: Intel model: SSDSC2KW512G8 size: 476.94 GiB 
  ID-5: /dev/sdi type: USB vendor: Toshiba model: External USB 3.0 
  size: 1.82 TiB 
  ID-6: /dev/sdj type: USB vendor: Toshiba model: StorE HDD 
  size: 298.09 GiB 
Partition:
  ID-1: / size: 468.45 GiB used: 13.08 GiB (2.8%) fs: ext4 dev: /dev/sdd1 
Sensors:
  System Temperatures: cpu: 21.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 222 Uptime: 2m Memory: 15.62 GiB used: 991.1 MiB (6.2%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 

Any ideas on what I should do?
Last edited by SeanIE on Tue Apr 07, 2020 6:51 am, edited 2 times in total.
User avatar
Pjotr
Level 23
Level 23
Posts: 18104
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland) 🇳🇱
Contact:

Re: Stuck in 640 X 480 with no hardware acceleration.

Post by Pjotr »

Try this:

Update your system to the latest kernel of the 5.3 series (should be a regular update), reboot and test a newer driver from the reliable graphics-drivers PPA:
https://easylinuxtipsproject.blogspot.c ... a.html#ID1
(item 1)
Tip: 10 things to do after installing Linux Mint 21 Vanessa
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.
SeanIE
Level 1
Level 1
Posts: 8
Joined: Thu Mar 26, 2020 1:31 pm

Re: Stuck in 640 X 480 with no hardware acceleration.

Post by SeanIE »

Thanks for that :)

I wasn't able to do a kernel update, after running some relevant apt upgrade/update commands the system did some updates but still reports kernel 5.0. But what seems to have solved the problem (fingers crossed that it works properly this time) was that page:

https://launchpad.net/~graphics-drivers ... ubuntu/ppa

Somewhere on that page was a recommendation that I use the Version 390 drivers with a GF1XX card (GeForce 1050 Ti has a GF107) and I did not even need to use the PPA, the driver manager had the 390 drivers as an option. I had been trying to use the newer drivers, 440 in the past but for some reason the older one works better. It worked, and so far, is continuing to work. :o

Fingers crossed that this resolves the problem permanently.

Edit on April 6th: I've been testing on and off and began using Mint as my "daily driver" OS a few days ago. It's working. I have no idea why reverting to older drivers resolved the problem, but I will probably just live with it for the remainder of the time I'm using my current computer.
Post Reply

Return to “Beginner Questions”