on 18.1 Chrome and Vivaldi fail to load https:// sites

Questions about applications and software
Forum rules
Before you post please read how to get help
Post Reply
tmay2
Level 1
Level 1
Posts: 9
Joined: Sun Mar 22, 2020 10:24 pm

on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by tmay2 »

I am somewhat newbie. Using 18.1Cinnamon I loaded Vivaldi from the current Deb . Program booted fine but it does not allow any web pages to load that are https:// I only know of one site that is old http:// and it loads fine. When a URL points to any website with commonplace https:// echoed into the address bar then the bar turns reddish and a small "i" appears on the left end which is clickable.
It opens a dialog stating "your connection is not secure" and links are offered to "site settings" . I toggled all the settings to "allow" and it makes no difference to behavior. I found equally that Chrome version 73.0 installed from a deb in 2019 has the same failure to load https:// sites. I downloaded and installed Chrome ver 83 current and it does the same
First is there anyone reading this list who has Mint 18.$ installed who has successfullyt installed current Chrome or Vivaldi witth no problem?
In each case I have installed from "debi" package manager. It is interesting that I can view the addition of each of the CHrome installs in the synaptic database of software ....but the Vivaldi install from Debi does not show up (I guess because NO version of Vivaldi was ever in the repository at ubuntu)
Second: Some how I think this is some common library item in 18.$ that is affecting both vivaldi and Chrome?
I feel unable to diagnose and correct that but I'm ready to be led by the (virtual) hand of anyone willing
TMay

User avatar
karlchen
Level 20
Level 20
Posts: 12259
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by karlchen »

Hello, tmay2.

https connections not working in 2 different browsers?! Linux Mint 18.1?! - Hm. I could imagine that you have missed a certificate update or two perhaps?
Linux Mint 18.1 still permitted excluding relevant software updates, based on some funny numbering schema.
Greedy as it is, this Linux Mint system here has always accepted all software updates, levels [1] through to [5].
Neither Firefox 74, nor Pale Moon 28.9.0.2 rejects any website, merely because it requests to be accessed via https. If they did I would not be able to log in to this forum.

Please, open a terminal window. Execute sudo apt-get update. Next execute apt list --upgradable and post the complete text output, which the command will display here.

Best regards,
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

tmay2
Level 1
Level 1
Posts: 9
Joined: Sun Mar 22, 2020 10:24 pm

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by tmay2 »

Thank you for helping me understand how to pinpoint if an update problem is the root cause
Hope the following directory structure and OUTPUT can help
Here is the tree of " etc/apt" I dont understand why "sources.list" stays at 1 byte . I hope to understand the folder "sources.list.d" which seems to support some daemon process for synaptic. I am using firefox which is uptodate ver74 which seems to get regular update on its own (outside of apt). I used "debi" to add debs for recent Chrome 78 and 83 and for vivaldi Vivald 2.11. and I see how each program has added a "FILE.list" to folder "sources.list.d"

Code: Select all

ty@ty-elite /etc/apt $ ls -l
total 80
drwxr-xr-x 2 root root  4096 Mar 25  2017 apt.conf.d
drwxr-xr-x 2 root root  4096 Mar 27 16:10 backup.sources.ld
drwxr-xr-x 2 root root  4096 Dec 13  2016 preferences.d
-rw-r--r-- 1 root root     1 Mar 26  2017 sources.list
-rw-r--r-- 1 root root    93 Mar  9  2017 sources.list~
drwxr-xr-x 2 root root  4096 Mar 27 16:10 sources.list.d
-rw-r--r-- 1 root root 26420 Mar 25 23:30 trusted.gpg
-rw-r--r-- 1 root root 24172 Mar 25 23:30 trusted.gpg~
drwxr-xr-x 2 root root  4096 Apr 14  2016 trusted.gpg.d
ty@ty-elite /etc/apt $ cd sou*d
ty@ty-elite /etc/apt/sources.list.d $ ls -l
total 16
-rw-r--r-- 1 root root   0 Mar 19 23:37 additional-repositories.list
-rw-r--r-- 1 root root 189 May 12  2018 google-chrome.list
-rw-r--r-- 1 root root 189 Mar 26 20:43 google-chrome-unstable.list
-rw-r--r-- 1 root root 479 Mar 26 16:37 official-package-repositories.list
-rw-r--r-- 1 root root 173 Mar 27 15:36 vivaldi.list
OUTPUT of sudo apt-get update is 40 lines
I notice these "ignore" lines but "Ign" should stand for my ignorance interpret:
Ign:9 http://repo.vivaldi.com/stable/deb stable InRelease
Hit:10 http://repo.vivaldi.com/stable/deb stable Release

Code: Select all

ty@ty-elite /etc/apt/sources.list.d $ sudo apt-get update
[sudo] password for ty: 
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:3 http://dl.google.com/linux/chrome/deb stable Release                     
Ign:4 http://packages.linuxmint.com serena InRelease                           
Hit:5 http://archive.ubuntu.com/ubuntu xenial InRelease                        
Hit:6 http://archive.canonical.com/ubuntu xenial InRelease                     
Hit:7 http://packages.linuxmint.com serena Release                             
Hit:8 http://archive.ubuntu.com/ubuntu xenial-updates InRelease         
Ign:9 http://repo.vivaldi.com/stable/deb stable InRelease
Hit:10 http://repo.vivaldi.com/stable/deb stable Release
Hit:12 http://archive.ubuntu.com/ubuntu xenial-backports InRelease
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
ty@ty-elite /etc/apt/sources.list.d $ sudo apt-get update
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Ign:2 http://packages.linuxmint.com serena InRelease                           
Hit:3 http://archive.canonical.com/ubuntu xenial InRelease                     
Hit:4 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:5 http://packages.linuxmint.com serena Release                             
Hit:6 http://archive.ubuntu.com/ubuntu xenial InRelease                        
Hit:7 http://security.ubuntu.com/ubuntu xenial-security InRelease              
Hit:10 http://archive.ubuntu.com/ubuntu xenial-updates InRelease         
Hit:11 http://archive.ubuntu.com/ubuntu xenial-backports InRelease       
Ign:12 http://repo.vivaldi.com/stable/deb stable InRelease               
Hit:13 http://repo.vivaldi.com/stable/deb stable Release
Reading package lists... Done 
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/google-chrome-unstable.list:3 and /etc/apt/sources.list.d/google-chrome.list:3
ty@ty-elite /etc/apt/sources.list.d $ 

OUTPUT of apt list --upgradable is 800 lines so I have copied clips for "apt", certificates. firefox, chrome and vivaldi

Code: Select all

ty@ty-elite /etc/apt/sources.list.d $ apt list --upgradable
Listing... Done
adobe-flashplugin/xenial 1:20200311.1-0ubuntu0.16.04.1 amd64 [upgradable from: 1:20170509.1-0ubuntu0.16.04.1]
apt/xenial-updates 1.2.32 amd64 [upgradable from: 1.2.17]
apt-transport-https/xenial-updates 1.2.32 amd64 [upgradable from: 1.2.17]
apt-utils/xenial-updates 1.2.32 amd64 [upgradable from: 1.2.17]
apt-xapian-index/xenial-updates,xenial-updates 0.47ubuntu8.4 all [upgradable from: 0.47ubuntu8.3]
aptdaemon/xenial-updates,xenial-updates,xenial-security,xenial-security 1.1.1+bzr982-0ubuntu14.2 all [upgradable from: 1.1.1+bzr982-0ubuntu14]
aptdaemon-data/xenial-updates,xenial-updates,xenial-security,xenial-security 1.1.1+bzr982-0ubuntu14.2 all [upgradable from: 1.1.1+bzr982-0ubuntu14]
 CERTIFICATE CLIP
ca-certificates/xenial-updates,xenial-updates 20170717~16.04.2 all [upgradable from: 20160104ubuntu1]
ca-certificates-java/xenial-updates,xenial-updates 20160321ubuntu1 all [upgradable from: 20160321]
chromium-codecs-ffmpeg-extra/xenial-updates,xenial-security 80.0.3987.87-0ubuntu0.16.04.1 amd64 [upgradable from: 58.0.3029.96-0ubuntu0.16.04.1279]
FIREFOX CLIP
firefox/serena 74.0+linuxmint2+sylvia amd64 [upgradable from: 54.0+linuxmint2+sonya]
firefox-locale-en/serena 74.0+linuxmint2+sylvia amd64 [upgradable from: 50.0.2+linuxmint1+serena]
GOOGLE
gnupg2/xenial-updates,xenial-security 2.1.11-6ubuntu2.1 amd64 [upgradable from: 2.1.11-6ubuntu2]
google-chrome-stable/stable 80.0.3987.149-1 amd64 [upgradable from: 78.0.3904.108-1]
VIVALDI  No entry
uuid-runtime/xenial-updates 2.27.1-6ubuntu3.10 amd64 [upgradable from: 2.27.1-6ubuntu3.1]
vim-common/xenial-updates,xenial-security 2:7.4.1689-3ubuntu1.4 amd64 [upgradable from: 2:7.4.1689-3ubuntu1.2]
Thankyou Tmay

User avatar
karlchen
Level 20
Level 20
Posts: 12259
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by karlchen »

Hello, tmay2.

Please, disable the software sources file google-chrome-unstable.list
It holds the same entries as the software sources file /etc/apt/sources.list.d/google-chrome.list
Commandline to disable the file google-chrome-unstable.list:
sudo mv /etc/apt/sources.list.d/google-chrome-unstable.list /etc/apt/sources.list.d/google-chrome-unstable.list.save

Next execute sudo apt-get update again.

Finally execute the command sudo apt-get upgrade When asked whether you want to install all the (800) updates, please, press y(es).
Once all the updates have been installed (successfully) you will have to reboot the machine.

Good luck.
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

tmay2
Level 1
Level 1
Posts: 9
Joined: Sun Mar 22, 2020 10:24 pm

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by tmay2 »

I did the upgrade and a restart
he upgrade did march through 858 tasks with get and then starting processing triggers and "settingup"

HERE IS CLIP TRANSITION FROM LAST LOAD nuber 850+ and startubsection on triggers

Code: Select all

Get:854 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 python-aptdaemon.gtk3widgets all 1.1.1+bzr982-0ubuntu14.2 [13.8 kB]
Get:855 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 python-aptdaemon all 1.1.1+bzr982-0ubuntu14.2 [76.6 kB]
Get:856 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 python3-louis all 2.6.4-2ubuntu0.4 [7,328 B]
Get:857 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 ruby2.3 amd64 2.3.1-2~ubuntu16.04.14 [40.8 kB]
Get:858 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 user-setup all 1.63ubuntu4.1 [192 kB] 
Fetched 620 MB in 2h 26min 6s (70.7 kB/s)                                                                
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 250884 files and directories currently installed.)
Preparing to unpack .../bash_4.3+linuxmint5_amd64.deb ...
Unpacking bash (4.3+linuxmint5) over (4.3+linuxmint4) ...
Processing triggers for install-info (6.1.0.dfsg.1-5) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up bash (4.3+linuxmint5) ...
HERE IS WHERE TRIGGERS ENDED AND COMPLAINED ABOUT LIBglib 2.0-0 NOT BEING CONFIGURED

If this type of processing is sequential for every upgraded deb then it should be noted tha tibglib was the upgrade task 96 and 97

Code: Select all

Get:96 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 libglib2.0-0 i386 2.48.2-0ubuntu4.6 [1,185 kB]
Get:97 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 libglib2.0-0 amd64 2.48.2-0ubuntu4.6 [1,120 kB]

Processing triggers for doc-base (0.10.7) ...
Processing 1 changed doc-base file...
Registering documents with scrollkeeper...
Processing triggers for man-db (2.7.5-1) ...
dpkg: dependency problems prevent processing triggers for desktop-file-utils:
 desktop-file-utils depends on libglib2.0-0 (>= 2.28.0); however:
  Package libglib2.0-0:amd64 is not configured yet.

dpkg: error processing package desktop-file-utils (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for desktop-file-utils:
 desktop-file-utils depends on libglib2.0-0 (>= 2.28.0); however:
  Package libglib2.0-0:amd64 is not configured yet.

dpkg: error processing package desktop-file-utils (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for desktop-file-utils:
 desktop-file-utils depends on libglib2.0-0 (>= 2.28.0); however:
  Package libglib2.0-0:amd64 is not configured yet.[/quote]

HERE IS WHERE UPGRADE GAVEUP  WITH  TOO MANY ERRORS AND ENDS
( Does that mean that some setting, triggering etc was left undone for some upgrades??)

[code]dpkg: error processing package desktop-file-utils (--configure):
 dependency problems - leaving triggers unprocessed
dpkg: too many errors, stopping
Errors were encountered while processing:
 desktop-file-utils
 desktop-file-utils
 desktop-file-utils
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)
ty@ty-elite /etc/apt $ 
Thanks for the education Im getting Tmay

tmay2
Level 1
Level 1
Posts: 9
Joined: Sun Mar 22, 2020 10:24 pm

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by tmay2 »

After the sudo apt-get upgrade described in above post both Vivaldi and Chrome83 still behave similar:
they do not display any webpage with HTTPS://
The addressbar "i" icon opens the dialog "your connection is not secure"
If I navigate to site settings and "All Sites" and Click
Privacy Security > Manage Certificates
The program vanishes as a process (both Vivaldi and CHrome)
My crude guess it seems to be some still missing or defective common library item
and I dont understand configurations or triggers in an upgrade

during upgrade output here is the only line for "chrome " and no line contains "vivaldi"
Line 38 gnupg2 google-chrome-stable gpgv grub-common grub-pc grub-pc-bin grub2-common gstreamer0.10-alsa
Line 160 Get:1 http://dl.google.com/linux/chrome/deb stable/main amd64 google-chrome-stable amd64 80.0.3987.149-1 [63.1 MB]

Thanks TMay

User avatar
karlchen
Level 20
Level 20
Posts: 12259
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by karlchen »

Hello, tmay2.

Sorry to learn that the sudo apt-get upgrade failed to finish successfully.
Without being able to go through the whole file /var/log/apt/term.log, where apt-get logged all steps and all messages, I will have to assume that this is the first error, which apt-get could not resolve and where it gave up:

Code: Select all

dpkg: dependency problems prevent processing triggers for desktop-file-utils:
desktop-file-utils depends on libglib2.0-0 (>= 2.28.0); however:
Package libglib2.0-0:amd64 is not configured yet.
Please execute the terminal command dpkg --list desktop-file-utils libglib2.0* andpost the complete text output, which it will display in the terminal window. dpkg will reveal the current status of the matching packages. This will hopefully help decide how to resolve the problem.

Regards,
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

tmay2
Level 1
Level 1
Posts: 9
Joined: Sun Mar 22, 2020 10:24 pm

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by tmay2 »

Here is output:

Code: Select all

ty@ty-elite /etc/apt $ dpkg --list desktop-file-utils libglib2.0*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
it  desktop-file-u 0.22-1ubuntu amd64        Utilities for .desktop files
iU  libglib2.0-0:a 2.48.2-0ubun amd64        GLib library of C routines
iU  libglib2.0-0:i 2.48.2-0ubun i386         GLib library of C routines
iU  libglib2.0-bin 2.48.2-0ubun amd64        Programs for the GLib library
ii  libglib2.0-cil 2.12.10-6    amd64        CLI binding for the GLib utility 
iU  libglib2.0-dat 2.48.2-0ubun all          Common files for GLib library
ty@ty-elite /etc/apt $ 
ty@ty-elite /etc/apt $ 
The status seems to be something about still not configured paraphrased as
not installed configuration files , or just half unpacked and awaiting something
but clearly reinstall required

Question1 of many:
Are there multiple other packages that completed initial get but have NOT been configured because the libglib2 error?
Question 2 of many
Does the role of libglib2 relate directly to anything about certificate setup and hangling in Vivaldi and CHrome?
Thanks Tmay

User avatar
karlchen
Level 20
Level 20
Posts: 12259
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by karlchen »

Hi, tmay2.

I suggest to try the following steps in order resolve the problem related to desktop-file-utils and the libglib2.0 packages:
  1. sudo dpkg --configure -a (pay attention to the 2 space characters and to --configure, but -a, once a double dash, next a single dash)
    If we are lucky, dpkg simply succeeds in configuring the packages.
  2. Checking success or defeat: dpkg --list desktop-file-utils libglib2.0*
    If all packages have got the status "ii", then dpkg was successful.
  3. In case dpkg was not successful, and only in this case, try to re-install the packages:
    sudo apt-get --reinstall install libglib2.0-0 libglib2.0-bin libglib2.0-data desktop-file-utils
  4. Checking success or defeat: dpkg --list desktop-file-utils libglib2.0*
    If all packages have got the status "ii", then re-installation was successful.
  5. In this case and only in this case run sudo dpkg --configure -a (again). It cannot do any harm, but it can repair some.
In order not to make the decision tree to complex, I will stop here and wait for the result.

About your 2 questions:
Are there multiple other packages that completed initial get but have NOT been configured because the libglib2 error?
Not sure. As stated in my previous post: I cannot inspect your file /var/log/apt/term.log. So I cannot get a complete picture.
Does the role of libglib2 relate directly to anything about certificate setup and hangling in Vivaldi and CHrome?
Not sure. I do not know all the direct and indirect dependencies, which Vivaldi and Chrome depend on.

But I know we have a sudo apt-get upgrade which aborted somewhere in the middle, leavin behind an unknown state and apparently some inconsistencies. This should not be ignored. You are not really keen on replacing the Vivaldi / Chrome problems by some other problems, which may be even more serious.

Best regards,
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

tmay2
Level 1
Level 1
Posts: 9
Joined: Sun Mar 22, 2020 10:24 pm

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by tmay2 »

Here are "libglib lines from the 160 line output
Setting up libglib2.0-0:amd64 (2.48.2-0ubuntu4.6) ...
Setting up libglib2.0-0:i386 (2.48.2-0ubuntu4.6) .
>multiple lines
Setting up libglib2.0-data (2.48.2-0ubuntu4.6) ...
more lines>
Setting up libglib2.0-bin (2.48.2-0ubuntu4.6) ...

CLIP from END of output sudo dpkg --configure -a
offers warning but no error:

Code: Select all

Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Setting up python (2.7.12-1~16.04) ...
Processing triggers for libc-bin (2.23-0ubuntu11) ...
Processing triggers for initramfs-tools (0.122ubuntu8.16) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
Warning: No support for locale: en_US.utf8
ty@ty-elite /etc/apt $ 

Code: Select all

ty@ty-elite /etc/apt $ dpkg --list desktop-file-utils libglib2.0*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  desktop-file-u 0.22-1ubuntu amd64        Utilities for .desktop files
ii  libglib2.0-0:a 2.48.2-0ubun amd64        GLib library of C routines
ii  libglib2.0-0:i 2.48.2-0ubun i386         GLib library of C routines
ii  libglib2.0-bin 2.48.2-0ubun amd64        Programs for the GLib library
ii  libglib2.0-cil 2.12.10-6    amd64        CLI binding for the GLib utility 
ii  libglib2.0-dat 2.48.2-0ubun all          Common files for GLib library
ty@ty-elite /etc/apt $ ^C
ty@ty-elite /etc/apt $ 
Thanks for the cookbook and i look forward to understanding the Chefs kitchen
Tmay

User avatar
karlchen
Level 20
Level 20
Posts: 12259
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by karlchen »

Hi, Tmay.

Actually, the results, which the commands displayed, look good. :) (Relief)

The warning in the 3rd line below is harmless. It may be safely ignored. Though it is possible to fix the cause as well. But doing so has got low priority.

Code: Select all

Processing triggers for initramfs-tools (0.122ubuntu8.16) ...
update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
Warning: No support for locale: en_US.utf8
I wonder whether there are still updates waiting to be installed.

Please, execute apt list --upgradable
In case the command comes back empty, no more updates need to be installed at the moment.
In case apt list --upgradable displays upgradable software packages, please, execute the command sudo apt-get upgrade again. If you execute the command, please, post what it displays in the terminal window.

Best regards,
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

tmay2
Level 1
Level 1
Posts: 9
Joined: Sun Mar 22, 2020 10:24 pm

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by tmay2 »

Yeah it worked
apt list --upgradable logged 648 lines, none with the word "libglib" conquered previously
I was worried about another big update run since my laptop is stuck at 70kBS but it was only about 15min
for sudo apt-get upgrade 2762 lines of output. Many updates must have been done in the first run of update.
Vivaldi anc Chrome now work with https:// sites
I have sort of avoided updates thinking to leave well enough alone and vivaldi was just one program I wanted out of the repositories.
I now feel REFRESHED but I wonder what security hole I may have been exposed to without updates for so long?

In the output of "upgrade" toward the end there is a whole section of certificate processing:

Code: Select all

update-initramfs: Generating /boot/initrd.img-4.4.0-53-generic
Warning: No support for locale: en_US.utf8
Processing triggers for ca-certificates (20170717~16.04.2) ...
Updating certificates in /etc/ssl/certs...
WARNING: Skipping duplicate certificate UbuntuOne-Go_Daddy_Class_2_CA.pem
WARNING: Skipping duplicate certificate UbuntuOne-Go_Daddy_Class_2_CA.pem
17 added, 42 removed; done.
Running hooks in /etc/ca-certificates/update.d...

Adding debian:AC_RAIZ_FNMT-RCM.pem
Adding debian:Amazon_Root_CA_1.pem
Adding debian:Amazon_Root_CA_2.pem
Adding debian:Amazon_Root_CA_3.pem
Adding debian:Amazon_Root_CA_4.pem
Adding debian:Certplus_Root_CA_G1.pem
Adding debian:Certplus_Root_CA_G2.pem
Adding debian:Certum_Trusted_Network_CA_2.pem
Adding debian:Hellenic_Academic_and_Research_Institutions_ECC_RootCA_2015.pem
Adding debian:Hellenic_Academic_and_Research_Institutions_RootCA_2015.pem
Adding debian:ISRG_Root_X1.pem
Adding debian:LuxTrust_Global_Root_2.pem
Adding debian:OpenTrust_Root_CA_G1.pem
Adding debian:OpenTrust_Root_CA_G2.pem
Adding debian:OpenTrust_Root_CA_G3.pem
Adding debian:SZAFIR_ROOT_CA2.pem
Adding debian:TUBITAK_Kamu_SM_SSL_Kok_Sertifikasi_-_Surum_1.pem
Removing debian:AC_Raíz_Certicámara_S.A..pem
Removing debian:ApplicationCA_-_Japanese_Government.pem
Removing debian:Buypass_Class_2_CA_1.pem
Removing debian:CA_Disig.pem
Removing debian:CA_WoSign_ECC_Root.pem
Removing debian:Certification_Authority_of_WoSign_G2.pem
Removing debian:ComSign_CA.pem
Removing debian:EBG_Elektronik_Sertifika_Hizmet_Sağlayıcısı.pem
Removing debian:Equifax_Secure_CA.pem
Removing debian:Equifax_Secure_Global_eBusiness_CA.pem
Removing debian:Equifax_Secure_eBusiness_CA_1.pem
Removing debian:IGC_A.pem
Removing debian:Juur-SK.pem
Removing debian:Microsec_e-Szigno_Root_CA.pem
Removing debian:NetLock_Business_=Class_B=_Root.pem
Removing debian:NetLock_Express_=Class_C=_Root.pem
Removing debian:NetLock_Notary_=Class_A=_Root.pem
Removing debian:NetLock_Qualified_=Class_QA=_Root.pem
Removing debian:RSA_Security_2048_v3.pem
Removing debian:Root_CA_Generalitat_Valenciana.pem
Removing debian:S-TRUST_Authentication_and_Encryption_Root_CA_2005_PN.pem
Removing debian:S-TRUST_Universal_Root_CA.pem
Removing debian:Sonera_Class_1_Root_CA.pem
Removing debian:Staat_der_Nederlanden_Root_CA.pem
Removing debian:StartCom_Certification_Authority.pem
Removing debian:StartCom_Certification_Authority_2.pem
Removing debian:StartCom_Certification_Authority_G2.pem
Removing debian:SwissSign_Platinum_CA_-_G2.pem
Removing debian:TC_TrustCenter_Class_3_CA_II.pem
Removing debian:TÜRKTRUST_Elektronik_Sertifika_Hizmet_Sağlayıcısı_H6.pem
Removing debian:UTN_USERFirst_Email_Root_CA.pem
Removing debian:Verisign_Class_1_Public_Primary_Certification_Authority.pem
Removing debian:Verisign_Class_1_Public_Primary_Certification_Authority_-_G2.pem
Removing debian:Verisign_Class_1_Public_Primary_Certification_Authority_-_G3.pem
Removing debian:Verisign_Class_2_Public_Primary_Certification_Authority_-_G2.pem
Removing debian:Verisign_Class_2_Public_Primary_Certification_Authority_-_G3.pem
Removing debian:Verisign_Class_3_Public_Primary_Certification_Authority.pem
Removing debian:Verisign_Class_3_Public_Primary_Certification_Authority_-_G2.pem
Removing debian:Verisign_Class_3_Public_Primary_Certification_Authority_2.pem
Removing debian:WellsSecure_Public_Root_Certificate_Authority.pem
Removing debian:WoSign.pem
Removing debian:WoSign_China.pem
done.
done.
Processing triggers for systemd (229-4ubuntu21.27) ...
Processing triggers for vlc-nox (2.2.2-5ubuntu0.16.04.4) ...
Processing triggers for resolvconf (1.78ubuntu7) ...
Processing triggers for dictionaries-common (1.26.3) ...
Processing triggers for dbus (1.10.6-1ubuntu3.5) ...
ty@ty-elite /etc/apt $

A repeat run of apt list -upgradable still shows a list (when to stop?)

Code: Select all

ty@ty-elite ~ $ apt list --upgradable
Listing... Done
cinnamon-screensaver/serena,serena 3.2.13+serena all [upgradable from: 3.2.9+serena]
cups-filters/xenial-updates,xenial-security 1.8.3-2ubuntu3.5 amd64 [upgradable from: 1.8.3-2ubuntu3.1]
cups-filters-core-drivers/xenial-updates,xenial-security 1.8.3-2ubuntu3.5 amd64 [upgradable from: 1.8.3-2ubuntu3.1]
libdrm-amdgpu1/xenial-updates 2.4.91-2~16.04.1 amd64 [upgradable from: 2.4.67-1ubuntu0.16.04.2]
libdrm2/xenial-updates 2.4.91-2~16.04.1 amd64 [upgradable from: 2.4.67-1ubuntu0.16.04.2]
libegl1-mesa/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
libgbm1/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
libgl1-mesa-dri/xenial-updates 18.0.5-0ubuntu0~16.04.1 i386 [upgradable from: 11.2.0-1ubuntu2.2]
libgl1-mesa-glx/xenial-updates 18.0.5-0ubuntu0~16.04.1 i386 [upgradable from: 11.2.0-1ubuntu2.2]
libglapi-mesa/xenial-updates 18.0.5-0ubuntu0~16.04.1 i386 [upgradable from: 11.2.0-1ubuntu2.2]
libgles2-mesa/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
libinput10/xenial-updates 1.6.3-1ubuntu1~16.04.1 amd64 [upgradable from: 1.2.3-1ubuntu1]
libjavascriptcoregtk-4.0-18/xenial-updates,xenial-security 2.20.5-0ubuntu0.16.04.1 amd64 [upgradable from: 2.12.5-0ubuntu0.16.04.1]
libmirclient9/xenial-updates,xenial-security 0.26.3+16.04.20170605-0ubuntu1.1 amd64 [upgradable from: 0.21.0+16.04.20160330-0ubuntu1]
libqmi-proxy/xenial-updates 1.16.2-1ubuntu0.16.04.1 amd64 [upgradable from: 1.12.6-1]
libwayland-egl1-mesa/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
libwebkit2gtk-4.0-37/xenial-updates,xenial-security 2.20.5-0ubuntu0.16.04.1 amd64 [upgradable from: 2.12.5-0ubuntu0.16.04.1]
libxatracker2/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
modemmanager/xenial-updates 1.6.4-1ubuntu0.16.04.1 amd64 [upgradable from: 1.4.12-1ubuntu1]
pix/serena 2.4.5+sarah amd64 [upgradable from: 1.2.1+serena]
pix-data/serena,serena 2.4.5+sarah all [upgradable from: 1.2.1+serena]
qpdf/xenial-updates,xenial-security 8.0.2-3~16.04.1 amd64 [upgradable from: 6.0.0-2]
shotwell/xenial-updates,xenial-security 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1.1 amd64 [upgradable from: 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1]
shotwell-common/xenial-updates,xenial-updates,xenial-security,xenial-security 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1.1 all [upgradable from: 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1]
ubuntu-minimal/xenial-updates 1.361.4 amd64 [upgradable from: 1.361]
ty@ty-elite ~ $ 
so I have witnessed how repeated runs of "list upgradeable" and apt-get upgrade can divide and conquer overdue upgrades
And the dpkg can do redundant runs with ==configure option
What library or configuration event in all of this upgrading do you think made the difference for both vivaldi and chrome?
Thankyou for all your help
Tmay
Last edited by karlchen on Sun Mar 29, 2020 7:07 am, edited 1 time in total.
Reason: added [c] [/c] tags around single line commands and [code] [/code] tags around the multiline commands and their screen output

User avatar
karlchen
Level 20
Level 20
Posts: 12259
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: on 18.1 Chrome and Vivaldi fail to load https:// sites

Post by karlchen »

Hello, Tmay.

Great to learn that your Vivaldi and Chrome browsers have been returned to normal operation again. :D
I assume that the most important upgrade in this respect will have been the list of certificates, where outdated certificates have been removed and new ones installed.
Yet, other software updates may have been required as well in order to achieve this goal.

On the list of still pending software updates:

Code: Select all

ty@ty-elite ~ $ apt list --upgradable
Listing... Done
cinnamon-screensaver/serena,serena 3.2.13+serena all [upgradable from: 3.2.9+serena]
cups-filters/xenial-updates,xenial-security 1.8.3-2ubuntu3.5 amd64 [upgradable from: 1.8.3-2ubuntu3.1]
cups-filters-core-drivers/xenial-updates,xenial-security 1.8.3-2ubuntu3.5 amd64 [upgradable from: 1.8.3-2ubuntu3.1]
libdrm-amdgpu1/xenial-updates 2.4.91-2~16.04.1 amd64 [upgradable from: 2.4.67-1ubuntu0.16.04.2]
libdrm2/xenial-updates 2.4.91-2~16.04.1 amd64 [upgradable from: 2.4.67-1ubuntu0.16.04.2]
libegl1-mesa/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
libgbm1/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
libgl1-mesa-dri/xenial-updates 18.0.5-0ubuntu0~16.04.1 i386 [upgradable from: 11.2.0-1ubuntu2.2]
libgl1-mesa-glx/xenial-updates 18.0.5-0ubuntu0~16.04.1 i386 [upgradable from: 11.2.0-1ubuntu2.2]
libglapi-mesa/xenial-updates 18.0.5-0ubuntu0~16.04.1 i386 [upgradable from: 11.2.0-1ubuntu2.2]
libgles2-mesa/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
libinput10/xenial-updates 1.6.3-1ubuntu1~16.04.1 amd64 [upgradable from: 1.2.3-1ubuntu1]
libjavascriptcoregtk-4.0-18/xenial-updates,xenial-security 2.20.5-0ubuntu0.16.04.1 amd64 [upgradable from: 2.12.5-0ubuntu0.16.04.1]
libmirclient9/xenial-updates,xenial-security 0.26.3+16.04.20170605-0ubuntu1.1 amd64 [upgradable from: 0.21.0+16.04.20160330-0ubuntu1]
libqmi-proxy/xenial-updates 1.16.2-1ubuntu0.16.04.1 amd64 [upgradable from: 1.12.6-1]
libwayland-egl1-mesa/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
libwebkit2gtk-4.0-37/xenial-updates,xenial-security 2.20.5-0ubuntu0.16.04.1 amd64 [upgradable from: 2.12.5-0ubuntu0.16.04.1]
libxatracker2/xenial-updates 18.0.5-0ubuntu0~16.04.1 amd64 [upgradable from: 11.2.0-1ubuntu2.2]
modemmanager/xenial-updates 1.6.4-1ubuntu0.16.04.1 amd64 [upgradable from: 1.4.12-1ubuntu1]
pix/serena 2.4.5+sarah amd64 [upgradable from: 1.2.1+serena]
pix-data/serena,serena 2.4.5+sarah all [upgradable from: 1.2.1+serena]
qpdf/xenial-updates,xenial-security 8.0.2-3~16.04.1 amd64 [upgradable from: 6.0.0-2]
shotwell/xenial-updates,xenial-security 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1.1 amd64 [upgradable from: 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1]
shotwell-common/xenial-updates,xenial-updates,xenial-security,xenial-security 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1.1 all [upgradable from: 0.22.0+git20160108.r1.f2fb1f7-0ubuntu1]
ubuntu-minimal/xenial-updates 1.361.4 amd64 [upgradable from: 1.361]
ty@ty-elite ~ $ 
Personally I would recommend to install these updates as well and reboot in order to make sure that all updated software packages are really in use.
Yet, this is your decision.

For the future, I strongly recommend to revise your level settings in Linux Mint Update Manager.
I recommend to make all 5 levels visible in order to make sure that Update Manager will display all available software updates to you and that it will no longer hide them from your view.
I recommend to mark levels 1, 2 and 3 as safe for installation in order to make sure that those will be installed in future.
This still permits you to decide when to install the updates, which affect hardware drivers (level 4 usually) and kernel updates (level 5). Installing these updates separately would make troubleshooting easier, in case they should cause trouble.

Best regards,
Karl
Image
Linux Mint 19.2 64-bit Cinnamon, Total Commander 9.22a 64-bit
Haß gleicht einer Krankheit, dem Miserere, wo man vorne herausgibt, was eigentlich hinten wegsollte. (Goethe)

Post Reply

Return to “Software & Applications”